summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD13
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99b5671fabab..945289945421 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fetchcord-testing
pkgdesc = FetchCord grabs your OS info and displays it as Discord Rich Presence
pkgver = 2.7.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/MrPotatoBobx/fetchcord
install = fetchcord.install
arch = any
@@ -9,6 +9,8 @@ pkgbase = fetchcord-testing
depends = neofetch
depends = python-psutil
depends = python-setuptools
+ depends = python-pypresence
+ optdepends = systemd: SystemD user service
provides = fetchcord
source = fetchcord::git+https://github.com/MrPotatoBobx/fetchcord#branch=testing
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 01f4e5146a1f..5cdd7cb0d2c1 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,23 @@
pkgname=fetchcord-testing
pkgver=2.7.8
-pkgrel=1
+pkgrel=2
pkgdesc="FetchCord grabs your OS info and displays it as Discord Rich Presence"
arch=('any')
url="https://github.com/MrPotatoBobx/fetchcord"
license=('MIT')
depends=('python')
+optdepends=('systemd: SystemD user service')
provides=('fetchcord')
-depends=('neofetch' 'python-psutil' 'python-setuptools')
+depends=('neofetch' 'python-psutil' 'python-setuptools' 'python-pypresence')
source=("fetchcord::git+$url#branch=testing")
sha256sums=('SKIP')
install=fetchcord.install
-pkgver() {
- cd "$srcdir/fetchcord"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+#pkgver() {
+# cd "$srcdir/fetchcord"
+# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+#}
build() {
cd "$srcdir/fetchcord"