aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rwxr-xr-xfetcher.sh2
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4966c316948c..4c23bb29665f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = fetcher
- pkgdesc = Update a list of git repos
+ pkgdesc = Automatic adding, commiting, pushing or pulling of git repos. Easily adjustable in a config file à la "<repopath> <command> <remote> <refspec>". Also added the special command addcommitpush, which does all three at once.
pkgver = 1.0
- pkgrel = 0
+ pkgrel = 1
install = fetcher.install
arch = any
license = MIT
depends = git
source = fetcher.sh
source = fetcher.service
- md5sums = de164dec82476dcfc15efad1b9617792
+ md5sums = 5df683b5b96f5e83331ab071b0979613
md5sums = ac026457052512cfdb9ae12e100ea696
pkgname = fetcher
diff --git a/PKGBUILD b/PKGBUILD
index 07736b9641af..2ecc9a987f30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,11 @@
pkgname=fetcher
pkgver=1.0
-pkgrel=0
-pkgdesc="Update a list of git repos"
+pkgrel=1
+pkgdesc="Automatic adding, commiting, pushing or pulling of git repos.
+Easily adjustable in a config file à la \"<repopath> <command> <remote> <refspec>\".
+Also added the special command addcommitpush, which does all three at once.
+"
arch=('any')
url=""
license=('MIT')
@@ -13,7 +16,7 @@ install="$pkgname.install"
source=("fetcher.sh"
"fetcher.service")
noextract=()
-md5sums=('de164dec82476dcfc15efad1b9617792'
+md5sums=('5df683b5b96f5e83331ab071b0979613'
'ac026457052512cfdb9ae12e100ea696')
package() {
diff --git a/fetcher.sh b/fetcher.sh
index 25626dac53e8..a334906de135 100755
--- a/fetcher.sh
+++ b/fetcher.sh
@@ -94,7 +94,7 @@ for ((i=0; i < ${#lines[@]}; i++)); do
fi
case $gitcmd in
- push)
+ addcommitpush)
if $dryrun; then
cmd="git -C $path add -n -A"
cmd="$cmd && (git -C $path commit -n -v || true)"