summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b68cb8973105..e56ac5476b8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = feynhiggs
pkgdesc = FeynHiggs is a Fortran code for the (diagrammatic) calculation of the masses, mixings and much more of the Higgs bosons in the MSSM with real/complex parameters at the highest level of accuracy.
pkgver = 2.11.3
- pkgrel = 4
+ pkgrel = 5
url = http://wwwth.mpp.mpg.de/members/heinemey/feynhiggs/cFeynHiggs.html
arch = i686
arch = x86_64
- license = GPL
+ license = GPL3
depends = gcc-fortran
+ options = staticlibs
source = http://wwwth.mpp.mpg.de/members/heinemey/feynhiggs/newversion/FeynHiggs-2.11.3.tar.gz
sha256sums = 570746c34efbbfba45b39ea7110b0069354747138ad149204f09819548b87f6a
diff --git a/PKGBUILD b/PKGBUILD
index dd2b3ef8bd7b..4d593fc9d000 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,20 @@
_pkgname=FeynHiggs
pkgname=feynhiggs
pkgver=2.11.3
-pkgrel=4
+pkgrel=5
pkgdesc="FeynHiggs is a Fortran code for the (diagrammatic) calculation of the masses, mixings and much more of the Higgs bosons in the MSSM with real/complex parameters at the highest level of accuracy."
arch=("i686" "x86_64")
url="http://wwwth.mpp.mpg.de/members/heinemey/feynhiggs/cFeynHiggs.html"
-license=('GPL')
+license=('GPL3')
depends=("gcc-fortran")
+options=('staticlibs')
source=("http://wwwth.mpp.mpg.de/members/heinemey/feynhiggs/newversion/${_pkgname}-$pkgver.tar.gz")
sha256sums=('570746c34efbbfba45b39ea7110b0069354747138ad149204f09819548b87f6a')
build() {
cd "${_pkgname}-$pkgver"
./configure --prefix=/usr --enable-full-g-2 --enable-slhapara
- sed -i 's/LIBDIR = $(PREFIX)\/lib$(LIBDIRSUFFIX)/LIBDIR = $(PREFIX)\/lib/g' makefile
- sed -i 's/-mkdir/-mkdir -p/g' makefile
+ sed -i 's/LIBDIR = $(PREFIX)\/lib$(LIBDIRSUFFIX)/LIBDIR = $(PREFIX)\/lib/' makefile
make
}