summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81f50e772170
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Sep 4 15:02:56 UTC 2016
+pkgbase = ffhevc
+ pkgdesc = a small yet quite capable shell script for encoding video files to the H.265/HEVC video format using ffmpeg and libx265.
+ pkgver = 2.7.8
+ pkgrel = 1
+ url = https://sourceforge.net/projects/ffhevc/
+ arch = any
+ license = GPL2
+ depends = ffmpeg
+ depends = mplayer
+ source = http://downloads.sourceforge.net/project/ffhevc/ffhevc-2.7.8.tar.gz
+ md5sums = 41f152edafe7aac119c46bd322154398
+
+pkgname = ffhevc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65e34f6c6334
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+#Maintainer: Bhoppi Chaw <bhoppi#outlook,com>
+
+pkgname=ffhevc
+pkgver=2.7.8
+pkgrel=1
+pkgdesc='a small yet quite capable shell script for encoding video files to the H.265/HEVC video format using ffmpeg and libx265.'
+arch=(any)
+url='https://sourceforge.net/projects/ffhevc/'
+license=(GPL2)
+depends=(ffmpeg
+ mplayer)
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.gz")
+
+prepare()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e "s,/usr/local,$pkgdir/usr,g" -e '/^MANDIR=/s,/man/,/share/man/,' install
+}
+
+package()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ ./install
+ rm "$pkgdir/usr/share/doc/$pkgname/uninstall"
+}
+md5sums=('41f152edafe7aac119c46bd322154398')