summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03cbf06d19dd..5a8f8b15ec85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-git
pkgdesc = Complete solution to record, convert and stream audio and video (git version)
- pkgver = 6.1.r110336.g0dceda12e7
+ pkgver = 6.1.r111232.g468615f204
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -35,7 +35,6 @@ pkgbase = ffmpeg-git
depends = libgl
depends = libiec61883
depends = libjxl.so
- depends = libmfx
depends = libmodplug
depends = libopenmpt.so
depends = libpulse
@@ -53,7 +52,6 @@ pkgbase = ffmpeg-git
depends = libvorbisenc.so
depends = libvorbis.so
depends = libvpx.so
- depends = libvulkan.so
depends = libwebp
depends = libx11
depends = libx264.so
@@ -65,6 +63,7 @@ pkgbase = ffmpeg-git
depends = libxvidcore.so
depends = libzimg.so
depends = ocl-icd
+ depends = onevpl
depends = opencore-amr
depends = openjpeg2
depends = opus
@@ -74,12 +73,13 @@ pkgbase = ffmpeg-git
depends = svt-av1
depends = v4l-utils
depends = vmaf
+ depends = vulkan-icd-loader
depends = xz
depends = zlib
optdepends = avisynthplus: for AviSynthPlus support
- optdepends = intel-media-sdk: for Intel Quick Sync Video
optdepends = ladspa: for LADSPA filters
optdepends = nvidia-utils: for Nvidia NVDEC/NVENC support
+ optdepends = onevpl-intel-gpu: for Intel Quick Sync Video
provides = libavcodec.so
provides = libavdevice.so
provides = libavfilter.so
diff --git a/PKGBUILD b/PKGBUILD
index d38d6403a2fb..d653c80329d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=6.1.r110336.g0dceda12e7
+pkgver=6.1.r111232.g468615f204
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
arch=('x86_64')
@@ -31,7 +31,6 @@ depends=(
libgl
libiec61883
libjxl.so
- libmfx
libmodplug
libopenmpt.so
libpulse
@@ -49,7 +48,6 @@ depends=(
libvorbisenc.so
libvorbis.so
libvpx.so
- libvulkan.so
libwebp
libx11
libx264.so
@@ -61,6 +59,7 @@ depends=(
libxvidcore.so
libzimg.so
ocl-icd
+ onevpl
opencore-amr
openjpeg2
opus
@@ -70,6 +69,7 @@ depends=(
svt-av1
v4l-utils
vmaf
+ vulkan-icd-loader
xz
zlib
)
@@ -86,9 +86,9 @@ makedepends=(
vulkan-headers
)
optdepends=('avisynthplus: for AviSynthPlus support'
- 'intel-media-sdk: for Intel Quick Sync Video'
'ladspa: for LADSPA filters'
- 'nvidia-utils: for Nvidia NVDEC/NVENC support')
+ 'nvidia-utils: for Nvidia NVDEC/NVENC support'
+ 'onevpl-intel-gpu: for Intel Quick Sync Video')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libswresample.so' 'libswscale.so'
'ffmpeg')
@@ -141,7 +141,6 @@ build() {
--enable-libiec61883 \
--enable-libjack \
--enable-libjxl \
- --enable-libmfx \
--enable-libmodplug \
--enable-libmp3lame \
--enable-libopencore_amrnb \
@@ -162,6 +161,7 @@ build() {
--enable-libvidstab \
--enable-libvmaf \
--enable-libvorbis \
+ --enable-libvpl \
--enable-libvpx \
--enable-libwebp \
--enable-libx264 \