summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..134b3e026c89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ffmpeg-gpl-bin
+ pkgdesc = FFmpeg minimal for apps usage
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/BtbN/FFmpeg-Builds
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ provides = ffmpeg
+ conflicts = ffmpeg
+ source_x86_64 = https://github.com/BtbN/FFmpeg-Builds/releases/download/latest/ffmpeg-master-latest-linux64-gpl.tar.xz
+ md5sums_x86_64 = SKIP
+ source_aarch64 = https://github.com/BtbN/FFmpeg-Builds/releases/download/latest/ffmpeg-master-latest-linuxarm64-gpl.tar.xz
+ md5sums_aarch64 = SKIP
+
+pkgname = ffmpeg-gpl-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..15d58065bc40
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efab6001db84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: BlackCatDevel0per <bcdev@mail.ru>
+# https://github.com/BlackCatDevel0per
+
+pkgname=ffmpeg-gpl-bin
+pkgver=latest
+pkgrel=1
+pkgdesc="FFmpeg minimal for apps usage"
+arch=("x86_64" "aarch64")
+license=("GPL")
+url="https://github.com/BtbN/FFmpeg-Builds"
+provides=("ffmpeg")
+conflicts=("ffmpeg")
+
+source_x86_64=("https://github.com/BtbN/FFmpeg-Builds/releases/download/${pkgver}/ffmpeg-master-latest-linux64-gpl.tar.xz")
+source_aarch64=("https://github.com/BtbN/FFmpeg-Builds/releases/download/${pkgver}/ffmpeg-master-latest-linuxarm64-gpl.tar.xz")
+
+md5sums_x86_64=('SKIP')
+md5sums_aarch64=('SKIP')
+
+package() {
+ cd ${srcdir}/ffmpeg-master-$pkgver-linux*64-gpl
+
+ install -Dm 755 -t "$pkgdir/usr/bin" bin/ffmpeg bin/ffplay bin/ffprobe
+ install -Dm 755 -t "$pkgdir/usr/share/doc/ffmpeg" doc/* LICENSE.txt
+}
+