summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD5
3 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8883c64ed1a..0257d1970fe3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-ndi
pkgdesc = Complete solution to record, convert and stream audio and video with NDI restored and enabled
pkgver = 4.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://ffmpeg.org/
arch = x86_64
license = custom: nonfree and unredistributable
@@ -85,6 +85,7 @@ pkgbase = ffmpeg-ndi
source = libndi_newtek_common.h::https://framagit.org/tytan652/ffmpeg-ndi-patch/-/raw/master/libavdevice/libndi_newtek_common.h?inline=false
source = libndi_newtek_dec.c::https://framagit.org/tytan652/ffmpeg-ndi-patch/-/raw/master/libavdevice/libndi_newtek_dec.c?inline=false
source = libndi_newtek_enc.c::https://framagit.org/tytan652/ffmpeg-ndi-patch/-/raw/master/libavdevice/libndi_newtek_enc.c?inline=false
+ source = LICENSE
sha256sums = SKIP
sha256sums = 8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d
sha256sums = 960fd930955cd126e33c543eb5bf300fc050efdd4238626ee4aad2a50d353fa7
@@ -92,6 +93,7 @@ pkgbase = ffmpeg-ndi
sha256sums = 462e984a7cb3d0af17b0ea0eb2a010aee2f79a3e77c2055fdfd760163dd75fa4
sha256sums = 3c6dea7583d79911e9ea198c35b1b56830b85eea84e49d63c2d5c03af5210eca
sha256sums = 83cc714edc8d1c37ffabd2ee17960d6ed91a1d019bd43d01383f84eea28e4fbb
+ sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-ndi
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b0bb658ca78c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+This software is nonfree and unredistributable.
+
+The end-user must compile this software for himself in order to be allowed to use it.
+
+This software cannot be redistributed.
+
+This software cannot be used commercially.
+
+Due to the libraries used to compile this software, the resulting binaries and libraries are under a complex and restrictive license mix.
diff --git a/PKGBUILD b/PKGBUILD
index add4826b7bbc..3e358682e657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ffmpeg-ndi
pkgver=4.3.1
-pkgrel=1
+pkgrel=2
pkgdesc='Complete solution to record, convert and stream audio and video with NDI restored and enabled'
arch=(x86_64)
url=https://ffmpeg.org/
@@ -99,6 +99,7 @@ source=(
'libndi_newtek_common.h'::'https://framagit.org/tytan652/ffmpeg-ndi-patch/-/raw/master/libavdevice/libndi_newtek_common.h?inline=false'
'libndi_newtek_dec.c'::'https://framagit.org/tytan652/ffmpeg-ndi-patch/-/raw/master/libavdevice/libndi_newtek_dec.c?inline=false'
'libndi_newtek_enc.c'::'https://framagit.org/tytan652/ffmpeg-ndi-patch/-/raw/master/libavdevice/libndi_newtek_enc.c?inline=false'
+ LICENSE
)
sha256sums=(
SKIP
@@ -108,6 +109,7 @@ sha256sums=(
462e984a7cb3d0af17b0ea0eb2a010aee2f79a3e77c2055fdfd760163dd75fa4
3c6dea7583d79911e9ea198c35b1b56830b85eea84e49d63c2d5c03af5210eca
83cc714edc8d1c37ffabd2ee17960d6ed91a1d019bd43d01383f84eea28e4fbb
+ 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
)
pkgver() {
@@ -192,6 +194,7 @@ build() {
package() {
make DESTDIR="${pkgdir}" -C ffmpeg install install-man
install -Dm 755 ffmpeg/tools/qt-faststart "${pkgdir}"/usr/bin/
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: