summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a0d286f7ed7..81955578d97e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = ffmt-bin
pkgdesc = FFXIV_Modding_Tool (FFMT for short) is a crossplatform commandline interface for Final Fantasy XIV Modding.
- pkgver = 0.9.2
- pkgrel = 1
+ pkgver = 0.9.3
+ pkgrel = 2
url = https://ffmt.pwd.cat/docs/
arch = i686
arch = x86_64
license = GNU General Public License v3.0
- depends = mono
- source = https://github.com/fosspill/FFXIV_Modding_Tool/releases/download/v0.9.2/FFXIV_Modding_Tool.zip
- sha256sums = 9f25c300ff3d9854eac87b9d012a3fb14b8a4ee9a2d1c55116a98f0158ff3d90
+ depends = dotnet-runtime
+ source = https://github.com/fosspill/FFXIV_Modding_Tool/releases/download/v0.9.3/FFXIV_Modding_Tool.zip
+ sha256sums = bc0c66ac7a44e892de16597b300a9933f195b4822230cf9658ea29a44f963046
pkgname = ffmt-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2f232e3b77db..f8ba4cad1cba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
pkgname="ffmt-bin"
fullpkgname="FFXIV_Modding_Tool"
-pkgver="0.9.2"
-pkgrel="1"
+pkgver="0.9.3"
+pkgrel="2"
pkgdesc="FFXIV_Modding_Tool (FFMT for short) is a crossplatform commandline interface for Final Fantasy XIV Modding."
arch=('i686' 'x86_64')
url="https://ffmt.pwd.cat/docs/"
license=("GNU General Public License v3.0")
-depends=("mono")
+depends=("dotnet-runtime")
source=("https://github.com/fosspill/FFXIV_Modding_Tool/releases/download/v${pkgver}/FFXIV_Modding_Tool.zip")
-sha256sums=("9f25c300ff3d9854eac87b9d012a3fb14b8a4ee9a2d1c55116a98f0158ff3d90")
+sha256sums=("bc0c66ac7a44e892de16597b300a9933f195b4822230cf9658ea29a44f963046")
package() {
cd $srcdir
install -dm755 ${fullpkgname}/ffmt "${pkgdir}/opt/ffmt"
- install -Dm755 ${fullpkgname}/ffmt/* "${pkgdir}/opt/ffmt/"
+ #install -Dm755 ${fullpkgname}/ffmt/* "${pkgdir}/opt/ffmt/"
+ cp -r ${fullpkgname}/ffmt/* "${pkgdir}/opt/ffmt/"
install -Dm755 ${fullpkgname}/ffmt.sh "${pkgdir}/usr/bin/ffmt"
}