summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a0d286f7ed7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ffmt-bin
+ pkgdesc = FFXIV_Modding_Tool (FFMT for short) is a crossplatform commandline interface for Final Fantasy XIV Modding.
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://ffmt.pwd.cat/docs/
+ arch = i686
+ arch = x86_64
+ license = GNU General Public License v3.0
+ depends = mono
+ source = https://github.com/fosspill/FFXIV_Modding_Tool/releases/download/v0.9.2/FFXIV_Modding_Tool.zip
+ sha256sums = 9f25c300ff3d9854eac87b9d012a3fb14b8a4ee9a2d1c55116a98f0158ff3d90
+
+pkgname = ffmt-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f232e3b77db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname="ffmt-bin"
+fullpkgname="FFXIV_Modding_Tool"
+pkgver="0.9.2"
+pkgrel="1"
+pkgdesc="FFXIV_Modding_Tool (FFMT for short) is a crossplatform commandline interface for Final Fantasy XIV Modding."
+arch=('i686' 'x86_64')
+url="https://ffmt.pwd.cat/docs/"
+license=("GNU General Public License v3.0")
+depends=("mono")
+source=("https://github.com/fosspill/FFXIV_Modding_Tool/releases/download/v${pkgver}/FFXIV_Modding_Tool.zip")
+sha256sums=("9f25c300ff3d9854eac87b9d012a3fb14b8a4ee9a2d1c55116a98f0158ff3d90")
+
+package() {
+ cd $srcdir
+ install -dm755 ${fullpkgname}/ffmt "${pkgdir}/opt/ffmt"
+ install -Dm755 ${fullpkgname}/ffmt/* "${pkgdir}/opt/ffmt/"
+ install -Dm755 ${fullpkgname}/ffmt.sh "${pkgdir}/usr/bin/ffmt"
+}