summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77cdbe66f3a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ffmulticonverter
+ pkgdesc = Convert audio, video, image and document files between all popular formats
+ pkgver = 1.7.0
+ pkgrel = 3
+ url = https://sites.google.com/site/ffmulticonverter/
+ arch = any
+ license = GPL3
+ depends = python-pyqt4
+ optdepends = ffmpeg: for video conversions
+ optdepends = imagemagick: for image conversions
+ optdepends = unoconv: for document conversions
+ conflicts = ffmulticonverter-git
+ source = https://sourceforge.net/projects/ffmulticonv/files/ffmulticonverter-1.7.0.tar.gz
+ sha256sums = d466c59a7c5c71bae5660924a4d89523bdceeab5f3b38d9d4f8d9f62c16f8c69
+
+pkgname = ffmulticonverter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..994ffb414139
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Ilias Stamatis <stamatis.iliass at gmail dot com>
+# Contributor: Panagiotis Mavrogiorgos (pmav99) <> (gmail)
+
+pkgname=ffmulticonverter
+pkgver=1.7.0
+pkgrel=3
+pkgdesc="Convert audio, video, image and document files between all popular formats"
+arch=(any)
+url="https://sites.google.com/site/ffmulticonverter/"
+license=('GPL3')
+depends=('python-pyqt4')
+optdepends=('ffmpeg: for video conversions'
+ 'imagemagick: for image conversions'
+ 'unoconv: for document conversions')
+conflicts=('ffmulticonverter-git')
+source=(https://sourceforge.net/projects/ffmulticonv/files/$pkgname-$pkgver.tar.gz)
+sha256sums=('d466c59a7c5c71bae5660924a4d89523bdceeab5f3b38d9d4f8d9f62c16f8c69')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}