summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD42
2 files changed, 39 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f17c13987561..ffcc737ab015 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = ffsend-git
- pkgdesc = Easily and securely share files from the command line. A Firefox Send client.
- pkgver = 0.2.42.903c0312
+ pkgdesc = Easily and securely share files from the command line. A Send client.
+ pkgver = 0.2.74.ccd489ce
pkgrel = 1
url = https://gitlab.com/timvisee/ffsend
arch = x86_64
arch = i686
license = GPL3
- makedepends = openssl>=1.0
- makedepends = rust>=1.32
makedepends = cargo
makedepends = cmake
+ makedepends = openssl>=1.0
depends = ca-certificates
optdepends = xclip: clipboard support
provides = ffsend
conflicts = ffsend
- source = ffsend::git+https://gitlab.com/timvisee/ffsend.git
+ source = git+https://gitlab.com/timvisee/ffsend
sha256sums = SKIP
pkgname = ffsend-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8f23c41c02d4..9631fcd5620a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,53 @@
# - Mirror: https://github.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-git/PKGBUILD
pkgname=ffsend-git
-pkgver=0.2.42.903c0312
+pkgver=0.2.74.ccd489ce
pkgrel=1
-pkgdesc="Easily and securely share files from the command line. A Firefox Send client."
+pkgdesc="Easily and securely share files from the command line. A Send client."
url="https://gitlab.com/timvisee/ffsend"
license=('GPL3')
-source=("ffsend::git+$url.git")
+source=("git+${url}")
sha256sums=('SKIP')
arch=('x86_64' 'i686')
provides=('ffsend')
conflicts=('ffsend')
depends=('ca-certificates')
-makedepends=('openssl>=1.0' 'rust>=1.32' 'cargo' 'cmake')
+makedepends=('cargo' 'cmake' 'openssl>=1.0')
optdepends=('xclip: clipboard support')
+prepare() {
+ cd "${pkgname%-git}"
+
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
build() {
- cd ffsend
- env CARGO_INCREMENTAL=0 cargo build --release
+ cd "${pkgname%-git}"
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+check() {
+ cd "${pkgname%-git}"
+
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen
}
package() {
- install -Dm755 "$srcdir/ffsend/target/release/ffsend" "$pkgdir/usr/bin/ffsend"
+ cd "${pkgname%-git}"
+
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/ffsend"
+
+ # Shell completions and LICENSE file
+ install -Dm644 "contrib/completions/ffsend.bash" \
+ "$pkgdir/etc/bash_completion.d/ffsend"
+ install -Dm644 "contrib/completions/_ffsend" \
+ "$pkgdir/usr/share/zsh/site-functions/_ffsend"
+ install -Dm644 "contrib/completions/ffsend.fish" \
+ "$pkgdir/usr/share/fish/vendor_completions.d/ffsend.fish"
+ install -Dm644 "LICENSE" \
+ "$pkgdir/usr/share/licenses/ffsend/LICENSE"
}