summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02cf8d739ac4..f17c13987561 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffsend-git
pkgdesc = Easily and securely share files from the command line. A Firefox Send client.
- pkgver = 0.2.42
+ pkgver = 0.2.42.903c0312
pkgrel = 1
url = https://gitlab.com/timvisee/ffsend
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = ffsend-git
optdepends = xclip: clipboard support
provides = ffsend
conflicts = ffsend
- source = ffsend-v0.2.42.tar.gz::https://gitlab.com/timvisee/ffsend/-/archive/v0.2.42/ffsend-v0.2.42.tar.gz
+ source = ffsend::git+https://gitlab.com/timvisee/ffsend.git
sha256sums = SKIP
pkgname = ffsend-git
diff --git a/PKGBUILD b/PKGBUILD
index f55a7614822e..8f23c41c02d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
# Maintainer: Tim Visee <tim@visee.me>
+#
+# This PKGBUILD is managed externally, and is automatically updated here:
+# - https://gitlab.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-git/PKGBUILD
+# - Mirror: https://github.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-git/PKGBUILD
pkgname=ffsend-git
-pkgver=0.2.42
+pkgver=0.2.42.903c0312
pkgrel=1
pkgdesc="Easily and securely share files from the command line. A Firefox Send client."
url="https://gitlab.com/timvisee/ffsend"
license=('GPL3')
-provides=('ffsend')
-conflicts=('ffsend')
-source=("ffsend-v$pkgver.tar.gz::$url/-/archive/v$pkgver/ffsend-v$pkgver.tar.gz")
+source=("ffsend::git+$url.git")
sha256sums=('SKIP')
arch=('x86_64' 'i686')
+provides=('ffsend')
+conflicts=('ffsend')
depends=('ca-certificates')
makedepends=('openssl>=1.0' 'rust>=1.32' 'cargo' 'cmake')
optdepends=('xclip: clipboard support')
build() {
- cd "ffsend-v$pkgver"
+ cd ffsend
env CARGO_INCREMENTAL=0 cargo build --release
}
package() {
- install -Dm755 "$srcdir/ffsend-v$pkgver/target/release/ffsend" "$pkgdir/usr/bin/ffsend"
+ install -Dm755 "$srcdir/ffsend/target/release/ffsend" "$pkgdir/usr/bin/ffsend"
}