summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD12
3 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 187db973aa1c..4dbc6afa15fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Nov 7 22:18:55 UTC 2017
+# Thu Nov 16 22:26:50 UTC 2017
pkgbase = fftw-mpi
- pkgdesc = fftw, compiled with MPI and OpenMP support
+ pkgdesc = FFTW, compiled with MPI and OpenMP support: header files, static and shared libraries
pkgver = 3.3.7
- pkgrel = 1
+ pkgrel = 2
url = http://www.fftw.org/
install = fftw.install
arch = i686
@@ -15,6 +15,7 @@ pkgbase = fftw-mpi
depends = openmpi
provides = fftw
conflicts = fftw
+ options = staticlibs
source = http://www.fftw.org/fftw-3.3.7.tar.gz
sha1sums = 2ae980a8d44c161ce4a09c6e2d1c79243ecbabb2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 6d2fd0b78efb..ed5bd0e87c63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,10 @@
+# Maintainer: Ashwin Vishnu <ashwinvis+arch at pr0t0nm4il dot com>
+# Contributor: Denis Gagnon <gagnon88 at gm41l dot com>
+
pkgname=fftw-mpi
pkgver=3.3.7
-pkgrel=1
-pkgdesc="fftw, compiled with MPI and OpenMP support"
+pkgrel=2
+pkgdesc="FFTW, compiled with MPI and OpenMP support: header files, static and shared libraries"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.fftw.org/"
@@ -10,6 +13,7 @@ conflicts=('fftw')
makedepends=('gcc-fortran')
source=("http://www.fftw.org/fftw-${pkgver}.tar.gz")
provides=('fftw')
+options=('staticlibs')
install=fftw.install
sha1sums=('2ae980a8d44c161ce4a09c6e2d1c79243ecbabb2')
@@ -35,7 +39,7 @@ build() {
# build double precision
cd ${srcdir}/fftw-${pkgver}-double
- $CONFIGURE --enable-sse2
+ $CONFIGURE --enable-sse2 --enable-avx
make
# build & install long double precission
@@ -45,7 +49,7 @@ build() {
# build & install single precision
cd ${srcdir}/fftw-${pkgver}-single
- $CONFIGURE --enable-float --enable-sse
+ $CONFIGURE --enable-float --enable-sse --enable-avx
make
}