summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD28
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9be8cf809613
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fgit
+ pkgdesc = Run git commands on multiple repositories with a single command
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/l0b0/fgit
+ arch = any
+ license = GPL3
+ makedepends = make
+ depends = bash
+ depends = git
+ depends = ncurses
+ provides = fgit
+ conflicts = fgit-git
+ source = https://github.com/l0b0/fgit/archive/1.0.2.tar.gz
+ sha512sums = 83cbbe918f6b2a154c107b7350ffd900f33a0e1021e62bd90cb7d8ef1b4e6773115c90de3c9677996fc8e877da3b92a0cdd75cc8c492fbcdb41fe15d02cde718
+
+pkgname = fgit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a9a6b899bf5e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+.idea/
+make-includes/
+pkg/
+*.pkg.tar.xz
+shell-includes/
+src/
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5e5c64116cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Victor Engmark <victor.engmark@gmail.com>
+pkgname=fgit
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Run git commands on multiple repositories with a single command"
+arch=('any')
+url='https://github.com/l0b0/fgit'
+license=('GPL3')
+depends=('bash' 'git' 'ncurses')
+makedepends=('make')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+source=("https://github.com/l0b0/fgit/archive/${pkgver}.tar.gz")
+sha512sums=('83cbbe918f6b2a154c107b7350ffd900f33a0e1021e62bd90cb7d8ef1b4e6773115c90de3c9677996fc8e877da3b92a0cdd75cc8c492fbcdb41fe15d02cde718')
+
+prepare() {
+ mv "$srcdir/${pkgname}-${pkgver}" "$srcdir/${pkgname}"
+}
+
+check() {
+ cd "$srcdir/${pkgname}"
+ make test
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ make PREFIX="${pkgdir}/usr" DESTDIR="/usr" install
+}