summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD33
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79649a79c81f..5b6c3d62595c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,12 +4,13 @@ pkgbase = fido
pkgrel = 1
url = https://openpreservation.org/tools/fido/
arch = any
- license = Apache
+ license = Apache-2.0
makedepends = python-build
makedepends = python-installer
makedepends = python-pytest-runner
makedepends = python-setuptools
makedepends = python-wheel
+ depends = python
depends = python-olefile
depends = python-six
depends = python-importlib_resources
diff --git a/PKGBUILD b/PKGBUILD
index 84a426208ecc..7b36384d7620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,27 +6,26 @@ pkgrel=1
pkgdesc="A command-line tool to identify the file formats of digital objects."
arch=('any')
url="https://openpreservation.org/tools/fido/"
-license=('Apache')
-depends=(
- 'python-olefile'
- 'python-six'
- 'python-importlib_resources'
- 'python-requests')
-makedepends=(
- 'python-build'
- 'python-installer'
- 'python-pytest-runner'
- 'python-setuptools'
- 'python-wheel')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/openpreserve/fido/archive/v${pkgver}.tar.gz")
+license=('Apache-2.0')
+depends=('python'
+ 'python-olefile'
+ 'python-six'
+ 'python-importlib_resources'
+ 'python-requests')
+makedepends=('python-build'
+ 'python-installer'
+ 'python-pytest-runner'
+ 'python-setuptools'
+ 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/openpreserve/fido/archive/v$pkgver.tar.gz")
sha256sums=('6980d23cd7b5004b42334d3032adcbeafd99cf597edc758cad0cb23f2dbab18d')
build() {
- cd "${pkgname}-${pkgver}"
- python -m build --wheel --no-isolation
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${pkgname}-${pkgver}"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}