summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD31
1 files changed, 21 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cd22d666d9f..f699023d69c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,21 +11,33 @@ pkgdesc="Flexible Isometric Free Engine is a cross platform game creation framew
arch=('i686' 'x86_64')
url="http://fifengine.net/"
license=('LGPL')
-depends=('boost' 'fifechan' 'libvorbis' 'sdl2_ttf' 'openal' 'python' 'tinyxml' 'glew')
-makedepends=('cmake' 'mesa' 'swig')
-# source=("https://github.com/$_githubname/$_githubname/archive/$pkgver.tar.gz")
-# Needs to build at this commit to be able to build with swig 4, upstream doesn't want to tag:
-source=("$pkgver-d14f232.tar.gz::https://github.com/$_githubname/$_githubname/archive/d14f232f4cd9a00b05d6872957070e8c020f515d.tar.gz")
-sha512sums=('6fafca8e75b7f8a374b74c9e75cfa63208277f976ef9efcdb1da5c94a1ef46dacd320afe0b9dbd83a1ce8acb078a28d687328b3c4ba8227510f492e5a8df9373')
+depends=('boost-libs' 'fifechan' 'glew' 'libgl' 'libpng' 'libstdc++5' 'libvorbis' 'openal' 'python' 'sdl2' 'sdl2_image' 'sdl2_ttf' 'tinyxml' 'zlib')
+makedepends=('boost' 'cmake' 'swig')
+source=("$pkgname-$pkgver.src.tar.gz::https://github.com/$_githubname/$_githubname/archive/$pkgver.tar.gz"
+ "$pkgname-[PATCH]-removed-flags-that-are-not-supported-with-swig-4.0.patch::https://github.com/$_githubname/$_githubname/commit/d14f232f4cd9a00b05d6872957070e8c020f515d.patch"
+ "$pkgname-[PATCH]-SyntaxWarning:-\"is\"-with-a-literal.patch::https://github.com/$_githubname/$_githubname/commit/454a981a777f141db999809944abbc64ed15c41f.patch")
+sha512sums=('2b92e936d3f900532c5dee235a217c338941c44da479dceb3e48b3e8b93a402b31dc5501a6533391a01af53d6dbd51b6793c74e8ac81301ae6f1fa18271761a4'
+ 'd5894f7708030ac6f8cc7612b4a29c1fb68aa2d545362017232874579661097ed1257b7de297489a10951716033d522d4ee6c17033009e2a4eaf3cfbdc26091d'
+ '59b47dabc2b02a807c978837ab47498dca140f156159ada2c2cdbcf7a912bd95fcaf622bb92bcd585b1c722d4023f50330c4320d59a76e4ba12bb344da43996c')
+
+prepare() {
+ cd "$_githubname-$pkgver"
+ patch --forward --strip=1 \
+ --input="$srcdir/$pkgname-[PATCH]-removed-flags-that-are-not-supported-with-swig-4.0.patch"
+ patch --forward --strip=1 \
+ --input="$srcdir/$pkgname-[PATCH]-SyntaxWarning:-\"is\"-with-a-literal.patch"
+}
build() {
- # cd "$_githubname-$pkgver"
- cd "$_githubname-d14f232f4cd9a00b05d6872957070e8c020f515d"
+ cd "$_githubname-$pkgver"
[[ -d "build" ]] && rm -r "build"
mkdir -p "build" && cd "build"
+
cmake \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -Wno-dev \
..
+
make
# If compilation seems to stall at 99% for ages, do not abort!
# While not perfectly convenient, that is to be expected from
@@ -33,8 +45,7 @@ build() {
}
package() {
- # cd "$_githubname-$pkgver"
- cd "$_githubname-d14f232f4cd9a00b05d6872957070e8c020f515d"
+ cd "$_githubname-$pkgver"
cd "build"
make DESTDIR="$pkgdir" install
}