summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c35c7a2de7b0..a0082f12bb1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Feb 10 19:55:47 UTC 2017
pkgbase = fife
pkgdesc = Flexible Isometric Free Engine is a cross platform game creation framework
- pkgver = 0.4.1
- pkgrel = 2
+ pkgver = 0.4.2
+ pkgrel = 1
url = http://fifengine.net/
arch = i686
arch = x86_64
@@ -12,22 +10,15 @@ pkgbase = fife
makedepends = mesa
makedepends = swig
depends = boost
- depends = boost-libs
- depends = fifechan>=0.1.4
- depends = libgl
- depends = libogg
- depends = libpng
+ depends = fifechan
depends = libvorbis
- depends = sdl2
depends = sdl2_ttf
- depends = sdl2_image
depends = openal
- depends = python2
+ depends = python
depends = tinyxml
- depends = zlib
- source = https://github.com/fifengine/fifengine/archive/0.4.1.tar.gz
- md5sums = 6ce5533102c4993b44c3ba8347f4ca93
- sha256sums = bae3fc591cc2891f7d1b3a656a5d8ad700ecc2e297ad453bf4f1bcbbf82e8cb2
+ depends = glew
+ source = https://github.com/fifengine/fifengine/archive/0.4.2.tar.gz
+ sha512sums = 2b92e936d3f900532c5dee235a217c338941c44da479dceb3e48b3e8b93a402b31dc5501a6533391a01af53d6dbd51b6793c74e8ac81301ae6f1fa18271761a4
pkgname = fife
diff --git a/PKGBUILD b/PKGBUILD
index bc041539c1e2..dd5a8bdb92a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,23 @@
-# Maintainer: Chris Oelmueller <chris.oelmueller@gmail.com>
+# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki>
+# Contributor: Chris Oelmueller <chris.oelmueller@gmail.com>
# Contributor: apaugh
# Contributor: speps <speps at aur dot archlinux dot org>
pkgname=fife
-pkgver=0.4.1
-pkgrel=2
+pkgver=0.4.2
+pkgrel=1
_githubname=fifengine
pkgdesc="Flexible Isometric Free Engine is a cross platform game creation framework"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://fifengine.net/"
license=('LGPL')
-depends=('boost' 'boost-libs' 'fifechan>=0.1.4' 'libgl' 'libogg' 'libpng' 'libvorbis'
- 'sdl2' 'sdl2_ttf' 'sdl2_image' 'openal' 'python2' 'tinyxml' 'zlib')
+depends=('boost' 'fifechan' 'libvorbis' 'sdl2_ttf' 'openal' 'python' 'tinyxml' 'glew')
makedepends=('cmake' 'mesa' 'swig')
-source=("https://github.com/${_githubname}/${_githubname}/archive/${pkgver}.tar.gz")
-md5sums=('6ce5533102c4993b44c3ba8347f4ca93')
-sha256sums=('bae3fc591cc2891f7d1b3a656a5d8ad700ecc2e297ad453bf4f1bcbbf82e8cb2')
-
-prepare() {
- # use python2
- export PYTHON=python2
-}
+source=("https://github.com/$_githubname/$_githubname/archive/$pkgver.tar.gz")
+sha512sums=('2b92e936d3f900532c5dee235a217c338941c44da479dceb3e48b3e8b93a402b31dc5501a6533391a01af53d6dbd51b6793c74e8ac81301ae6f1fa18271761a4')
build() {
- cd "${_githubname}-${pkgver}"
+ cd "$_githubname-$pkgver"
[[ -d "build" ]] && rm -r "build"
mkdir -p "build" && cd "build"
cmake \
@@ -36,9 +30,9 @@ build() {
}
package() {
- cd "${_githubname}-${pkgver}"
+ cd "$_githubname-$pkgver"
cd "build"
- make DESTDIR=$pkgdir install
+ make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et: