summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07456ff5ef03..8fbde4f04e67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fightcade2
pkgdesc = The best way to play your favorite retro games with or against any other player in the world.
pkgver = 2.0.12
- pkgrel = 2
+ pkgrel = 3
url = https://play.fightcade.com/
arch = any
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index d925fd572f41..f294645c4ea3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=fightcade2
pkgver=2.0.12
-pkgrel=2
+pkgrel=3
pkgdesc='The best way to play your favorite retro games with or against any other player in the world.'
url='https://play.fightcade.com/'
arch=('any')
@@ -33,5 +33,9 @@ package() {
install -dm755 $pkgdir/opt/
install -Dm644 "$srcdir/Fightcade2/fc2-electron/resources/app/icon.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ msg "Copying files..."
rsync -r --chmod=755 $srcdir/Fightcade2/* $pkgdir/opt/$pkgname/
+ msg "Changing emulators configs permissions..."
+ chmod 777 "$pkgdir/opt/$pkgname/emulator/snes9x/fcadesnes9x.conf"
+ chown -R $USER $pkgdir/opt/$pkgname/emulator/fba/config/
}