summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD50
-rw-r--r--file-roller-tmp.install15
-rw-r--r--tmp-as-temp.patch85
5 files changed, 31 insertions, 157 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f3e02d64f4b..f3ff0869aa1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,12 @@
pkgbase = file-roller-tmp
- pkgdesc = Create and modify archives. SSD-friendly version (stores temporary files in /tmp).
+ pkgdesc = [Meta-PKG] Use 'file-roller' instead; delete this dummy metapackage
pkgver = 3.36.2
- pkgrel = 1
- url = https://gitlab.gnome.org/GNOME/file-roller
- arch = x86_64
- groups = gnome
+ pkgrel = 2
+ url = https://archlinux.org/packages/?q=file-roller
+ install = file-roller-tmp.install
+ arch = any
license = GPL2
- makedepends = yelp-tools
- makedepends = git
- makedepends = libnautilus-extension
- makedepends = meson
- makedepends = appstream-glib
- depends = gtk3
- depends = dconf
- depends = libarchive
- depends = file
- depends = json-glib
- depends = libnotify
- depends = zip
- depends = unzip
- optdepends = p7zip: 7z, arj, exe and encrypted zip files support
- optdepends = unrar: better RAR archive support
- optdepends = unace: ACE archive support
- optdepends = lrzip: lrzip archive support
- provides = file-roller=3.36.2
+ optdepends = file-roller: migrate to this package instead of file-roller-tmp
conflicts = file-roller
- replaces = file-roller
- source = git+https://gitlab.gnome.org/GNOME/file-roller.git#commit=eef4df4c857520ac81b1514d3b923e88855ce669
- source = tmp-as-temp.patch
- sha256sums = SKIP
- sha256sums = SKIP
pkgname = file-roller-tmp
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ed45410df8fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index a33171549274..0e200a766d40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,14 @@
-# Maintainer : Kresimir Pripuzic <kpripuzic@gmail.com>
+# Contributor: Kresimir Pripuzic <kpripuzic@gmail.com>
# Contributor: Andrey Vetrov <vetrov@mail.ru>
# https://aur.archlinux.org/packages/file-roller-tmp/
pkgname=file-roller-tmp
pkgver=3.36.2
-pkgrel=1
-pkgdesc="Create and modify archives. SSD-friendly version (stores temporary files in /tmp)."
-url="https://gitlab.gnome.org/GNOME/file-roller"
-arch=(x86_64)
+pkgrel=2
+pkgdesc="[Meta-PKG] Use 'file-roller' instead; delete this dummy metapackage"
+url="https://archlinux.org/packages/?q=file-roller"
+arch=(any)
license=(GPL2)
-provides=("file-roller=$pkgver")
conflicts=('file-roller')
-replaces=('file-roller')
-depends=('gtk3' 'dconf' 'libarchive' 'file' 'json-glib' 'libnotify' 'zip' 'unzip')
-makedepends=('yelp-tools' 'git' 'libnautilus-extension' 'meson' 'appstream-glib')
-optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
- 'unrar: better RAR archive support'
- 'unace: ACE archive support'
- 'lrzip: lrzip archive support')
-groups=(gnome)
-_commit=eef4df4c857520ac81b1514d3b923e88855ce669 # tags/3.36.2^0
-source=("git+https://gitlab.gnome.org/GNOME/file-roller.git#commit=$_commit"
- 'tmp-as-temp.patch')
-sha256sums=('SKIP' 'SKIP')
-
-pkgver() {
- cd ${pkgname:0:11}
- git describe --tags | sed 's/-/+/g'
-}
-
-prepare() {
- cd ${pkgname:0:11}
- #patch
- cd $srcdir/${pkgname:0:11}
- patch -Np0 -i ../tmp-as-temp.patch
-}
-
-build() {
- arch-meson ${pkgname:0:11} build
- ninja -C build
-}
-
-check() {
- meson test -C build
-}
-
-package() {
- DESTDIR="$pkgdir" meson install -C build
-}
+optdepends=('file-roller: migrate to this package instead of file-roller-tmp')
+install="${pkgname}.install"
diff --git a/file-roller-tmp.install b/file-roller-tmp.install
new file mode 100644
index 000000000000..19d5a06306d2
--- /dev/null
+++ b/file-roller-tmp.install
@@ -0,0 +1,15 @@
+pre_install() {
+ echo "WARNING: 'file-roller-tmp' is now empty: manual intervention required"
+ echo
+ echo " AUR/file-roller-tmp has been abandoned since 2020,"
+ echo " and now it has been deleted."
+ echo
+ echo " Please install 'file-roller' instead (this will remove 'file-roller-tmp'):"
+ echo
+ echo " sudo pacman -Syu file-roller"
+ echo
+}
+
+pre_upgrade() {
+ pre_install
+}
diff --git a/tmp-as-temp.patch b/tmp-as-temp.patch
deleted file mode 100644
index e2e788a5b737..000000000000
--- a/tmp-as-temp.patch
+++ /dev/null
@@ -1,85 +0,0 @@
---- src/file-utils.c 2017-05-02 14:13:27.327758724 +0200
-+++ src/file-utils.c 2017-05-02 14:26:07.501244763 +0200
-@@ -51,27 +51,6 @@
-
- /* path */
-
--
--static const char *try_folder[] = { "cache", "~", "tmp", NULL };
--
--
--static const char *
--get_nth_temp_folder_to_try (int n)
--{
-- const char *folder;
--
-- folder = try_folder[n];
-- if (strcmp (folder, "cache") == 0)
-- folder = g_get_user_cache_dir ();
-- else if (strcmp (folder, "~") == 0)
-- folder = g_get_home_dir ();
-- else if (strcmp (folder, "tmp") == 0)
-- folder = g_get_tmp_dir ();
--
-- return folder;
--}
--
--
- char *
- _g_path_get_temp_work_dir (const char *parent_folder)
- {
-@@ -81,28 +60,7 @@
- char *template;
- char *result = NULL;
-
-- if (parent_folder == NULL) {
-- /* find the folder with more free space. */
--
-- for (i = 0; try_folder[i] != NULL; i++) {
-- const char *folder;
-- GFile *file;
-- guint64 size;
--
-- folder = get_nth_temp_folder_to_try (i);
-- file = g_file_new_for_path (folder);
-- size = _g_file_get_free_space (file);
-- g_object_unref (file);
--
-- if (max_size < size) {
-- max_size = size;
-- g_free (best_folder);
-- best_folder = g_strdup (folder);
-- }
-- }
-- }
-- else
-- best_folder = g_strdup (parent_folder);
-+ best_folder = g_strdup (g_get_tmp_dir ());
-
- if (best_folder == NULL)
- return NULL;
-@@ -578,17 +536,15 @@
- return FALSE;
- }
-
-- for (i = 0; try_folder[i] != NULL; i++) {
-- const char *folder;
-
-- folder = get_nth_temp_folder_to_try (i);
-- if (strncmp (path, folder, strlen (folder)) == 0) {
-- if (strncmp (path + strlen (folder), "/.fr-", 5) == 0) {
-- result = TRUE;
-- break;
-- }
-+ const char *folder;
-+
-+ folder = g_strdup (g_get_tmp_dir ());
-+ if (strncmp (path, folder, strlen (folder)) == 0) {
-+ if (strncmp (path + strlen (folder), "/.fr-", 5) == 0) {
-+ result = TRUE;
- }
-- }
-+ }
-
- g_free (path);
-