summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
2 files changed, 34 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc83ce5d2639..b77a09b304c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = file-roller-tmp
- pkgdesc = The file-roller with an additional patch to put temporary files in /tmp instead of ~/.cache (and thus to reduce the amount of writes to SSDs).
- pkgver = 3.24.1
+ pkgdesc = Create and modify archives. SSD-friendly version (stores temporary files in /tmp).
+ pkgver = 3.30.1
pkgrel = 1
- arch = i686
+ url = https://wiki.gnome.org/Apps/FileRoller
arch = x86_64
- groups = gnome-extra
+ groups = gnome
license = GPL
- makedepends = intltool
- makedepends = itstool
- makedepends = docbook-xsl
- makedepends = gnome-common
+ makedepends = yelp-tools
makedepends = git
makedepends = libnautilus-extension
+ makedepends = meson
+ makedepends = appstream-glib
depends = gtk3
depends = dconf
depends = libarchive
@@ -24,12 +23,13 @@ pkgbase = file-roller-tmp
optdepends = unrar: better RAR archive support
optdepends = unace: ACE archive support
optdepends = lrzip: lrzip archive support
- provides = file-roller
+ provides = file-roller=3.30.1
conflicts = file-roller
- source = git+https://git.gnome.org/browse/file-roller#commit=e6ef6fa43a6d5d6e1509f122a206870adc113563
+ replaces = file-roller
+ source = git+https://gitlab.gnome.org/GNOME/file-roller.git#commit=7962fbaf86db77ec6c0713491920341487be1681
source = tmp-as-temp.patch
sha256sums = SKIP
- sha256sums = 753c6ee41772677b115f4178fe6384c21d8aa5d489a6074f659d5305736acf57
+ sha256sums = SKIP
pkgname = file-roller-tmp
diff --git a/PKGBUILD b/PKGBUILD
index 42fcc6d0c7aa..389c7ff03e05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# $Id$
# Maintainer: Kresimir Pripuzic <kpripuzic@gmail.com>
+# https://aur.archlinux.org/packages/file-roller-tmp/
pkgname=file-roller-tmp
-pkgver=3.24.1
+pkgver=3.30.1
pkgrel=1
-pkgdesc="The file-roller with an additional patch to put temporary files in /tmp instead of ~/.cache (and thus to reduce the amount of writes to SSDs)."
-arch=(i686 x86_64)
+pkgdesc="Create and modify archives. SSD-friendly version (stores temporary files in /tmp)."
+url="https://wiki.gnome.org/Apps/FileRoller"
+arch=(x86_64)
license=(GPL)
-depends=(gtk3 dconf libarchive file json-glib libnotify zip unzip)
-makedepends=(intltool itstool docbook-xsl gnome-common git libnautilus-extension)
+provides=("file-roller=$pkgver")
+conflicts=('file-roller')
+replaces=('file-roller')
+depends=('gtk3' 'dconf' 'libarchive' 'file' 'json-glib' 'libnotify' 'zip' 'unzip')
+makedepends=('yelp-tools' 'git' 'libnautilus-extension' 'meson' 'appstream-glib')
optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
'unrar: better RAR archive support'
'unace: ACE archive support'
'lrzip: lrzip archive support')
-groups=(gnome-extra)
-provides=('file-roller')
-conflicts=('file-roller')
-_commit=e6ef6fa43a6d5d6e1509f122a206870adc113563 # tags/3.24.1^0
-source=("git+https://git.gnome.org/browse/file-roller#commit=$_commit"
- tmp-as-temp.patch)
-sha256sums=('SKIP'
- '753c6ee41772677b115f4178fe6384c21d8aa5d489a6074f659d5305736acf57')
+groups=(gnome)
+_commit=7962fbaf86db77ec6c0713491920341487be1681 # tags/3.30.1^0
+source=("git+https://gitlab.gnome.org/GNOME/file-roller.git#commit=$_commit"
+ 'tmp-as-temp.patch')
+sha256sums=('SKIP' 'SKIP')
pkgver() {
cd ${pkgname:0:11}
@@ -28,8 +29,7 @@ pkgver() {
}
prepare() {
- cd ${pkgname:0:11}
- NOCONFIGURE=1 ./autogen.sh
+ cd ${pkgname:0:11}
#patch
cd $srcdir/${pkgname:0:11}
@@ -37,14 +37,14 @@ prepare() {
}
build() {
- cd ${pkgname:0:11}
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/$pkgname --disable-static --disable-schemas-compile
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ arch-meson ${pkgname:0:11} build
+ ninja -C build
+}
+
+check() {
+ meson test -C build
}
package() {
- cd ${pkgname:0:11}
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
}