summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD62
-rw-r--r--filegdb-api.changelog4
3 files changed, 38 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c9573e519f1..5edaa43311ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = filegdb-api
pkgdesc = ESRI File Geodatabase (FileGDB) API
pkgver = 1.5.1
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/Esri/file-geodatabase-api
changelog = filegdb-api.changelog
arch = i686
arch = x86_64
license = APACHE
makedepends = libxml2
- makedepends = clang>=3.7.0
- optdepends = gdal-filegdb: wrapper
- source = filegdb-api-1.5.1.tar.gz::http://downloads2.esri.com/Software/FileGDB_API_1_5_1-64gcc51.tar.gz
+ makedepends = gcc
+ source = filegdb-api-1.5.1.tar.gz::https://raw.githubusercontent.com/Esri/file-geodatabase-api/master/FileGDB_API_1.5.1/FileGDB_API_1_5_1-64gcc51.tar.gz
md5sums = 10a18003adaa6ccf0c4d8e6bb8da1e4f
pkgname = filegdb-api
-
diff --git a/PKGBUILD b/PKGBUILD
index 892eba723e14..24f1beb01bd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,20 @@
pkgname=filegdb-api
_pkgname=FileGDB_API
pkgver=1.5.1
-pkgrel=2
+pkgrel=4
pkgdesc="ESRI File Geodatabase (FileGDB) API"
arch=('i686' 'x86_64')
url="https://github.com/Esri/file-geodatabase-api"
license=('APACHE')
-makedepends=('libxml2' 'clang>=3.7.0')
-optdepends=('gdal-filegdb: wrapper')
+makedepends=('libxml2' 'gcc')
changelog=$pkgname.changelog
case $CARCH in
i686)
- source=($pkgname-$pkgver.tar.gz::http://downloads2.esri.com/Software/${_pkgname}_${pkgver//./_}-32gcc51.tar.gz)
+ source=($pkgname-$pkgver.tar.gz::https://raw.githubusercontent.com/Esri/file-geodatabase-api/master/${_pkgname}_${pkgver}/${_pkgname}_${pkgver//./_}-32gcc51.tar.gz)
md5sums=('145f760871892b822b5f26442e2e8255')
;;
x86_64)
- source=($pkgname-$pkgver.tar.gz::http://downloads2.esri.com/Software/${_pkgname}_${pkgver//./_}-64gcc51.tar.gz)
+ source=($pkgname-$pkgver.tar.gz::https://raw.githubusercontent.com/Esri/file-geodatabase-api/master/${_pkgname}_${pkgver}/${_pkgname}_${pkgver//./_}-64gcc51.tar.gz)
md5sums=('10a18003adaa6ccf0c4d8e6bb8da1e4f')
;;
esac
@@ -32,49 +31,50 @@ build() {
#Build for linux
export CPPFLAGS+=" -Dlinux"
- #Setup LD_LIBRARY_PATH
- export LD_LIBRARY_PATH=$srcdir/${pkgname}/lib:$LD_LIBRARY_PATH
+ #Setup LD_LIBRARY_PATH
+ export LD_LIBRARY_PATH=$srcdir/${pkgname}/lib:$LD_LIBRARY_PATH
- #Modify make.include to use old ABI
+ # Modify make.include to use old ABI
# cd "$srcdir/${pkgname}/include"
# sed -i '/-D_LARGEFILE64_SOURCE/ s/$/ -D_GLIBCXX_USE_CXX11_ABI=0/' make.include
- #Building all samples
- cd "$srcdir/${pkgname}/samples"
- make
+ # Building all samples
+ cd "$srcdir/${pkgname}/samples"
+ make
- # Building ProcessTopology
- cd "$srcdir/${pkgname}/samples/ProcessTopologies"
+ # Building ProcessTopology
+ cd "$srcdir/${pkgname}/samples/ProcessTopologies"
- # Insert libxml2 library path to Makefile
- #sed -i '/^CXXFLAGS=/ s/$/ -I\/usr\/include\/libxml2\//' Makefile
- #make
+ # Insert libxml2 library path to Makefile
+ # sed -i '/^CXXFLAGS=/ s/$/ -I\/usr\/include\/libxml2\//' Makefile
+ # make
}
# Uncomment check() portion if you want to perform sample tests
# Warning: Lots of verbose output for tests!
#
-#check() {
-# cd "$srcdir/${_pkgname}/samples/bin"
-# for i in *
-# do
-# ./${i}
-# done
-#}
+# check() {
+ # cd "$srcdir/${pkgname}/samples/bin"
+ # for i in *
+ # do
+ # ./${i}
+ # done
+# }
package() {
cd $pkgdir
- mkdir -p $pkgdir/usr/{lib,share/{doc,licenses}/$pkgname}
- mkdir -p $pkgdir/usr/include
+ mkdir -p $pkgdir/usr/{lib,share/{doc,licenses}/$pkgname}
+ mkdir -p $pkgdir/usr/include/${pkgname}/
- install -Dm644 $srcdir/${pkgname}/lib/* "$pkgdir/usr/lib/"
- install -Dm644 $srcdir/${pkgname}/include/* "$pkgdir/usr/include/"
+ install -Dm644 $srcdir/${pkgname}/lib/* "$pkgdir/usr/lib/"
+ rm $pkgdir/usr/lib/libstdc++.so*
+ install -Dm644 $srcdir/${pkgname}/include/* "$pkgdir/usr/include/$pkgname"
- cp -r $srcdir/${pkgname}/doc/html "$pkgdir/usr/share/doc/$pkgname/"
+ cp -r $srcdir/${pkgname}/doc/html "$pkgdir/usr/share/doc/$pkgname/"
- find $pkgdir/usr/share/doc/$pkgname/ -type d -exec chmod 755 '{}' \;
- find $pkgdir/usr/share/doc/$pkgname/ -type f -exec chmod 644 '{}' \;
+ find $pkgdir/usr/share/doc/$pkgname/ -type d -exec chmod 755 '{}' \;
+ find $pkgdir/usr/share/doc/$pkgname/ -type f -exec chmod 644 '{}' \;
- chown root: $pkgdir/usr/share/doc/$pkgname/*
+ chown root: $pkgdir/usr/share/doc/$pkgname/*
}
diff --git a/filegdb-api.changelog b/filegdb-api.changelog
index f548a81a9f47..c1c9fdc38e39 100644
--- a/filegdb-api.changelog
+++ b/filegdb-api.changelog
@@ -1,3 +1,7 @@
+2019-05-06 SaultDon <sault.don gmail>
+ * 1.5.1-3 :
+ - fixed incorrect source urls
+
2018-05-16 SaultDon <sault.don gmail>
* 1.5.1-2 :
- removed sed command to build against old ABI