summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
-rw-r--r--fim.install22
3 files changed, 31 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c138541493d5..88eb19a30b9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,23 @@
pkgbase = fim
pkgdesc = FIM (Fbi IMproved) is a highly customizable and scriptable image viewer.
- pkgver = 0.6
- pkgrel = 2
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://www.nongnu.org/fbi-improved/
- install = fim.install
arch = i686
arch = x86_64
- license = GPL2
- depends = giflib
- depends = libjpeg-turbo
+ license = GPL-2.0-or-later
depends = libexif
- depends = sdl
depends = terminus-font
+ optdepends = aalib: ASCII art support
optdepends = djvulibre: djvu support
+ optdepends = giflib: GIF support
+ optdepends = imagemagick: use convert for unrecognized files
+ optdepends = libjpeg-turbo: JPEG support
+ optdepends = libpng: PNG support
optdepends = libspectre: postscript support
+ optdepends = libtiff: TIFF support
optdepends = sdl: X support
- optdepends = poppler: PDF support
- conflicts = fim-svn
- source = https://download.savannah.gnu.org/releases/fbi-improved/fim-0.6-trunk.tar.gz
- source = fim.install
- sha256sums = f77f45d38cbd2ddb5a21ce48b6ecb44e7ddcf77d00635d7c7dbe74ea083b8b88
- sha256sums = 8c647abb30baced37aaef6544b66ed2f8709b7ad6636d761f948d85c3071c536
+ source = http://download.savannah.gnu.org/releases/fbi-improved/fim-0.7.0.tar.gz
+ sha256sums = 44cf99e37ff93a219734fb379128a7714c4a8e689f06338c7e479dc949ad53ff
pkgname = fim
-
diff --git a/PKGBUILD b/PKGBUILD
index 2b70091128f7..9c304379dc81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,41 @@
-# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+# Maintainer: Andrew O'Neill <andrew at haunted dot sh>
# Contributor: Steven Honeyman <stevenhoneyman at gmail com>
# Contributor: Alexej Magura <agm2819*gmail*>
# Contributor: Dragonlord <dragonlord[at]seznam[.]cz>
# Contributor: daniel <quite a hack org>
pkgname=fim
-_pkgname='trunk'
-pkgver=0.6
-pkgrel=2
+pkgver=0.7.0
+pkgrel=1
pkgdesc='FIM (Fbi IMproved) is a highly customizable and scriptable image viewer.'
arch=('i686' 'x86_64')
-conflicts=('fim-svn')
url='https://www.nongnu.org/fbi-improved/'
-license=('GPL2')
-optdepends=('djvulibre: djvu support'
+license=('GPL-2.0-or-later')
+depends=('libexif' 'terminus-font')
+optdepends=('aalib: ASCII art support'
+ 'djvulibre: djvu support'
+ 'giflib: GIF support'
+ 'imagemagick: use convert for unrecognized files'
+ 'libjpeg-turbo: JPEG support'
+ 'libpng: PNG support'
'libspectre: postscript support'
- 'sdl: X support'
- 'poppler: PDF support')
-depends=('giflib' 'libjpeg-turbo' 'libexif' 'sdl' 'terminus-font')
-install=${pkgname}.install
-source=("https://download.savannah.gnu.org/releases/fbi-improved/${pkgname}-${pkgver}-${_pkgname}.tar.gz"
- "${pkgname}.install")
-sha256sums=('f77f45d38cbd2ddb5a21ce48b6ecb44e7ddcf77d00635d7c7dbe74ea083b8b88'
- '8c647abb30baced37aaef6544b66ed2f8709b7ad6636d761f948d85c3071c536')
+ 'libtiff: TIFF support'
+ 'sdl: X support')
+source=("http://download.savannah.gnu.org/releases/fbi-improved/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('44cf99e37ff93a219734fb379128a7714c4a8e689f06338c7e479dc949ad53ff')
build() {
- cd "${pkgname}-${pkgver}-${_pkgname}"
+ cd "${pkgname}-${pkgver}"
- ./configure LIBS=-lpthread --prefix=/usr --disable-debug --enable-unicode \
- --enable-hardcoded-font --disable-xcftopnm --disable-inkscape \
- --disable-xfig --disable-dia --disable-imlib2 --enable-sdl
+ PKG_CONFIG=/usr/bin/pkg-config ./configure \
+ LIBS=-lpthread --prefix=/usr --disable-debug \
+ --enable-hardcoded-font --disable-avif --disable-webp
make
}
package() {
- cd "${pkgname}-${pkgver}-${_pkgname}"
+ cd "${pkgname}-${pkgver}"
make DESTDIR=${pkgdir} install
}
diff --git a/fim.install b/fim.install
deleted file mode 100644
index ad956ab0b0bb..000000000000
--- a/fim.install
+++ /dev/null
@@ -1,22 +0,0 @@
-post_install() {
- cat <<EOF
-==> NOTE: If you already have FBFONT exported correctly, you can disregard this
-==> message.
-==>
-==> To get fim to work after you've installed it, place the following export in
-==> your ~/.profile file:
-==>
-==> export FBFONT=/usr/share/kbd/consolefonts/ter-216n.psf.gz
-==>
-==> Once this is done, log out and log back in to get your ~/.profile file
-==> read and the FBFONT variable exported.
-==>
-==> NOTE: If you place this export in your ~/.zshrc or your ~/.bashrc file, you
-==> don't need to logout. Simply starting a new session of your shell-of-choice
-==> will do the trick.
-EOF
-}
-
-post_upgrade() {
- post_install
-}