summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
-rw-r--r--fim.install (renamed from install)2
3 files changed, 33 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffc707083a61..4be78eb4105a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
-# Generated by mksrcinfo v8
-# Wed Jun 8 17:09:48 UTC 2016
pkgbase = fim
- pkgdesc = Highly customizable and scriptable framebuffer image viewer based on fbi.
- pkgver = 0.5
+ pkgdesc = FIM (Fbi IMproved) is a highly customizable and scriptable image viewer.
+ pkgver = 0.6
pkgrel = 1
- url = https://www.autistici.org/dezperado/fim/
- install = install
+ url = https://www.nongnu.org/fbi-improved/
+ install = fim.install
arch = i686
arch = x86_64
- license = GPL
+ license = GPL2
depends = giflib
depends = libjpeg-turbo
+ depends = libexif
+ depends = terminus-font
optdepends = djvulibre: djvu support
optdepends = libspectre: postscript support
optdepends = sdl: X support
optdepends = poppler: PDF support
conflicts = fim-svn
- options = !makeflags
- source = http://download.savannah.gnu.org/releases/fbi-improved/fim-0.5-rc2.tar.bz2
- md5sums = 01333ce38f1eacd60ad668a2ca38ac7e
+ source = https://download.savannah.gnu.org/releases/fbi-improved/fim-0.6-trunk.tar.gz
+ source = fim.install
+ sha256sums = f77f45d38cbd2ddb5a21ce48b6ecb44e7ddcf77d00635d7c7dbe74ea083b8b88
+ sha256sums = 8c647abb30baced37aaef6544b66ed2f8709b7ad6636d761f948d85c3071c536
pkgname = fim
diff --git a/PKGBUILD b/PKGBUILD
index e9e89759ab91..e6f30067fe5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,41 @@
-# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+# Contributor: Steven Honeyman <stevenhoneyman at gmail com>
# Contributor: Alexej Magura <agm2819*gmail*>
# Contributor: Dragonlord <dragonlord[at]seznam[.]cz>
# Contributor: daniel <quite a hack org>
pkgname=fim
-_pkgname='rc2'
-pkgver=0.5
+_pkgname='trunk'
+pkgver=0.6
pkgrel=1
-pkgdesc="Highly customizable and scriptable framebuffer image viewer based on fbi."
+pkgdesc='FIM (Fbi IMproved) is a highly customizable and scriptable image viewer.'
arch=('i686' 'x86_64')
conflicts=('fim-svn')
-url="https://www.autistici.org/dezperado/fim/"
-license=('GPL')
+url='https://www.nongnu.org/fbi-improved/'
+license=('GPL2')
optdepends=('djvulibre: djvu support'
'libspectre: postscript support'
'sdl: X support'
'poppler: PDF support')
-depends=('giflib' 'libjpeg-turbo')
-
-# It doesn't like to be parallel built
-options=(!makeflags)
-install=install
-source=("http://download.savannah.gnu.org/releases/fbi-improved/$pkgname-$pkgver-${_pkgname}.tar.bz2")
-md5sums=('01333ce38f1eacd60ad668a2ca38ac7e')
-
+depends=('giflib' 'libjpeg-turbo' 'libexif' 'terminus-font')
+install=${pkgname}.install
+source=("https://download.savannah.gnu.org/releases/fbi-improved/${pkgname}-${pkgver}-${_pkgname}.tar.gz"
+ "${pkgname}.install")
+sha256sums=('f77f45d38cbd2ddb5a21ce48b6ecb44e7ddcf77d00635d7c7dbe74ea083b8b88'
+ '8c647abb30baced37aaef6544b66ed2f8709b7ad6636d761f948d85c3071c536')
build() {
- cd "$srcdir/$pkgname-$pkgver-$_pkgname"
- ./configure --prefix=/usr --disable-debug --enable-unicode --enable-hardcoded-font \
- --enable-recursive-dirs --disable-xcftopnm --disable-inkscape \
- --disable-xfig --disable-dia --disable-imlib2
+ cd "${pkgname}-${pkgver}-${_pkgname}"
+
+ ./configure --prefix=/usr --disable-debug --enable-unicode \
+ --enable-hardcoded-font --disable-xcftopnm --disable-inkscape \
+ --disable-xfig --disable-dia --disable-imlib2
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver-$_pkgname"
- make DESTDIR=$pkgdir install
+ cd "${pkgname}-${pkgver}-${_pkgname}"
+
+ make DESTDIR=${pkgdir} install
}
diff --git a/install b/fim.install
index cb729b86ac6c..ad956ab0b0bb 100644
--- a/install
+++ b/fim.install
@@ -8,7 +8,7 @@ post_install() {
==>
==> export FBFONT=/usr/share/kbd/consolefonts/ter-216n.psf.gz
==>
-==> Once you've done that logout and log back in to get your ~/.profile file
+==> Once this is done, log out and log back in to get your ~/.profile file
==> read and the FBFONT variable exported.
==>
==> NOTE: If you place this export in your ~/.zshrc or your ~/.bashrc file, you