summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
-rwxr-xr-xlauncher.sh29
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f83e2dc8226
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fim-cli
+ pkgdesc = Fim manages the integrity of a complete file tree
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = https://evrignaud.github.io/fim
+ arch = any
+ license = GPL3
+ depends = java-runtime>=8
+ depends = sh
+ conflicts = fim
+ source = https://github.com/evrignaud/fim/releases/download/1.2.3/fim-1.2.3-distribution.tar.gz
+ source = launcher.sh
+ sha512sums = 7969f1b4b7e50c5ebf647bc5e5f296f0801d5a7844d8807b114602d70c64a238acaa847c5201466f6027a034eac2b6508a48260a4c2b5138475e34c54602b1a5
+ sha512sums = a9e85412436cdef7a7d55e5d83731204bf97e3193f4600f4bd3543f89667597f95583a56e0d8bbbb8b90ec6d36fa3eed6ee238ee199e45681de5f6e45470d48f
+
+pkgname = fim-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5e7d0255e92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: crasm <crasm@fim.email.vczf.io>
+pkgname='fim-cli'
+pkgver=1.2.3
+pkgrel=1
+pkgdesc="Fim manages the integrity of a complete file tree"
+arch=('any')
+url="https://evrignaud.github.io/fim"
+license=('GPL3')
+depends=('java-runtime>=8'
+ 'sh')
+conflicts=('fim')
+source=("https://github.com/evrignaud/fim/releases/download/$pkgver/fim-$pkgver-distribution.tar.gz"
+ "launcher.sh")
+sha512sums=('7969f1b4b7e50c5ebf647bc5e5f296f0801d5a7844d8807b114602d70c64a238acaa847c5201466f6027a034eac2b6508a48260a4c2b5138475e34c54602b1a5'
+ 'a9e85412436cdef7a7d55e5d83731204bf97e3193f4600f4bd3543f89667597f95583a56e0d8bbbb8b90ec6d36fa3eed6ee238ee199e45681de5f6e45470d48f')
+
+package() {
+ install -m 755 -D "./launcher.sh" "${pkgdir}/usr/bin/fim"
+ install -m 644 -D "./bin/fim-${pkgver}.jar" "${pkgdir}/usr/lib/fim/fim.jar"
+ install -m 755 -d css/ images/ slides/ "${pkgdir}/usr/share/doc/fim/"
+ install -m 644 -D *.html "${pkgdir}/usr/share/doc/fim/"
+}
diff --git a/launcher.sh b/launcher.sh
new file mode 100755
index 000000000000..fe0db636a8b0
--- /dev/null
+++ b/launcher.sh
@@ -0,0 +1,29 @@
+#!/bin/sh
+#-----------------------------------------------------------------------------------------------------------------------
+# This file is part of Fim - File Integrity Manager
+#
+# Copyright (C) 2017 Etienne Vrignaud
+#
+# Fim is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Fim is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Fim. If not, see <https://www.gnu.org/licenses/>.
+#-----------------------------------------------------------------------------------------------------------------------
+
+if type tput > /dev/null 2>&1; then
+ export TERMINAL_COLUMNS=$(tput cols)
+fi
+
+JAVA_OPTIONS="-Xmx2g -XX:MaxMetaspaceSize=128m"
+
+java ${JAVA_OPTIONS} -jar "/usr/lib/fim/fim.jar" "$@"
+
+#-----------------------------------------------------------------------------------------------------------------------