summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xfbrokendesktop.py2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c1ea9a8fc8f..4fcf21dac09d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = find-broken-desktop
pkgdesc = Find desktop entries files with broken executables. Similar in functionality to fbrokendesktop, but written in python to avoid some of the shortcomings of parsing .desktop files with shell scripts
pkgver = 1.3
- pkgrel = 1
+ pkgrel = 2
arch = any
license = MIT
depends = python
depends = python-pyxdg
source = fbrokendesktop.py
- sha256sums = 27cb59808bf8245041962a3fc576bb33a3d911745901c583694d77fbf44720e5
+ sha256sums = af8bfb0d6d587beeafea67a528b638a20f76eb436ce9fa9a89e8a0161ab2ec71
pkgname = find-broken-desktop
diff --git a/PKGBUILD b/PKGBUILD
index bf9136739977..d43b57ee923b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: FirstAirBender <noblechuk5[at]web[dot]de>
pkgname=find-broken-desktop
pkgver=1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Find desktop entries files with broken executables.
Similar in functionality to fbrokendesktop, but written in python to avoid some
of the shortcomings of parsing .desktop files with shell scripts"
@@ -9,7 +9,7 @@ arch=("any")
license=('MIT')
depends=('python' 'python-pyxdg')
source=("fbrokendesktop.py")
-sha256sums=('27cb59808bf8245041962a3fc576bb33a3d911745901c583694d77fbf44720e5')
+sha256sums=('af8bfb0d6d587beeafea67a528b638a20f76eb436ce9fa9a89e8a0161ab2ec71')
package() {
chmod +x fbrokendesktop.py
diff --git a/fbrokendesktop.py b/fbrokendesktop.py
index 6f793c7177c2..872b6b58d6e1 100755
--- a/fbrokendesktop.py
+++ b/fbrokendesktop.py
@@ -66,7 +66,7 @@ def find_missing_desktop_files(desktop_dir: str, show_all: bool):
if is_gapp_cmd(cmd):
if not is_valid_gapp_cmd(cmd[2]):
yield shlex.quote(de.getFileName())
- elif not shutil.which(cmd[0]):
+ elif not (cmd and shutil.which(cmd[0])):
yield shlex.quote(de.getFileName())
except ValueError as err:
print(f"Error parsing '{file_path}': {err}", file=sys.stderr)