summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..621f2e2bf14a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fipolate-custom
+ pkgdesc = Interpolate text files with variables through a fifo via user prompts.
+ pkgver = 2015.4
+ pkgrel = 1
+ url = https://github.com/djmattyg007/fipolate-custom
+ arch = any
+ license = GPL
+ depends = python3
+ depends = python-pyinotify
+ provides = fipolate
+ conflicts = fipolate
+ source = https://github.com/djmattyg007/fipolate-custom/archive/2015.4.tar.gz
+ sha256sums = 88eec9be64e396aee974a1a7ec79f7f61d62186bdb190eb3d42a974a506e3bec
+
+pkgname = fipolate-custom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac2e5bfc45d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Matthew Gamble
+
+pkgname=fipolate-custom
+pkgver=2015.4
+pkgrel=1
+pkgdesc='Interpolate text files with variables through a fifo via user prompts.'
+arch=(any)
+license=(GPL)
+url="https://github.com/djmattyg007/fipolate-custom"
+depends=(python3 python-pyinotify)
+provides=('fipolate')
+conflicts=('fipolate')
+source=("https://github.com/djmattyg007/fipolate-custom/archive/$pkgver.tar.gz")
+sha256sums=("88eec9be64e396aee974a1a7ec79f7f61d62186bdb190eb3d42a974a506e3bec")
+
+package () {
+ install -Dm755 "$srcdir/fipolate-custom-$pkgver/fipolate" "$pkgdir/usr/bin/fipolate"
+}