summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--firebird-gcc6.patch272
-rw-r--r--firebird-icu60.patch60
-rw-r--r--firebird-libio.patch13
5 files changed, 11 insertions, 377 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3099794bc068..2417f2d8f8fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Aug 20 12:50:31 UTC 2018
pkgbase = firebird-superserver
pkgdesc = A open source SQL relational database management system (RDMS)
- pkgver = 2.5.8.27089
- pkgrel = 4
+ pkgver = 2.5.9.27139
+ pkgrel = 1
url = http://www.firebirdsql.org/
install = firebird-superserver.install
arch = i686
@@ -12,29 +10,23 @@ pkgbase = firebird-superserver
license = custom:IDPL
depends = icu
depends = libedit
- provides = libfbclient=2.5.8.27089
+ provides = libfbclient=2.5.9.27139
conflicts = firebird-classicserver
conflicts = libfbclient
options = !makeflags
backup = etc/firebird/firebird.conf
backup = etc/firebird/fbtrace.conf
backup = etc/firebird/aliases.conf
- source = https://github.com/FirebirdSQL/firebird/releases/download/R2_5_8/Firebird-2.5.8.27089-0.tar.bz2
+ source = https://github.com/FirebirdSQL/firebird/releases/download/R2_5_9/Firebird-2.5.9.27139-0.tar.bz2
source = default.password
source = firebird-tmpfiles.conf
source = firebird-sysusers.conf
source = firebird.service
- source = firebird-icu60.patch
- source = firebird-gcc6.patch
- source = firebird-libio.patch
- md5sums = 38862a3da39cf91f4f2366fb510f18a6
+ md5sums = e32043e61511f53703df6c47441ff6ab
md5sums = ee601f52f1ba2481fe1f05b25d000bb8
md5sums = 79a1416e307e4dfb99640311b8defe07
md5sums = a43ab472f4d95e48ac21910bb33a5e86
md5sums = 90b4631c9bff99aab08511b3a184593e
- md5sums = 70197fc801f9c66a6a1d7710e0c63718
- md5sums = 9ab88cfcda674f9d28850a4f86f23741
- md5sums = 8e7cac6da439c8798dccf6d4b4e457db
pkgname = firebird-superserver
diff --git a/PKGBUILD b/PKGBUILD
index ab1cbe019293..b7322feec5cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Benjamin Bukowski <bbukowski@posteo.de>
pkgname=firebird-superserver
-_pkgver=2.5.8
-pkgver=$_pkgver.27089
-pkgrel=4
+_pkgver=2.5.9
+pkgver=$_pkgver.27139
+pkgrel=1
pkgdesc="A open source SQL relational database management system (RDMS)"
arch=('i686' 'x86_64')
url="http://www.firebirdsql.org/"
@@ -18,26 +18,13 @@ source=("https://github.com/FirebirdSQL/firebird/releases/download/R${_pkgver//.
'default.password'
'firebird-tmpfiles.conf'
'firebird-sysusers.conf'
- 'firebird.service'
- 'firebird-icu60.patch'
- 'firebird-gcc6.patch'
- 'firebird-libio.patch')
+ 'firebird.service')
-md5sums=('38862a3da39cf91f4f2366fb510f18a6'
+md5sums=('e32043e61511f53703df6c47441ff6ab'
'ee601f52f1ba2481fe1f05b25d000bb8'
'79a1416e307e4dfb99640311b8defe07'
'a43ab472f4d95e48ac21910bb33a5e86'
- '90b4631c9bff99aab08511b3a184593e'
- '70197fc801f9c66a6a1d7710e0c63718'
- '9ab88cfcda674f9d28850a4f86f23741'
- '8e7cac6da439c8798dccf6d4b4e457db')
-
-prepare() {
- cd $srcdir/Firebird-$pkgver-0
- patch -Np1 -i ../firebird-icu60.patch
- patch -Np1 -i ../firebird-gcc6.patch
- patch -Np1 -i ../firebird-libio.patch
-}
+ '90b4631c9bff99aab08511b3a184593e')
build() {
cd $srcdir/Firebird-$pkgver-0
diff --git a/firebird-gcc6.patch b/firebird-gcc6.patch
deleted file mode 100644
index 1bc69073c13d..000000000000
--- a/firebird-gcc6.patch
+++ /dev/null
@@ -1,272 +0,0 @@
-From acb2b707dae178dd5a7a03eb3e21d885ba971974 Mon Sep 17 00:00:00 2001
-From: AlexPeshkoff <alexander.peshkoff@gmail.com>
-Date: Tue, 23 Jan 2018 19:44:06 +0300
-Subject: [PATCH] Make it build with gcc6, also fixed most annoying warnings
-
----
- builds/posix/prefix.linux | 2 +-
- builds/posix/prefix.linux_amd64 | 2 +-
- builds/posix/prefix.linux_generic | 2 +-
- src/common/classes/alloc.cpp | 11 ++++-
- src/common/classes/alloc.h | 84 ++++++++++++++++++++++-----------------
- src/include/fb_blk.h | 17 ++++----
- src/jrd/gdsassert.h | 2 +-
- 7 files changed, 68 insertions(+), 52 deletions(-)
-
-diff --git a/builds/posix/prefix.linux b/builds/posix/prefix.linux
-index 61f01813e4..b37373215e 100644
---- a/builds/posix/prefix.linux
-+++ b/builds/posix/prefix.linux
-@@ -18,7 +18,7 @@
- #
- # 2 Oct 2002, Nickolay Samofatov - Major cleanup
-
--COMMON_FLAGS=-ggdb -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -pipe -MMD -fPIC -fmessage-length=0
-+COMMON_FLAGS=-ggdb -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -pipe -MMD -fPIC -fmessage-length=0 -std=gnu++03 -fno-delete-null-pointer-checks
- OPTIMIZE_FLAGS=-O3 -march=i586 -mtune=i686 -fno-omit-frame-pointer
- WARN_FLAGS=-Wall -Wno-switch -Wno-parentheses -Wno-unknown-pragmas -Wno-unused-variable
-
-diff --git a/builds/posix/prefix.linux_amd64 b/builds/posix/prefix.linux_amd64
-index 8a22b2c2e9..4f20d0aaea 100644
---- a/builds/posix/prefix.linux_amd64
-+++ b/builds/posix/prefix.linux_amd64
-@@ -18,7 +18,7 @@
- #
- # 2 Oct 2002, Nickolay Samofatov - Major cleanup
-
--COMMON_FLAGS=-ggdb -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -DAMD64 -pipe -MMD -fPIC -fmessage-length=0
-+COMMON_FLAGS=-ggdb -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -DAMD64 -pipe -MMD -fPIC -fmessage-length=0 -std=gnu++03 -fno-delete-null-pointer-checks
- OPTIMIZE_FLAGS=-O3 -fno-omit-frame-pointer
- WARN_FLAGS=-Wall -Wno-switch -Wno-parentheses -Wno-unknown-pragmas -Wno-unused-variable
- CXXFLAGS:= $(CXXFLAGS) -fno-rtti
-diff --git a/builds/posix/prefix.linux_generic b/builds/posix/prefix.linux_generic
-index 1a25abebff..130f43bcf6 100644
---- a/builds/posix/prefix.linux_generic
-+++ b/builds/posix/prefix.linux_generic
-@@ -18,7 +18,7 @@
- #
- # 2 Oct 2002, Nickolay Samofatov - Major cleanup
-
--COMMON_FLAGS=-DLINUX -pipe -MMD -fPIC -DFB_SEND_FLAGS=MSG_NOSIGNAL -fsigned-char
-+COMMON_FLAGS=-DLINUX -pipe -MMD -fPIC -DFB_SEND_FLAGS=MSG_NOSIGNAL -fsigned-char -std=gnu++03 -fno-delete-null-pointer-checks
-
- PROD_FLAGS=-ggdb -O3 -DNDEBUG $(COMMON_FLAGS)
- DEV_FLAGS=-ggdb -p -Wall -Wno-switch $(COMMON_FLAGS)
-diff --git a/src/common/classes/alloc.cpp b/src/common/classes/alloc.cpp
-index 7a7a76caab..84238cf25c 100644
---- a/src/common/classes/alloc.cpp
-+++ b/src/common/classes/alloc.cpp
-@@ -2199,6 +2199,13 @@ void* MemoryPool::globalAlloc(size_t s) THROW_BAD_ALLOC
- }
- #endif // LIBC_CALLS_NEW
-
-+void* MemoryPool::calloc(size_t size ALLOC_PARAMS)
-+{
-+ void* block = allocate(size ALLOC_PASS_ARGS);
-+ memset(block, 0, size);
-+ return block;
-+}
-+
- #if defined(DEV_BUILD)
- void AutoStorage::ProbeStack() const
- {
-@@ -2224,11 +2231,11 @@ void AutoStorage::ProbeStack() const
-
- void* operator new(size_t s) THROW_BAD_ALLOC
- {
-- return Firebird::MemoryPool::globalAlloc(s);
-+ return Firebird::MemoryPool::globalAlloc(s ALLOC_ARGS);
- }
- void* operator new[](size_t s) THROW_BAD_ALLOC
- {
-- return Firebird::MemoryPool::globalAlloc(s);
-+ return Firebird::MemoryPool::globalAlloc(s ALLOC_ARGS);
- }
-
- void operator delete(void* mem) throw()
-diff --git a/src/common/classes/alloc.h b/src/common/classes/alloc.h
-index 6a27a7b4fb..81a26feffa 100644
---- a/src/common/classes/alloc.h
-+++ b/src/common/classes/alloc.h
-@@ -73,6 +73,16 @@
-
- #endif
-
-+#ifdef DEBUG_GDS_ALLOC
-+#define ALLOC_ARGS , __FILE__, __LINE__
-+#define ALLOC_PARAMS , const char* file, int line
-+#define ALLOC_PASS_ARGS , file, line
-+#else
-+#define ALLOC_ARGS
-+#define ALLOC_PARAMS
-+#define ALLOC_PASS_ARGS
-+#endif // DEBUG_GDS_ALLOC
-+
- namespace Firebird {
-
- // Maximum number of B+ tree pages kept spare for tree allocation
-@@ -395,15 +405,11 @@ class MemoryPool
- // This method is needed when C++ runtime can call
- // redefined by us operator new before initialization of global variables.
- #ifdef LIBC_CALLS_NEW
-- static void* globalAlloc(size_t s) THROW_BAD_ALLOC;
-+ static void* globalAlloc(size_t s ALLOC_PARAMS) THROW_BAD_ALLOC;
- #else // LIBC_CALLS_NEW
-- static void* globalAlloc(size_t s) THROW_BAD_ALLOC
-+ static void* globalAlloc(size_t s ALLOC_PARAMS) THROW_BAD_ALLOC
- {
-- return processMemoryPool->allocate(s
--#ifdef DEBUG_GDS_ALLOC
-- ,__FILE__, __LINE__
--#endif
-- );
-+ return processMemoryPool->allocate(s ALLOC_PASS_ARGS);
- }
- #endif // LIBC_CALLS_NEW
-
-@@ -424,19 +430,7 @@ class MemoryPool
- }
-
- // Allocate zero-initialized block of memory
-- void* calloc(size_t size
--#ifdef DEBUG_GDS_ALLOC
-- , const char* file = NULL, int line = 0
--#endif
-- ) {
-- void* result = allocate(size
--#ifdef DEBUG_GDS_ALLOC
-- , file, line
--#endif
-- );
-- memset(result, 0, size);
-- return result;
-- }
-+ void* calloc(size_t size ALLOC_PARAMS);
-
- // Initialize and finalize global memory pool
- static void init();
-@@ -498,40 +492,58 @@ using Firebird::MemoryPool;
-
- inline static MemoryPool* getDefaultMemoryPool() { return Firebird::MemoryPool::processMemoryPool; }
-
--#if (( ! __GNUC__ ) || ( __GNUC__ < 6 ))
-+// operators new and delete
-
--// Global versions of operators new and delete
- void* operator new(size_t s) THROW_BAD_ALLOC;
- void* operator new[](size_t s) THROW_BAD_ALLOC;
-
--#endif
--
- void operator delete(void* mem) throw();
- void operator delete[](void* mem) throw();
-
-+inline void* operator new(size_t s, Firebird::MemoryPool& pool ALLOC_PARAMS) THROW_BAD_ALLOC
-+{
-+ return pool.allocate(s ALLOC_PASS_ARGS);
-+}
-+inline void* operator new[](size_t s, Firebird::MemoryPool& pool ALLOC_PARAMS) THROW_BAD_ALLOC
-+{
-+ return pool.allocate(s ALLOC_PASS_ARGS);
-+}
-+
-+inline void operator delete(void* mem, Firebird::MemoryPool& pool ALLOC_PARAMS) throw()
-+{
-+ MemoryPool::globalFree(mem);
-+}
-+inline void operator delete[](void* mem, Firebird::MemoryPool& pool ALLOC_PARAMS) throw()
-+{
-+ MemoryPool::globalFree(mem);
-+}
-+
- #ifdef DEBUG_GDS_ALLOC
--inline void* operator new(size_t s, Firebird::MemoryPool& pool, const char* file, int line)
-+
-+inline void* operator new(size_t s ALLOC_PARAMS) THROW_BAD_ALLOC
- {
-- return pool.allocate(s, file, line);
-+ return MemoryPool::globalAlloc(s ALLOC_PASS_ARGS);
- }
--inline void* operator new[](size_t s, Firebird::MemoryPool& pool, const char* file, int line)
-+inline void* operator new[](size_t s ALLOC_PARAMS) THROW_BAD_ALLOC
- {
-- return pool.allocate(s, file, line);
-+ return MemoryPool::globalAlloc(s ALLOC_PASS_ARGS);
- }
--#define FB_NEW(pool) new(pool, __FILE__, __LINE__)
--#define FB_NEW_RPT(pool, count) new(pool, count, __FILE__, __LINE__)
--#else
--inline void* operator new(size_t s, Firebird::MemoryPool& pool)
-+
-+inline void operator delete(void* mem ALLOC_PARAMS) throw()
- {
-- return pool.allocate(s);
-+ MemoryPool::globalFree(mem);
- }
--inline void* operator new[](size_t s, Firebird::MemoryPool& pool)
-+inline void operator delete[](void* mem ALLOC_PARAMS) throw()
- {
-- return pool.allocate(s);
-+ MemoryPool::globalFree(mem);
- }
-+
-+#define FB_NEW(pool) new(pool, __FILE__, __LINE__)
-+#define FB_NEW_RPT(pool, count) new(pool, count, __FILE__, __LINE__)
-+#else // DEBUG_GDS_ALLOC
- #define FB_NEW(pool) new(pool)
- #define FB_NEW_RPT(pool, count) new(pool, count)
--#endif
-+#endif // DEBUG_GDS_ALLOC
-
-
- namespace Firebird
-diff --git a/src/include/fb_blk.h b/src/include/fb_blk.h
-index b57443f3c4..fdd894408b 100644
---- a/src/include/fb_blk.h
-+++ b/src/include/fb_blk.h
-@@ -170,8 +170,8 @@ class pool_alloc : public TypedHandle<BLOCK_TYPE>
-
- private:
- // These operators are off-limits
-- void* operator new(size_t s) { return 0; }
-- void* operator new[](size_t s) { return 0; }
-+ void* operator new(size_t s);
-+ void* operator new[](size_t s);
- };
-
- template<typename RPT, BlockType BLOCK_TYPE = type_unknown>
-@@ -193,16 +193,13 @@ class pool_alloc_rpt : public TypedHandle<BLOCK_TYPE>
-
- private:
- // These operations are not supported on static repeat-base objects
-- void* operator new[](size_t s, MemoryPool& p)
-- { return 0; }
-- void operator delete[](void* mem, MemoryPool& p)
-- { }
-- void operator delete[](void* mem)
-- { }
-+ void* operator new[](size_t s, MemoryPool& p);
-+ void operator delete[](void* mem, MemoryPool& p);
-+ void operator delete[](void* mem);
-
- // These operators are off-limits
-- void* operator new(size_t s) { return 0; }
-- void* operator new[](size_t s) { return 0; }
-+ void* operator new(size_t s);
-+ void* operator new[](size_t s);
- };
-
- #endif // INCLUDE_FB_BLK
-diff --git a/src/jrd/gdsassert.h b/src/jrd/gdsassert.h
-index 9431479fc7..dd90c38823 100644
---- a/src/jrd/gdsassert.h
-+++ b/src/jrd/gdsassert.h
-@@ -28,7 +28,7 @@
- #include <stdlib.h> // abort()
- #include <stdio.h>
-
--#define FB_ASSERT_FAILURE_STRING "Assertion (%s) failure: %s %"LINEFORMAT"\n"
-+#define FB_ASSERT_FAILURE_STRING "Assertion (%s) failure: %s %" LINEFORMAT "\n"
-
- #ifdef SUPERCLIENT
-
diff --git a/firebird-icu60.patch b/firebird-icu60.patch
deleted file mode 100644
index 6e6340e84d28..000000000000
--- a/firebird-icu60.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 317ab524ddb41f8d41c16b9d4fe7e87bb953883b Mon Sep 17 00:00:00 2001
-From: AlexPeshkoff <alexander.peshkoff@gmail.com>
-Date: Sat, 10 Feb 2018 19:53:37 +0300
-Subject: [PATCH] Make it build with icu60
-
----
- src/intl/cs_icu.cpp | 5 +++++
- src/intl/cv_icu.cpp | 5 +++++
- src/jrd/unicode_util.cpp | 6 ++++++
- 3 files changed, 16 insertions(+)
-
-diff --git a/src/intl/cs_icu.cpp b/src/intl/cs_icu.cpp
-index c4f9a3f52e..94e32540cf 100644
---- a/src/intl/cs_icu.cpp
-+++ b/src/intl/cs_icu.cpp
-@@ -28,6 +28,11 @@
- #include "../intl/ldcommon.h"
- #include "cs_icu.h"
- #include "cv_icu.h"
-+
-+#undef U_SHOW_CPLUSPLUS_API
-+#define U_SHOW_CPLUSPLUS_API 0
-+#undef UCHAR_TYPE
-+#define UCHAR_TYPE uint16_t
- #include "unicode/ucnv.h"
-
-
-diff --git a/src/intl/cv_icu.cpp b/src/intl/cv_icu.cpp
-index f5f559f011..f226cc25de 100644
---- a/src/intl/cv_icu.cpp
-+++ b/src/intl/cv_icu.cpp
-@@ -28,6 +28,11 @@
- #include "../intl/ldcommon.h"
- #include "ld_proto.h"
- #include "cv_icu.h"
-+
-+#undef U_SHOW_CPLUSPLUS_API
-+#define U_SHOW_CPLUSPLUS_API 0
-+#undef UCHAR_TYPE
-+#define UCHAR_TYPE uint16_t
- #include "unicode/ucnv.h"
-
-
-diff --git a/src/jrd/unicode_util.cpp b/src/jrd/unicode_util.cpp
-index 19f7016d8d..bda87f9b25 100644
---- a/src/jrd/unicode_util.cpp
-+++ b/src/jrd/unicode_util.cpp
-@@ -37,6 +37,12 @@
- #include "../common/classes/init.h"
- #include "../common/classes/objects_array.h"
- #include "../common/classes/rwlock.h"
-+
-+#undef U_SHOW_CPLUSPLUS_API
-+#define U_SHOW_CPLUSPLUS_API 0
-+#undef UCHAR_TYPE
-+#define UCHAR_TYPE uint16_t
-+
- #include "unicode/ustring.h"
- #include "unicode/utrans.h"
- #include "unicode/uchar.h"
diff --git a/firebird-libio.patch b/firebird-libio.patch
deleted file mode 100644
index e54cb6aa43c7..000000000000
--- a/firebird-libio.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/src/jrd/perf.h 2018-01-05
-+++ b/src/jrd/perf.h 2018-08-20
-@@ -31,10 +31,6 @@
- #ifndef JRD_PERF_H
- #define JRD_PERF_H
-
--#ifdef LINUX
--#include <libio.h>
--#endif
--
- #ifdef HAVE_TIMES
- #include <sys/types.h>
- #include <sys/times.h>