summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--.gitlab-ci.yml25
-rw-r--r--PKGBUILD62
4 files changed, 66 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6218c342933..7c17c1ce3c5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-pkgbase = firedragon
- pkgdesc = Librewolf fork build using custom branding, settings & KDE patches by OpenSUSE
+pkgbase = firedragon-unsigned-extensions
+ pkgdesc = FireDragon modified to allow installation of unsigned extensions
pkgver = 116.0.2
pkgrel = 1
url = https://gitlab.com/dr460nf1r3/settings/
@@ -61,6 +61,8 @@ pkgbase = firedragon
optdepends = libappindicator-gtk3: Global menu support for GTK apps
optdepends = appmenu-gtk-module-git: Appmenu for GTK only
optdepends = plasma5-applets-window-appmenu: Appmenu for Plasma only
+ provides = firedragon
+ conflicts = firedragon
options = !emptydirs
options = !makeflags
options = !strip
@@ -73,11 +75,11 @@ pkgbase = firedragon
source = firedragon.desktop
source = git+https://gitlab.com/dr460nf1r3/common.git
source = git+https://gitlab.com/dr460nf1r3/settings.git
- source = librewolf-source::git+https://gitlab.com/librewolf-community/browser/source.git
+ source = librewolf-source::git+https://gitlab.com/librewolf-community/browser/source.git#tag=116.0.2-1
source = librewolf-settings::git+https://gitlab.com/librewolf-community/settings.git
source = cachyos-source::git+https://github.com/CachyOS/CachyOS-Browser-Common.git
validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
- sha256sums = 6708ab24a748de336aff4789f97f248452a46117e86bb6b4b9746768e52fb114
+ sha256sums = 6b2844124c13b4bd9d97ac7f5840f3e957b7631659591f3bea1ac9a89bee1654
sha256sums = SKIP
sha256sums = 53d3e743f3750522318a786befa196237892c93f20571443fdf82a480e7f0560
sha256sums = SKIP
@@ -86,4 +88,4 @@ pkgbase = firedragon
sha256sums = SKIP
sha256sums = SKIP
-pkgname = firedragon
+pkgname = firedragon-unsigned-extensions
diff --git a/.gitignore b/.gitignore
index c90e38626aaa..e37aca9291a5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,4 @@ cachyos-source
librewolf-settings
librewolf-source
*.tar.xz*
+*.tar.zst*
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..bb2aba532cc9
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,25 @@
+stages:
+ - build
+ - publish
+
+build:
+ stage: build
+ image: registry.stefanwimmer128.io/stefanwimmer128/archlinux-chaotic-paru-user:latest
+ before_script:
+ - gpg --keyserver keys.openpgp.org --recv-key 14F26682D0916CDD81E37B6D61B7B526D98F0353
+ - paru -Syu --noconfirm
+ script:
+ - makepkg -s --noconfirm
+ artifacts:
+ paths:
+ - "*.pkg.tar.zst"
+ timeout: 2h
+
+publish:
+ stage: publish
+ image: alpine:latest
+ rules:
+ - if: $CI_COMMIT_TAG
+ script:
+ - apk add curl
+ - 'curl --header "JOB-TOKEN: $CI_JOB_TOKEN" --upload-file "firedragon-unsigned-extensions-$CI_COMMIT_TAG-x86_64.pkg.tar.zst" "$CI_API_V4_URL/projects/$CI_PROJECT_ID/packages/generic/firedragon-unsigned-extensions/$CI_COMMIT_TAG/firedragon-unsigned-extensions-$CI_COMMIT_TAG-x86_64.pkg.tar.zst"'
diff --git a/PKGBUILD b/PKGBUILD
index bd2daff27836..c6b42880651b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
-# Maintainer: dr460nf1r3 <dr460nf1r3 at garudalinux dot org>
-# Co-Maintainer: FGD
+# Maintainer: stefanwimmer128 <info at stefanwimmer128 dot io>
+# Contributor: dr460nf1r3 <dr460nf1r3 at garudalinux dot org>
+# Contributor: FGD
# Contributor: Peter Jung <admin@ptr1337.dev>
# Contributor: vnepogodin
# Contributor: torvic9 AT mailbox DOT org
# Contributor: lsf
-pkgname=firedragon
+__pkgname=firedragon
+pkgname=$__pkgname-unsigned-extensions
_pkgname=FireDragon
pkgver=116.0.2
pkgrel=1
-pkgdesc="Librewolf fork build using custom branding, settings & KDE patches by OpenSUSE"
+pkgdesc="FireDragon modified to allow installation of unsigned extensions"
arch=(x86_64 x86_64_v3 aarch64)
backup=('usr/lib/firedragon/firedragon.cfg'
'usr/lib/firedragon/distribution/policies.json')
@@ -34,16 +36,18 @@ optdepends=('firejail-git: Sandboxing the browser using the included profiles'
'libappindicator-gtk3: Global menu support for GTK apps'
'appmenu-gtk-module-git: Appmenu for GTK only'
'plasma5-applets-window-appmenu: Appmenu for Plasma only')
+provides=("firedragon")
+conflicts=("firedragon")
options=(!emptydirs !makeflags !strip !lto !debug)
-install=$pkgname.install
+install=$__pkgname.install
source=(https://archive.mozilla.org/pub/firefox/releases/"$pkgver"/source/firefox-"$pkgver".source.tar.xz{,.asc}
- "$pkgname.desktop"
+ "$__pkgname.desktop"
"git+https://gitlab.com/dr460nf1r3/common.git"
"git+https://gitlab.com/dr460nf1r3/settings.git"
- "librewolf-source::git+https://gitlab.com/librewolf-community/browser/source.git"
+ "librewolf-source::git+https://gitlab.com/librewolf-community/browser/source.git#tag=116.0.2-1"
"librewolf-settings::git+https://gitlab.com/librewolf-community/settings.git"
"cachyos-source::git+https://github.com/CachyOS/CachyOS-Browser-Common.git")
-sha256sums=('6708ab24a748de336aff4789f97f248452a46117e86bb6b4b9746768e52fb114'
+ sha256sums=('6708ab24a748de336aff4789f97f248452a46117e86bb6b4b9746768e52fb114'
'SKIP'
'53d3e743f3750522318a786befa196237892c93f20571443fdf82a480e7f0560'
'SKIP'
@@ -116,11 +120,11 @@ export RANLIB=llvm-ranlib
# Branding
ac_add_options --allow-addon-sideload
ac_add_options --enable-update-channel=release
-ac_add_options --with-app-name=${pkgname}
-ac_add_options --with-branding=browser/branding/${pkgname}
+ac_add_options --with-app-name=${__pkgname}
+ac_add_options --with-branding=browser/branding/${__pkgname}
ac_add_options --with-distribution-id=org.garudalinux
ac_add_options --with-unsigned-addon-scopes=app,system
-export MOZ_REQUIRE_SIGNING=1
+export MOZ_REQUIRE_SIGNING=
# System libraries
ac_add_options --with-system-nspr
@@ -325,12 +329,12 @@ package() {
cd firefox-"$pkgver"
DESTDIR="$pkgdir" ./mach install
- rm "$pkgdir"/usr/lib/${pkgname}/pingsender
+ rm "$pkgdir"/usr/lib/${__pkgname}/pingsender
- install -Dvm644 "$srcdir/settings/$pkgname.psd" "$pkgdir/usr/share/psd/browsers/$pkgname"
+ install -Dvm644 "$srcdir/settings/$__pkgname.psd" "$pkgdir/usr/share/psd/browsers/$__pkgname"
local vendorjs
- vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
+ vendorjs="$pkgdir/usr/lib/$__pkgname/browser/defaults/preferences/vendor.js"
install -Dvm644 /dev/stdin "$vendorjs" <<END
// Use system-provided dictionaries
@@ -344,9 +348,9 @@ END
# cd ${srcdir}/settings
# git checkout ${_settings_commit}
cd ${srcdir}/firefox-"$pkgver"
- cp -r ${srcdir}/settings/* ${pkgdir}/usr/lib/${pkgname}/
+ cp -r ${srcdir}/settings/* ${pkgdir}/usr/lib/${__pkgname}/
- local distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
+ local distini="$pkgdir/usr/lib/$__pkgname/distribution/distribution.ini"
install -Dvm644 /dev/stdin "$distini" <<END
[Global]
@@ -356,36 +360,36 @@ about=$_pkgname for Garuda Linux
[Preferences]
app.distributor=garudalinux
-app.distributor.channel=$pkgname
+app.distributor.channel=$__pkgname
app.partner.garudalinux=garudalinux
END
for i in 16 32 48 64 128; do
- install -Dvm644 browser/branding/${pkgname}/default$i.png \
- "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
+ install -Dvm644 browser/branding/${__pkgname}/default$i.png \
+ "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$__pkgname.png"
done
- install -Dvm644 browser/branding/${pkgname}/content/about-logo.png \
- "$pkgdir/usr/share/icons/hicolor/192x192/apps/$pkgname.png"
+ install -Dvm644 browser/branding/${__pkgname}/content/about-logo.png \
+ "$pkgdir/usr/share/icons/hicolor/192x192/apps/$__pkgname.png"
# Arch upstream provides a separate svg for this. we don't have that, so let's re-use 16.png
- install -Dvm644 browser/branding/${pkgname}/default16.png \
- "$pkgdir/usr/share/icons/hicolor/symbolic/apps/$pkgname-symbolic.png"
+ install -Dvm644 browser/branding/${__pkgname}/default16.png \
+ "$pkgdir/usr/share/icons/hicolor/symbolic/apps/$__pkgname-symbolic.png"
- install -Dvm644 ../$pkgname.desktop \
- "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dvm644 ../$__pkgname.desktop \
+ "$pkgdir/usr/share/applications/$__pkgname.desktop"
# Install a wrapper to avoid confusion about binary path
- install -Dvm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
+ install -Dvm755 /dev/stdin "$pkgdir/usr/bin/$__pkgname" <<END
#!/bin/sh
-exec /usr/lib/$pkgname/$pkgname "\$@"
+exec /usr/lib/$__pkgname/$__pkgname "\$@"
END
# Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -srfv "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/lib/$pkgname/$pkgname-bin"
+ ln -srfv "$pkgdir/usr/bin/$__pkgname" "$pkgdir/usr/lib/$__pkgname/$__pkgname-bin"
# Use system certificates
- local nssckbi="$pkgdir/usr/lib/$pkgname/libnssckbi.so"
+ local nssckbi="$pkgdir/usr/lib/$__pkgname/libnssckbi.so"
if [[ -e $nssckbi ]]; then
ln -srfv "$pkgdir/usr/lib/libnssckbi.so" "$nssckbi"
fi