summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
-rw-r--r--firefly-iota-desktop.sh19
3 files changed, 26 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f9801da7d4c..3c7a088a2b67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = firefly-iota-desktop-bin
pkgdesc = Manage your IOTA assets directly from your computer with both software and hardware wallet support. Earn staking rewards and participate in governance votes.
- pkgver = 2.0.9
- pkgrel = 2
+ pkgver = 2.0.10
+ pkgrel = 1
url = https://firefly.iota.org/
arch = x86_64
license = Apache-2.0
makedepends = fuse2
depends = electron27
- provides = firefly-iota-desktop=2.0.9
+ provides = firefly-iota-desktop=2.0.10
conflicts = firefly-iota-desktop
conflicts = iota-firefly-wallet
- source = firefly-iota-desktop-2.0.9.AppImage::https://github.com/iotaledger/firefly/releases/download/desktop-iota-2.0.9/firefly-iota-desktop-2.0.9.AppImage
+ source = firefly-iota-desktop-2.0.10.AppImage::https://github.com/iotaledger/firefly/releases/download/desktop-iota-2.0.10/firefly-iota-desktop-2.0.10.AppImage
source = firefly-iota-desktop.sh
- sha256sums = 1fecfb2a80d416b33e8862d92e1e7c5c2f1f2ca86caf766e92e6f1cc543b334a
- sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+ sha256sums = cdbedf97ad9cda1c10227a8795c8633f4d55cece508113354a5cfc303e3435b7
+ sha256sums = 05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a
pkgname = firefly-iota-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3c136dabcaa0..e7ef932e4a2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=firefly-iota-desktop-bin
-pkgver=2.0.9
+pkgver=2.0.10
_electronversion=27
-pkgrel=2
+pkgrel=1
pkgdesc="Manage your IOTA assets directly from your computer with both software and hardware wallet support. Earn staking rewards and participate in governance votes."
arch=('x86_64')
url="https://firefly.iota.org/"
@@ -23,8 +23,8 @@ source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/desktop-iota-${pkgver}/${pkgname%-bin}-${pkgver}.AppImage"
"${pkgname%-bin}.sh"
)
-sha256sums=('1fecfb2a80d416b33e8862d92e1e7c5c2f1f2ca86caf766e92e6f1cc543b334a'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+sha256sums=('cdbedf97ad9cda1c10227a8795c8633f4d55cece508113354a5cfc303e3435b7'
+ '05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/firefly-iota-desktop.sh b/firefly-iota-desktop.sh
index 7ddcaab8d734..5594e5380ba2 100644
--- a/firefly-iota-desktop.sh
+++ b/firefly-iota-desktop.sh
@@ -7,10 +7,23 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export ELECTRON_FORCE_IS_PACKAGED=true
+export ELECTRON_DISABLE_SECURITY_WARNINGS=true
+export ELECTRON_OVERRIDE_DIST_PATH="/usr/bin/electron@electronversion@"
export NODE_ENV=production
+export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
+_FLAGS_FILE="${XDG_CONFIG_HOME}/@appname@-flags.conf"
+declare -a flags
+if [[ -f "${_FLAGS_FILE}" ]]; then
+ mapfile -t < "${_FLAGS_FILE}"
+fi
+for line in "${MAPFILE[@]}"; do
+ if [[ ! "${line}" =~ ^[[:space:]]*#.* ]] && [[ -n "${line}" ]]; then
+ flags+=("${line}")
+ fi
+done
cd "${_APPDIR}"
-if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS}" "$@" || exit $?
fi \ No newline at end of file