summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--0001-Use-remoting-name-for-GDK-application-names.patch56
-rw-r--r--PKGBUILD28
-rw-r--r--firefox.desktop2
4 files changed, 83 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccd0dc8d3731..9b2a1356109f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = firefox-appmenu
- pkgdesc = Firefox from extra with appmenu patch
- pkgver = 68.0
- pkgrel = 1
- url = https://aur.archlinux.org/packages/firefox-appmenu/
+ pkgdesc = Standalone web browser from mozilla.org
+ pkgver = 68.0.1
+ pkgrel = 2
+ url = https://www.mozilla.org/firefox/
arch = x86_64
license = MPL
license = GPL
@@ -42,19 +42,20 @@ pkgbase = firefox-appmenu
optdepends = pulseaudio: Audio support
optdepends = speech-dispatcher: Text-to-Speech
optdepends = hunspell-en_US: Spell checking, American English
- provides = firefox=68.0
- conflicts = firefox
options = !emptydirs
options = !makeflags
- source = https://archive.mozilla.org/pub/firefox/releases/68.0/source/firefox-68.0.source.tar.xz
- source = https://archive.mozilla.org/pub/firefox/releases/68.0/source/firefox-68.0.source.tar.xz.asc
+ options = !strip
+ source = https://archive.mozilla.org/pub/firefox/releases/68.0.1/source/firefox-68.0.1.source.tar.xz
+ source = https://archive.mozilla.org/pub/firefox/releases/68.0.1/source/firefox-68.0.1.source.tar.xz.asc
+ source = 0001-Use-remoting-name-for-GDK-application-names.patch
source = firefox.desktop
source = firefox-symbolic.svg
source = unity-menubar.patch
validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
- sha256sums = f7d61a08820088f1280d27f0808e355152c1dd0c94625fd077ced7319e522565
+ sha256sums = 6037f77bdab29d79ca5e3fbd1d32f6c209e09d2066189a13dc7f7491227f5568
sha256sums = SKIP
- sha256sums = e8d2908727309a58bee9a3dc994e85140c5977b2d486381d67d5e22ad3830d28
+ sha256sums = ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894
+ sha256sums = e466789015e15be9409b7a7044353674ca6aa0f392e882217f90c79821fe2630
sha256sums = 9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797
sha256sums = 03684be59adac8ab83c4c5cad3156879983b6d1311555fcaa8476684730d94f8
diff --git a/0001-Use-remoting-name-for-GDK-application-names.patch b/0001-Use-remoting-name-for-GDK-application-names.patch
new file mode 100644
index 000000000000..8cc378636c19
--- /dev/null
+++ b/0001-Use-remoting-name-for-GDK-application-names.patch
@@ -0,0 +1,56 @@
+From 1cab10b39cfda068100cab8c598f1ca0f50e4131 Mon Sep 17 00:00:00 2001
+Message-Id: <1cab10b39cfda068100cab8c598f1ca0f50e4131.1553597287.git.jan.steffens@gmail.com>
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Mon, 25 Mar 2019 20:30:11 +0100
+Subject: [PATCH] Use remoting name for GDK application names
+
+---
+ toolkit/xre/nsAppRunner.cpp | 6 +-----
+ widget/gtk/nsAppShell.cpp | 7 +++----
+ 2 files changed, 4 insertions(+), 9 deletions(-)
+
+diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
+index 0b808ef215f06..28911c0ffeaec 100644
+--- a/toolkit/xre/nsAppRunner.cpp
++++ b/toolkit/xre/nsAppRunner.cpp
+@@ -3728,11 +3728,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
+ // consistently.
+
+ // Set program name to the one defined in application.ini.
+- {
+- nsAutoCString program(gAppData->name);
+- ToLowerCase(program);
+- g_set_prgname(program.get());
+- }
++ g_set_prgname(gAppData->remotingName);
+
+ // Initialize GTK here for splash.
+
+diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
+index 0686ff814916b..ae4a4ea55f420 100644
+--- a/widget/gtk/nsAppShell.cpp
++++ b/widget/gtk/nsAppShell.cpp
+@@ -24,6 +24,7 @@
+ # include "WakeLockListener.h"
+ #endif
+ #include "gfxPlatform.h"
++#include "nsAppRunner.h"
+ #include "ScreenHelperGTK.h"
+ #include "HeadlessScreenHelper.h"
+ #include "mozilla/widget/ScreenManager.h"
+@@ -171,10 +172,8 @@ nsresult nsAppShell::Init() {
+ // option when program uses gdk_set_program_class().
+ //
+ // See https://bugzilla.gnome.org/show_bug.cgi?id=747634
+- nsAutoString brandName;
+- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
+- if (!brandName.IsEmpty()) {
+- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
++ if (gAppData) {
++ gdk_set_program_class(gAppData->remotingName);
+ }
+ }
+
+--
+2.21.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 25204580a7fc..3ed4c0f328a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
pkgname=firefox-appmenu
_pkgname=firefox
-pkgver=68.0
-pkgrel=1
-pkgdesc="Firefox from extra with appmenu patch"
+pkgver=68.0.1
+pkgrel=2
+pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
-url="https://aur.archlinux.org/packages/firefox-appmenu/"
+url="https://www.mozilla.org/firefox/"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
@@ -21,15 +21,15 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech'
'hunspell-en_US: Spell checking, American English')
-provides=("firefox=$pkgver")
-conflicts=("firefox")
-options=(!emptydirs !makeflags)
+options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
+ 0001-Use-remoting-name-for-GDK-application-names.patch
$_pkgname.desktop firefox-symbolic.svg
unity-menubar.patch)
-sha256sums=('f7d61a08820088f1280d27f0808e355152c1dd0c94625fd077ced7319e522565'
+sha256sums=('6037f77bdab29d79ca5e3fbd1d32f6c209e09d2066189a13dc7f7491227f5568'
'SKIP'
- 'e8d2908727309a58bee9a3dc994e85140c5977b2d486381d67d5e22ad3830d28'
+ 'ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894'
+ 'e466789015e15be9409b7a7044353674ca6aa0f392e882217f90c79821fe2630'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
'03684be59adac8ab83c4c5cad3156879983b6d1311555fcaa8476684730d94f8')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@@ -53,9 +53,8 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
_repo=https://hg.mozilla.org/releases/mozilla-release
_tag=FIREFOX_${pkgver//./_}_RELEASE
-_changeset=353628fec415324ca6aa333ab6c47d447ecc128e
-_changeset_tag=FIREFOX_68_0_RELEASE
-
+_changeset=837bbcb850cd58eb07c7f6437078d5229986967c
+_changeset_tag=FIREFOX_68_0_1_RELEASE
if [[ $1 == update_hgrev ]]; then
_changeset=$(hg id -r $_tag --id $_repo --template '{node}')
@@ -71,6 +70,9 @@ prepare() {
mkdir mozbuild
cd firefox-$pkgver
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
+ patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
+
# actual appmenu patch from ubuntu repos
patch -Np1 -i ../unity-menubar.patch
@@ -99,7 +101,7 @@ ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=org.archlinux
ac_add_options --with-unsigned-addon-scopes=app,system
export MOZILLA_OFFICIAL=1
-export MOZ_APP_REMOTINGNAME=${pkgname//-/}
+export MOZ_APP_REMOTINGNAME=${_pkgname//-/}
export MOZ_TELEMETRY_REPORTING=1
export MOZ_REQUIRE_SIGNING=1
diff --git a/firefox.desktop b/firefox.desktop
index de69915208e4..ba8d6d21399a 100644
--- a/firefox.desktop
+++ b/firefox.desktop
@@ -119,7 +119,7 @@ X-MultipleArgs=false
Type=Application
MimeType=text/html;text/xml;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;application/x-xpinstall;
StartupNotify=true
-StartupWMClass=Firefox
+StartupWMClass=firefox
Categories=Network;WebBrowser;
Actions=new-window;new-private-window;