summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD30
-rw-r--r--unity-menubar.patch45
-rwxr-xr-xupload-symbol-archive25
3 files changed, 28 insertions, 72 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8c404d8aa77..235afc97d170 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=firefox-appmenu
_pkgname=firefox
-pkgver=68.0.2
+pkgver=69.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
@@ -26,12 +26,12 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
0001-Use-remoting-name-for-GDK-application-names.patch
$_pkgname.desktop firefox-symbolic.svg
unity-menubar.patch)
-sha256sums=('9b3e6d8f99819f9eda9ebba403b644a2b96d19450b42cae422bbf4386902a840'
+sha256sums=('413c3febdfeb69eade818824eecbdb11eaeda71de229573810afd641ba741ec5'
'SKIP'
'ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894'
'e466789015e15be9409b7a7044353674ca6aa0f392e882217f90c79821fe2630'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- '03684be59adac8ab83c4c5cad3156879983b6d1311555fcaa8476684730d94f8')
+ '2fd7261853ee2ed95ca6a68838de1e7cc18e01c7a56db9abcad4ac93867cedf7')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -46,26 +46,6 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
# more information.
_mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
-# For telemetry and crash dump analysis to work correctly, we need to tell the
-# build system which Mercurial changeset is our source. Should not be needed
-# anymore once 69 is released:
-# https://bugzilla.mozilla.org/show_bug.cgi?id=1338099
-_repo=https://hg.mozilla.org/releases/mozilla-release
-_tag=FIREFOX_${pkgver//./_}_RELEASE
-
-_changeset=7ece03f6971968eede29275477502309bbe399da
-_changeset_tag=FIREFOX_68_0_2_RELEASE
-
-if [[ $1 == update_hgrev ]]; then
- _changeset=$(hg id -r $_tag --id $_repo --template '{node}')
- sed -e "/^_changeset=/s/=.*/=$_changeset/;/^_changeset_tag=/s/=.*/=$_tag/" \
- -i "${BASH_SOURCE[0]}"
- exit 0
-elif [[ $_tag != $_changeset_tag ]]; then
- error "Changeset needs update. Run: bash PKGBUILD update_hgrev"
- exit 1
-fi
-
prepare() {
mkdir mozbuild
cd firefox-$pkgver
@@ -128,15 +108,15 @@ END
build() {
cd firefox-$pkgver
- export MOZ_SOURCE_REPO="$_repo"
- export MOZ_SOURCE_CHANGESET="$_changeset"
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
# LTO needs more open files
ulimit -n 4096
+ msg2 "Building optimized browser..."
xvfb-run -a -n 97 -s "-screen 0 1600x1200x24" ./mach build
+ msg2 "Building symbol archive..."
./mach buildsymbols
}
diff --git a/unity-menubar.patch b/unity-menubar.patch
index 0f1d9bbe6702..1d2c9d1cc0ed 100644
--- a/unity-menubar.patch
+++ b/unity-menubar.patch
@@ -14,7 +14,7 @@
<menu id="file-menu" label="&fileMenu.label;"
--- a/browser/base/content/browser.js
+++ b/browser/base/content/browser.js
-@@ -5977,11 +5977,17 @@ function onViewToolbarsPopupShowing(aEve
+@@ -6809,11 +6809,17 @@ function onViewToolbarsPopupShowing(aEve
let toolbarNodes = gNavToolbox.querySelectorAll("toolbar");
@@ -30,8 +30,8 @@
+ }
+
let menuItem = document.createXULElement("menuitem");
- let hidingAttribute = toolbar.getAttribute("type") == "menubar" ?
- "autohide" : "collapsed";
+ let hidingAttribute =
+ toolbar.getAttribute("type") == "menubar" ? "autohide" : "collapsed";
--- a/browser/components/places/content/places.xul
+++ b/browser/components/places/content/places.xul
@@ -166,7 +166,7 @@
@@ -70,7 +70,7 @@
nsINode* XULPopupElement::GetTriggerNode() const {
--- a/dom/xul/moz.build
+++ b/dom/xul/moz.build
-@@ -78,6 +78,11 @@ LOCAL_INCLUDES += [
+@@ -77,6 +77,11 @@ LOCAL_INCLUDES += [
include('/ipc/chromium/chromium-config.mozbuild')
@@ -97,7 +97,7 @@
'components.conf',
--- a/modules/libpref/init/all.js
+++ b/modules/libpref/init/all.js
-@@ -246,6 +246,9 @@ pref("dom.window.event.enabled", true);
+@@ -196,6 +196,9 @@ pref("dom.script_loader.binast_encoding.
pref("browser.sessionhistory.max_total_viewers", -1);
pref("ui.use_native_colors", true);
@@ -109,7 +109,7 @@
pref("ui.android.mouse_as_touch", 1);
--- a/toolkit/content/xul.css
+++ b/toolkit/content/xul.css
-@@ -215,6 +215,18 @@ toolbar[type="menubar"] {
+@@ -212,6 +212,18 @@ toolbar[type="menubar"] {
}
%endif
@@ -146,7 +146,7 @@
'nsWindow.cpp', # conflicts with X11 headers
]
-@@ -127,6 +136,7 @@ FINAL_LIBRARY = 'xul'
+@@ -129,6 +138,7 @@ FINAL_LIBRARY = 'xul'
LOCAL_INCLUDES += [
'/layout/base',
'/layout/generic',
@@ -324,7 +324,7 @@
+#endif /* __nsDbusmenu_h__ */
--- /dev/null
+++ b/widget/gtk/nsMenu.cpp
-@@ -0,0 +1,843 @@
+@@ -0,0 +1,844 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/* vim:expandtab:shiftwidth=4:tabstop=4:
+ */
@@ -458,8 +458,8 @@
+ return;
+ }
+
-+ const nsStyleDisplay* display = style->StyleDisplay();
-+ if (!display->mBinding) {
++ const auto& binding = style->StyleDisplay()->mBinding;
++ if (binding.IsNone()) {
+ return;
+ }
+
@@ -468,16 +468,17 @@
+ return;
+ }
+
-+ RefPtr<nsXBLBinding> binding;
++ RefPtr<nsXBLBinding> pendingBinding;
++ const auto& url = binding.AsUrl();
+ nsresult rv = xbl->LoadBindings(aContent->AsElement(),
-+ display->mBinding->GetURI(),
-+ display->mBinding->ExtraData()->Principal(),
-+ getter_AddRefs(binding));
-+ if ((NS_FAILED(rv) && rv != NS_ERROR_XBL_BLOCKED) || !binding) {
++ url.GetURI(),
++ url.ExtraData().Principal(),
++ getter_AddRefs(pendingBinding));
++ if ((NS_FAILED(rv) && rv != NS_ERROR_XBL_BLOCKED) || !pendingBinding) {
+ return;
+ }
+
-+ doc->BindingManager()->AddToAttachedQueue(binding);
++ doc->BindingManager()->AddToAttachedQueue(pendingBinding);
+}
+
+void
@@ -5141,7 +5142,7 @@
#include "mozilla/Preferences.h"
#include "nsIPrefService.h"
#include "nsIServiceManager.h"
-@@ -5028,6 +5029,10 @@ void nsWindow::HideWindowChrome(bool aSh
+@@ -5123,6 +5124,10 @@ void nsWindow::HideWindowChrome(bool aSh
SetWindowDecoration(aShouldHide ? eBorderStyle_none : mBorderStyle);
}
@@ -5172,7 +5173,7 @@
/**
* GetLastUserInputTime returns a timestamp for the most recent user input
* event. This is intended for pointer grab requests (including drags).
-@@ -632,6 +636,8 @@ class nsWindow final : public nsBaseWidg
+@@ -635,6 +639,8 @@ class nsWindow final : public nsBaseWidg
mozilla::UniquePtr<mozilla::CurrentX11TimeGetter> mCurrentTimeGetter;
static CSDSupportLevel sCSDSupportLevel;
@@ -5183,7 +5184,7 @@
#endif /* __nsWindow_h__ */
--- a/widget/moz.build
+++ b/widget/moz.build
-@@ -68,9 +68,9 @@ elif toolkit == 'cocoa':
+@@ -69,9 +69,9 @@ elif toolkit == 'cocoa':
'nsITouchBarInput.idl',
'nsITouchBarUpdater.idl',
]
@@ -5229,7 +5230,7 @@
import sys
# Static atom definitions, used to generate nsGkAtomList.h.
-@@ -2476,7 +2477,7 @@ STATIC_ATOMS = [
+@@ -2478,7 +2479,7 @@ STATIC_ATOMS = [
InheritingAnonBoxAtom("AnonBox_mozSVGForeignContent", ":-moz-svg-foreign-content"),
InheritingAnonBoxAtom("AnonBox_mozSVGText", ":-moz-svg-text"),
# END ATOMS
@@ -5241,8 +5242,8 @@
--- a/widget/gtk/components.conf
+++ b/widget/gtk/components.conf
@@ -75,6 +75,14 @@ Classes = [
- 'type': 'nsTransferable',
- 'headers': ['/widget/nsTransferable.h'],
+ 'headers': ['/widget/gtk/nsApplicationChooser.h'],
+ 'processes': ProcessSelector.MAIN_PROCESS_ONLY,
},
+ {
+ 'cid': '{0B3FE5AA-BC72-4303-85AE-76365DF1251D}',
diff --git a/upload-symbol-archive b/upload-symbol-archive
deleted file mode 100755
index 1fcba7c44af8..000000000000
--- a/upload-symbol-archive
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/bash -e
-
-die() {
- echo >&2 "$@"
- exit 1
-}
-
-(( $# >= 2 )) || die "Usage: $0 TOKEN-FILE SYMBOL-ARCHIVE..."
-token="$1"
-shift
-
-[[ -f $token && -s $token ]] || die "Invalid TOKEN-FILE ${token@Q}"
-
-for zip; do
- [[ $(file -Ebi "$zip") == application/zip* ]] || die "Invalid SYMBOL-ARCHIVE ${zip@Q}"
-done
-
-for zip; do
- echo >&2 "Uploading ${zip@Q} ..."
- curl -X POST -H "Auth-Token: $(<"$token")" -F "${zip##*/}=@$zip" \
- --retry 4 --retry-connrefused --connect-timeout 120 \
- https://symbols.mozilla.org/upload/
- mv -v "$zip" "$zip.uploaded"
- echo
-done