summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD39
-rw-r--r--unity-menubar.patch20
-rwxr-xr-x[-rw-r--r--]upload-symbol-archive0
3 files changed, 30 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86bc1fcaf9df..80a760377c3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,34 +7,31 @@
pkgname=firefox-appmenu
_pkgname=firefox
-pkgver=77.0.1
+pkgver=78.0
pkgrel=1
pkgdesc="Firefox from extra with appmenu patch"
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
-depends=(gtk3 libxt startup-notification mime-types dbus-glib ffmpeg nss
- ttf-font libpulse)
-makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
- xorg-server-xvfb autoconf2.13 rust clang llvm jack gtk2 python
- nodejs python2-psutil cbindgen nasm)
+depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss ttf-font libpulse)
+makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
+ autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
+ python-setuptools python-psutil)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech'
'hunspell-en_US: Spell checking, American English')
-provides=("firefox=$pkgver")
-conflict=("firefox")
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
0001-Use-remoting-name-for-GDK-application-names.patch
$_pkgname.desktop
unity-menubar.patch)
-sha256sums=('54256fc5f8e9c2e8129ef84773fae31fcfdaf95da6d4d03151f3939e9f749640'
+sha256sums=('291a593151e476e6c4b61e48a3bdd5a11896fbde6261dcad347d5b7df265a058'
'SKIP'
'3bb7463471fb43b2163a705a79a13a3003d70fff4bbe44f467807ca056de9a75'
'34514a657d6907a159594c51e674eeb81297c431ec26a736417c2fdb995c2c0c'
- 'c87e9df0fa2ba96989b70403e412aae54de9e29a56c7872f155cfd8a1e0b9a33')
+ '411f1580801f7b1484575d38f5967cf3d8c68efbba8dd4e2950e13a763bd09d8')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -52,12 +49,12 @@ _mozilla_api_key=e05d56db0a694edc8b5aaebda3f2db6a
prepare() {
mkdir mozbuild
cd firefox-$pkgver
-
+
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
-
+
# actual appmenu patch from ubuntu repos
- # http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_77.0.1+build1-0ubuntu0.18.04.1.debian.tar.xz
+ # https://launchpad.net/~mozillateam/+archive/ubuntu/firefox-next/+sourcefiles/firefox/78.0+build2-0ubuntu0.18.04.1~mt1/firefox_78.0+build2-0ubuntu0.18.04.1~mt1.debian.tar.xz
patch -Np1 -i ../unity-menubar.patch
echo -n "$_google_api_key" >google-api-key
@@ -93,12 +90,14 @@ ac_add_options --with-google-location-service-api-keyfile=${PWD@Q}/google-api-ke
ac_add_options --with-google-safebrowsing-api-keyfile=${PWD@Q}/google-api-key
ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
+# System libraries
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+
# Features
ac_add_options --enable-alsa
ac_add_options --enable-jack
-ac_add_options --enable-startup-notification
ac_add_options --enable-crashreporter
-ac_add_options --disable-gconf
ac_add_options --disable-updater
ac_add_options --disable-tests
END
@@ -162,7 +161,7 @@ package() {
cd firefox-$pkgver
DESTDIR="$pkgdir" ./mach install
- local vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
+ local vendorjs="$pkgdir/usr/lib/$_pkgname/browser/defaults/preferences/vendor.js"
install -Dvm644 /dev/stdin "$vendorjs" <<END
// Use LANG environment variable to choose locale
pref("intl.locale.requested", "");
@@ -177,7 +176,7 @@ pref("browser.shell.checkDefaultBrowser", false);
pref("extensions.autoDisableScopes", 11);
END
- local distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
+ local distini="$pkgdir/usr/lib/$_pkgname/distribution/distribution.ini"
install -Dvm644 /dev/stdin "$distini" <<END
[Global]
id=archlinux
@@ -213,10 +212,10 @@ END
# Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -srfv "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/lib/$pkgname/firefox-bin"
+ ln -srfv "$pkgdir/usr/bin/$_pkgname" "$pkgdir/usr/lib/$_pkgname/firefox-bin"
# Use system certificates
- local nssckbi="$pkgdir/usr/lib/$pkgname/libnssckbi.so"
+ local nssckbi="$pkgdir/usr/lib/$_pkgname/libnssckbi.so"
if [[ -e $nssckbi ]]; then
ln -srfv "$pkgdir/usr/lib/libnssckbi.so" "$nssckbi"
fi
@@ -229,3 +228,5 @@ END
cp -fvt "$startdir" {} +
fi
}
+
+# vim:set sw=2 et:
diff --git a/unity-menubar.patch b/unity-menubar.patch
index d1dd175e21c4..ab36cf3e3a24 100644
--- a/unity-menubar.patch
+++ b/unity-menubar.patch
@@ -14,7 +14,7 @@
<menu id="file-menu" data-l10n-id="menu-file">
--- a/browser/base/content/browser.js
+++ b/browser/base/content/browser.js
-@@ -6296,11 +6296,17 @@ function onViewToolbarsPopupShowing(aEve
+@@ -6301,11 +6301,17 @@ function onViewToolbarsPopupShowing(aEve
let toolbarNodes = gNavToolbox.querySelectorAll("toolbar");
@@ -35,7 +35,7 @@
--- a/browser/components/places/content/places.xhtml
+++ b/browser/components/places/content/places.xhtml
@@ -169,7 +169,7 @@
- <toolbarbutton type="menu" class="tabbable"
+ <toolbarbutton type="menu" class="tabbable" wantdropmarker="true"
onpopupshowing="document.getElementById('placeContent').focus()"
#else
- <menubar id="placesMenu">
@@ -97,7 +97,7 @@
'components.conf',
--- a/modules/libpref/init/all.js
+++ b/modules/libpref/init/all.js
-@@ -309,6 +309,9 @@ pref("dom.mouseevent.click.hack.use_lega
+@@ -313,6 +313,9 @@ pref("dom.mouseevent.click.hack.use_lega
// of content viewers to cache based on the amount of available memory.
pref("browser.sessionhistory.max_total_viewers", -1);
@@ -109,7 +109,7 @@
pref("ui.android.mouse_as_touch", 1);
--- a/toolkit/content/xul.css
+++ b/toolkit/content/xul.css
-@@ -204,6 +204,13 @@ toolbar[type="menubar"] {
+@@ -200,6 +200,13 @@ toolbar[type="menubar"] {
}
%endif
@@ -141,7 +141,7 @@
'nsWindow.cpp', # conflicts with X11 headers
'WaylandVsyncSource.cpp', # conflicts with X11 headers
]
-@@ -132,6 +141,7 @@ FINAL_LIBRARY = 'xul'
+@@ -134,6 +143,7 @@ FINAL_LIBRARY = 'xul'
LOCAL_INCLUDES += [
'/layout/base',
'/layout/generic',
@@ -3255,7 +3255,7 @@
+ nullptr, 0, loadGroup, this, nullptr, nullptr,
+ nsIRequest::LOAD_NORMAL, nullptr,
+ nsIContentPolicy::TYPE_IMAGE, EmptyString(),
-+ false, getter_AddRefs(mImageRequest));
++ false, false, getter_AddRefs(mImageRequest));
+ }
+}
+
@@ -5077,7 +5077,7 @@
+#endif /* __nsNativeMenuService_h__ */
--- a/widget/gtk/nsWindow.cpp
+++ b/widget/gtk/nsWindow.cpp
-@@ -6008,6 +6008,10 @@ void nsWindow::HideWindowChrome(bool aSh
+@@ -6069,6 +6069,10 @@ void nsWindow::HideWindowChrome(bool aSh
SetWindowDecoration(aShouldHide ? eBorderStyle_none : mBorderStyle);
}
@@ -5130,8 +5130,8 @@
+if toolkit in ('cocoa', 'gtk'):
+ EXPORTS += ['nsINativeMenuService.h']
- TEST_DIRS += ['tests']
-
+ TEST_DIRS += [
+ 'tests',
--- /dev/null
+++ b/xpcom/ds/NativeMenuAtoms.py
@@ -0,0 +1,9 @@
@@ -5154,7 +5154,7 @@
import sys
# Static atom definitions, used to generate nsGkAtomList.h.
-@@ -2552,7 +2553,7 @@ STATIC_ATOMS = [
+@@ -2553,7 +2554,7 @@ STATIC_ATOMS = [
InheritingAnonBoxAtom("AnonBox_mozSVGForeignContent", ":-moz-svg-foreign-content"),
InheritingAnonBoxAtom("AnonBox_mozSVGText", ":-moz-svg-text"),
# END ATOMS
diff --git a/upload-symbol-archive b/upload-symbol-archive
index 059a399c429f..059a399c429f 100644..100755
--- a/upload-symbol-archive
+++ b/upload-symbol-archive