summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch35
-rw-r--r--PKGBUILD14
-rw-r--r--firefox.desktop2
-rw-r--r--[-rwxr-xr-x]upload-symbol-archive0
5 files changed, 51 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1084e6abaf37..50fe2367f4b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-appmenu
pkgdesc = Firefox from extra with appmenu patch
pkgver = 75.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.mozilla.org/firefox/
arch = x86_64
license = MPL
@@ -47,14 +47,16 @@ pkgbase = firefox-appmenu
options = !strip
source = https://archive.mozilla.org/pub/firefox/releases/75.0/source/firefox-75.0.source.tar.xz
source = https://archive.mozilla.org/pub/firefox/releases/75.0/source/firefox-75.0.source.tar.xz.asc
+ source = 0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch
source = 0001-Use-remoting-name-for-GDK-application-names.patch
source = firefox.desktop
source = unity-menubar.patch
validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
sha256sums = bbb1054d8f2717c634480556d3753a8483986af7360e023bb6232df80b746b0f
sha256sums = SKIP
+ sha256sums = ebb169804750ddc10a4801ed6ddb37356331bbf76615f58eb29de2e6e15ee930
sha256sums = 5f7ac724a5c5afd9322b1e59006f4170ea5354ca1e0e60dab08b7784c2d8463c
- sha256sums = e466789015e15be9409b7a7044353674ca6aa0f392e882217f90c79821fe2630
+ sha256sums = 34514a657d6907a159594c51e674eeb81297c431ec26a736417c2fdb995c2c0c
sha256sums = 364e5c59a5a55d0be43bcb090dec51476580d0c35b63c0974a25bfeba212a1fc
pkgname = firefox-appmenu
diff --git a/0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch b/0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch
new file mode 100644
index 000000000000..eb9667476110
--- /dev/null
+++ b/0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch
@@ -0,0 +1,35 @@
+From 0447215abf836bbb8eef53aeccf029dd40bd1a52 Mon Sep 17 00:00:00 2001
+From: Jeff Gilbert <jgilbert@mozilla.com>
+Date: Sun, 12 Apr 2020 21:21:32 +0000
+Subject: [PATCH] Bug 1623885 - Add "subsystem" to Mesa sandbox policy to fix
+ libdrm-2.4.101+. r=gcp, a=RyanVM
+
+Differential Revision: https://phabricator.services.mozilla.com/D70579
+---
+ .../linux/broker/SandboxBrokerPolicyFactory.cpp | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp b/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp
+index 3aa7cf27e353..0b3948ebd92e 100644
+--- a/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp
++++ b/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp
+@@ -86,10 +86,12 @@ static void AddMesaSysfsPaths(SandboxBroker::Policy* aPolicy) {
+ // broker. To match this, allow the canonical paths.
+ UniqueFreePtr<char[]> realSysPath(realpath(sysPath.get(), nullptr));
+ if (realSysPath) {
+- static const Array<const char*, 7> kMesaAttrSuffixes = {
+- "revision", "vendor", "device", "subsystem_vendor",
+- "subsystem_device", "uevent", "config"};
+- for (const auto attrSuffix : kMesaAttrSuffixes) {
++ constexpr const char* kMesaAttrSuffixes[] = {
++ "config", "device", "revision",
++ "subsystem", "subsystem_device", "subsystem_vendor",
++ "uevent", "vendor",
++ };
++ for (const auto& attrSuffix : kMesaAttrSuffixes) {
+ nsPrintfCString attrPath("%s/%s", realSysPath.get(),
+ attrSuffix);
+ aPolicy->AddPath(rdonly, attrPath.get());
+--
+2.26.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 28800408bb7c..3f00d6256299 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,14 @@
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
-# Additional patching: Nikita Tarasov <nikatar@disroot.org>
+
+### Appmenu patching ###
+# PKGBUILD: Nikita Tarasov <nikatar@disroot.org>
pkgname=firefox-appmenu
_pkgname=firefox
pkgver=75.0
-pkgrel=1
+pkgrel=2
pkgdesc="Firefox from extra with appmenu patch"
arch=(x86_64)
license=(MPL GPL LGPL)
@@ -25,13 +27,15 @@ provides=("firefox=$pkgver")
conflict=("firefox")
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
+ 0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch
0001-Use-remoting-name-for-GDK-application-names.patch
$_pkgname.desktop
unity-menubar.patch)
sha256sums=('bbb1054d8f2717c634480556d3753a8483986af7360e023bb6232df80b746b0f'
'SKIP'
+ 'ebb169804750ddc10a4801ed6ddb37356331bbf76615f58eb29de2e6e15ee930'
'5f7ac724a5c5afd9322b1e59006f4170ea5354ca1e0e60dab08b7784c2d8463c'
- 'e466789015e15be9409b7a7044353674ca6aa0f392e882217f90c79821fe2630'
+ '34514a657d6907a159594c51e674eeb81297c431ec26a736417c2fdb995c2c0c'
'364e5c59a5a55d0be43bcb090dec51476580d0c35b63c0974a25bfeba212a1fc')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@@ -50,11 +54,15 @@ _mozilla_api_key=e05d56db0a694edc8b5aaebda3f2db6a
prepare() {
mkdir mozbuild
cd firefox-$pkgver
+
+ # https://bugs.archlinux.org/task/66185
+ patch -Np1 -i ../0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
# actual appmenu patch from ubuntu repos
+ # http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_75.0+build3-0ubuntu0.18.04.1.debian.tar.xz
patch -Np1 -i ../unity-menubar.patch
echo -n "$_google_api_key" >google-api-key
diff --git a/firefox.desktop b/firefox.desktop
index ba8d6d21399a..08ddb1b2e127 100644
--- a/firefox.desktop
+++ b/firefox.desktop
@@ -117,7 +117,7 @@ Icon=firefox
Terminal=false
X-MultipleArgs=false
Type=Application
-MimeType=text/html;text/xml;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;application/x-xpinstall;
+MimeType=text/html;text/xml;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;application/x-xpinstall;application/pdf;application/json;
StartupNotify=true
StartupWMClass=firefox
Categories=Network;WebBrowser;
diff --git a/upload-symbol-archive b/upload-symbol-archive
index 059a399c429f..059a399c429f 100755..100644
--- a/upload-symbol-archive
+++ b/upload-symbol-archive