summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Use-remoting-name-for-GDK-application-names.patch37
-rw-r--r--PKGBUILD10
3 files changed, 31 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4ca5540bf0c..25fe632305a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-beta
pkgdesc = Standalone web browser from mozilla.org - Beta
- pkgver = 76.0b8
- pkgrel = 2
+ pkgver = 77.0b1
+ pkgrel = 1
url = https://www.mozilla.org/en-US/firefox/channel/#beta
arch = i686
arch = x86_64
@@ -43,19 +43,19 @@ pkgbase = firefox-beta
optdepends = pulseaudio: Audio support
optdepends = speech-dispatcher: Text-to-Speech
optdepends = hunspell-en_US: Spell checking, American English
- provides = firefox=76.0b8
+ provides = firefox=77.0b1
conflicts = firefox-beta-bin
options = !emptydirs
options = !makeflags
options = !strip
- source = https://archive.mozilla.org/pub/firefox/releases/76.0b8/source/firefox-76.0b8.source.tar.xz
- source = https://archive.mozilla.org/pub/firefox/releases/76.0b8/source/firefox-76.0b8.source.tar.xz.asc
+ source = https://archive.mozilla.org/pub/firefox/releases/77.0b1/source/firefox-77.0b1.source.tar.xz
+ source = https://archive.mozilla.org/pub/firefox/releases/77.0b1/source/firefox-77.0b1.source.tar.xz.asc
source = 0001-Use-remoting-name-for-GDK-application-names.patch
source = firefox-beta.desktop
validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
- sha256sums = 7a1baefeec7edaf35022e1b47683d7ab62a84dfe5768af971bcfe2f8b35c666c
+ sha256sums = 051403c3053bbb4f6d41ea2a12b5401447d251e75b53ce7e3aee216b4bb45e11
sha256sums = SKIP
- sha256sums = 5f7ac724a5c5afd9322b1e59006f4170ea5354ca1e0e60dab08b7784c2d8463c
+ sha256sums = 94106b6394be466a74c5eb5527290cf32056dc956fc47313ed37ea05005e27dc
sha256sums = d6b4c91a7fe77f9a335b44b943e120ce44511e46bbb16ae305cc82b4c3db66cd
pkgname = firefox-beta
diff --git a/0001-Use-remoting-name-for-GDK-application-names.patch b/0001-Use-remoting-name-for-GDK-application-names.patch
index 165a532f470c..ceac9da65b49 100644
--- a/0001-Use-remoting-name-for-GDK-application-names.patch
+++ b/0001-Use-remoting-name-for-GDK-application-names.patch
@@ -9,12 +9,12 @@ Subject: [PATCH] Use remoting name for GDK application names
2 files changed, 4 insertions(+), 9 deletions(-)
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
-index 984b998133bd..b6c9f013940c 100644
+index 0828400952..f5b941a37d 100644
--- a/toolkit/xre/nsAppRunner.cpp
+++ b/toolkit/xre/nsAppRunner.cpp
-@@ -3746,11 +3746,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
+@@ -3703,11 +3703,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
// consistently.
-
+
// Set program name to the one defined in application.ini.
- {
- nsAutoCString program(gAppData->name);
@@ -22,11 +22,11 @@ index 984b998133bd..b6c9f013940c 100644
- g_set_prgname(program.get());
- }
+ g_set_prgname(gAppData->remotingName);
-
+
// Initialize GTK here for splash.
-
+
diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
-index 0daa78fdbbad..49038d0bb1c8 100644
+index 163a93e2d1..0435506029 100644
--- a/widget/gtk/nsAppShell.cpp
+++ b/widget/gtk/nsAppShell.cpp
@@ -24,6 +24,7 @@
@@ -37,19 +37,20 @@ index 0daa78fdbbad..49038d0bb1c8 100644
#include "ScreenHelperGTK.h"
#include "HeadlessScreenHelper.h"
#include "mozilla/widget/ScreenManager.h"
-@@ -175,10 +176,8 @@ nsresult nsAppShell::Init() {
- // option when program uses gdk_set_program_class().
- //
- // See https://bugzilla.gnome.org/show_bug.cgi?id=747634
-- nsAutoString brandName;
-- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
-- if (!brandName.IsEmpty()) {
-- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
-+ if (gAppData) {
-+ gdk_set_program_class(gAppData->remotingName);
+@@ -178,10 +179,8 @@ nsresult nsAppShell::Init() {
+ // creating top-level windows. (At this point, a child process hasn't
+ // received the list of registered chrome packages, so the
+ // GetBrandShortName call would fail anyway.)
+- nsAutoString brandName;
+- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
+- if (!brandName.IsEmpty()) {
+- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
++ if (gAppData) {
++ gdk_set_program_class(gAppData->remotingName);
+ }
}
}
-
---
+
+--
2.24.0
diff --git a/PKGBUILD b/PKGBUILD
index 134140e84c69..75d0bb50e3c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@
pkgname=firefox-beta
_pkgname=firefox
-pkgver=76.0b8
-_pkgver=76.0
-pkgrel=2
+pkgver=77.0b1
+_pkgver=77.0
+pkgrel=1
pkgdesc="Standalone web browser from mozilla.org - Beta"
arch=(i686 x86_64)
license=(MPL GPL LGPL)
@@ -30,9 +30,9 @@ options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/$_pkgname-$pkgver.source.tar.xz{,.asc}
0001-Use-remoting-name-for-GDK-application-names.patch
$pkgname.desktop)
-sha256sums=('7a1baefeec7edaf35022e1b47683d7ab62a84dfe5768af971bcfe2f8b35c666c'
+sha256sums=('051403c3053bbb4f6d41ea2a12b5401447d251e75b53ce7e3aee216b4bb45e11'
'SKIP'
- '5f7ac724a5c5afd9322b1e59006f4170ea5354ca1e0e60dab08b7784c2d8463c'
+ '94106b6394be466a74c5eb5527290cf32056dc956fc47313ed37ea05005e27dc'
'd6b4c91a7fe77f9a335b44b943e120ce44511e46bbb16ae305cc82b4c3db66cd')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>