summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD187
-rw-r--r--firefox-fixed-loading-icon.pngbin12184 -> 0 bytes
-rw-r--r--firefox-install-dir.patch12
-rw-r--r--firefox.sh2
-rw-r--r--fix-wifi-scanner.diff16
-rw-r--r--mozconfig47
-rw-r--r--no-libnotify.patch50
-rw-r--r--vendor.js9
9 files changed, 77 insertions, 287 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a516461e770..4dd46f6f4afa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = firefox-beta
- pkgdesc = Standalone web browser from mozilla.org, with telemetry and signing disabled
- pkgver = 63.0
+ pkgdesc = Standalone web browser from mozilla.org - Beta
+ pkgver = 70.0b4
pkgrel = 1
- url = https://www.mozilla.org/firefox/
+ url = https://www.mozilla.org/en-US/firefox/channel/#beta
arch = i686
arch = x86_64
license = MPL
@@ -11,22 +11,24 @@ pkgbase = firefox-beta
makedepends = unzip
makedepends = zip
makedepends = diffutils
- makedepends = python2
+ makedepends = python2-setuptools
makedepends = yasm
makedepends = mesa
makedepends = imake
- makedepends = gconf
makedepends = inetutils
makedepends = xorg-server-xvfb
makedepends = autoconf2.13
makedepends = rust
- makedepends = mercurial
makedepends = clang
makedepends = llvm
makedepends = jack
+ makedepends = gtk2
+ makedepends = python
+ makedepends = nodejs
+ makedepends = python2-psutil
makedepends = cbindgen
+ makedepends = nasm
depends = gtk3
- depends = gtk2
depends = mozilla-common
depends = libxt
depends = startup-notification
@@ -34,35 +36,24 @@ pkgbase = firefox-beta
depends = dbus-glib
depends = ffmpeg
depends = nss
- depends = hunspell
- depends = sqlite
depends = ttf-font
depends = libpulse
optdepends = networkmanager: Location detection via available WiFi networks
optdepends = libnotify: Notification integration
optdepends = pulseaudio: Audio support
optdepends = speech-dispatcher: Text-to-Speech
+ optdepends = hunspell-en_US: Spell checking, American English
options = !emptydirs
options = !makeflags
options = !strip
- source = https://hg.mozilla.org/mozilla-unified/archive/FIREFOX_62_0b9_RELEASE.tar.gz
- source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/FIREFOX_62_0b9_RELEASE.desktop
- source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-symbolic.svg
- source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-52-disable-data-sharing-infobar.patch
- source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-52-disable-location.services.mozilla.com.patch
- source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-52-disable-telemetry.patch
- source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/id.patch
- source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/fix.patch
- source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/fix2.patch
- sha256sums = 3e7205bae7ec50800369418f3dad924769e1a9e3a04ee1d6b97767f4b0b86c07
+ source = http://ftp.mozilla.org/pub/firefox/releases/70.0b4/source/firefox-70.0b4.source.tar.xz
+ source = firefox.sh
+ source = firefox-beta.desktop
+ source = firefox-symbolic.svg
+ sha256sums = ef8f88908009b6e9436245bfc9476779527da401c2c903017c19e7ff573d06cd
+ sha256sums = 367100e5f66523a90c3792e2e0d0e2fe8a3c28748b905ce9f5f6b121343d7842
sha256sums = d6b4c91a7fe77f9a335b44b943e120ce44511e46bbb16ae305cc82b4c3db66cd
sha256sums = a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9
- sha256sums = bdad68eafe110b9f94a0e025635e32a6ab53e2f9adcd594c8dd2e3225f6453ab
- sha256sums = 57889bc467f7410ef64f4a90b5ca915b9bcb0c9eb215ec9e154302bc810f0221
- sha256sums = 24019d3d7e6b169087d4515db9d3a179239d1e4fe726f0906f6f26877c726040
- sha256sums = 7e44bd2eb4ce243ef47451e64e793203c8d637f900c86889106eb7f8adf79296
- sha256sums = 7e44dc0dc836a31c6f8e3e3461aeb636de210fb5a238e58a0eb10787ca4ad958
- sha256sums = 32d04bf9c5c76ec3803aa7e1f82ca11dc5ea3d32b86d054168f4cc1e1ef9960c
pkgname = firefox-beta
diff --git a/PKGBUILD b/PKGBUILD
index a6d0438c847e..0be906fba3de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,161 +1,105 @@
# $Id$
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox-beta
+_pkgname=firefox
name=firefox-beta
-pkgver=63.0
+pkgver=70.0b4
+_pkgver=70.0
pkgrel=1
-meme=FIREFOX_62_0b9_RELEASE
-meme2=DEVEDITION_63_0b1_RELEASE
-meme3=FIREFOX_BETA_63_BASE
-pkgdesc="Standalone web browser from mozilla.org, with telemetry and signing disabled"
+pkgdesc="Standalone web browser from mozilla.org - Beta"
arch=(i686 x86_64)
license=(MPL GPL LGPL)
-url="https://www.mozilla.org/firefox/"
-depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell sqlite ttf-font libpulse)
-makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm jack cbindgen)
+url="https://www.mozilla.org/en-US/firefox/channel/#beta"
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
+ ffmpeg nss ttf-font libpulse)
+makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
+ xorg-server-xvfb autoconf2.13 rust clang llvm jack gtk2
+ python nodejs python2-psutil cbindgen nasm)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
- 'speech-dispatcher: Text-to-Speech')
+ 'speech-dispatcher: Text-to-Speech'
+ 'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags !strip)
-source=("https://hg.mozilla.org/mozilla-unified/archive/$meme.tar.gz"
- https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/$meme.desktop
-https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-symbolic.svg
-https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-52-disable-data-sharing-infobar.patch
-https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-52-disable-location.services.mozilla.com.patch
-https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-52-disable-telemetry.patch
-https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/id.patch
-https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/fix.patch
-https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/fix2.patch
-)
-
-sha256sums=('3e7205bae7ec50800369418f3dad924769e1a9e3a04ee1d6b97767f4b0b86c07'
+source=("http://ftp.mozilla.org/pub/firefox/releases/70.0b4/source/$_pkgname-$pkgver.source.tar.xz"
+ "$_pkgname.sh"
+ "$pkgname.desktop"
+ "$_pkgname-symbolic.svg")
+sha256sums=('ef8f88908009b6e9436245bfc9476779527da401c2c903017c19e7ff573d06cd'
+ '367100e5f66523a90c3792e2e0d0e2fe8a3c28748b905ce9f5f6b121343d7842'
'd6b4c91a7fe77f9a335b44b943e120ce44511e46bbb16ae305cc82b4c3db66cd'
- 'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
- 'bdad68eafe110b9f94a0e025635e32a6ab53e2f9adcd594c8dd2e3225f6453ab'
- '57889bc467f7410ef64f4a90b5ca915b9bcb0c9eb215ec9e154302bc810f0221'
- '24019d3d7e6b169087d4515db9d3a179239d1e4fe726f0906f6f26877c726040'
- '7e44bd2eb4ce243ef47451e64e793203c8d637f900c86889106eb7f8adf79296'
- '7e44dc0dc836a31c6f8e3e3461aeb636de210fb5a238e58a0eb10787ca4ad958'
- '32d04bf9c5c76ec3803aa7e1f82ca11dc5ea3d32b86d054168f4cc1e1ef9960c')
-
-
-
-# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
-# Note: These are for Arch Linux use ONLY. For your own distribution, please
-# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
-# more information.
-
-
-# Mozilla API keys (see https://location.services.mozilla.com/api)
-# Note: These are for Arch Linux use ONLY. For your own distribution, please
-# get your own set of keys. Feel free to contact heftig@archlinux.org for
-# more information.
-
+ 'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9')
prepare() {
- mkdir path
- ln -s /usr/bin/python2 path/python
-
- cd mozilla-unified-$meme
- patch -Np1 -i ../id.patch
-
-
-
-patch -Np1 -i ../firefox-52-disable-data-sharing-infobar.patch
-patch -Np1 -i ../firefox-52-disable-telemetry.patch
-patch -Np1 -i ../fix.patch
-patch -Np1 -i ../fix2.patch
-
+ mkdir mozbuild
+ cd firefox-$_pkgver
cat >.mozconfig <<END
ac_add_options --enable-application=browser
ac_add_options --prefix=/usr
ac_add_options --enable-release
-ac_add_options --enable-gold
-ac_add_options --enable-pie
-ac_add_options --enable-optimize="-O2"
+ac_add_options --enable-hardening
+ac_add_options --enable-optimize
+ac_add_options --enable-rust-simd
+export CC=clang
+export CXX=clang++
+export AR=llvm-ar
+export NM=llvm-nm
+export RANLIB=llvm-ranlib
# Branding
ac_add_options --with-branding=browser/branding/aurora
-ac_add_options --enable-update-channel=aurora
+#ac_add_options --enable-update-channel=beta
ac_add_options --with-distribution-id=org.archlinux
export MOZILLA_OFFICIAL=1
-export MOZ_TELEMETRY_REPORTING=0
+#export MOZ_TELEMETRY_REPORTING=0
export MOZ_ADDON_SIGNING=1
export MOZ_REQUIRE_SIGNING=0
-# Keys
# System libraries
-ac_add_options --with-system-zlib
-ac_add_options --with-system-bz2
-ac_add_options --enable-system-hunspell
-ac_add_options --enable-system-sqlite
-ac_add_options --enable-system-ffi
-ac_add_options --disable-gamepad
-ac_add_options --disable-necko-wifi
-ac_add_options --disable-webspeech
-
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
# Features
ac_add_options --enable-alsa
ac_add_options --enable-jack
ac_add_options --enable-startup-notification
ac_add_options --enable-crashreporter
+ac_add_options --disable-gconf
ac_add_options --disable-updater
-
-ac_add_options --disable-debug
-ac_add_options --disable-debug-symbols
ac_add_options --disable-tests
-ac_add_options --disable-parental-controls
-ac_add_options --disable-accessibility
-
-
-# faster build
-ac_add_options --disable-tests
-
-ac_add_options --enable-rust-simd
-# please put 1.25 times your number of threads
-
-mk_add_options MOZ_MAKE_FLAGS="-j10"
END
}
build() {
- cd mozilla-unified-$meme
-
- # _FORTIFY_SOURCE causes configure failures
- CPPFLAGS+=" -O2"
-
- export PATH="$srcdir/path:$PATH"
- export MOZ_SOURCE_REPO="$_repo"
+ cd firefox-$_pkgver
- # Do PGO
- #xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \
- # MOZ_PGO=1 ./mach build
- export LANG=C
+ export MOZ_NOSPAM=1
+ export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ ./mach configure
./mach build
- ./mach buildsymbols
+
}
package() {
- cd mozilla-unified-$meme
+ cd firefox-$_pkgver
DESTDIR="$pkgdir" ./mach install
- find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +
- _vendorjs="$pkgdir/usr/lib/$name/browser/defaults/preferences/vendor.js"
+ _vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END
// Use LANG environment variable to choose locale
-pref("intl.locale.matchOS", true);
+pref("intl.locale.requested", "");
+
+// Use system-provided dictionaries
+pref("spellchecker.dictionary_path", "/usr/share/hunspell");
// Disable default browser checking.
pref("browser.shell.checkDefaultBrowser", false);
@@ -163,12 +107,9 @@ pref("browser.shell.checkDefaultBrowser", false);
// Don't disable our bundled extensions in the application directory
pref("extensions.autoDisableScopes", 11);
pref("extensions.shownSelectionUI", true);
-
-// Opt all of us into e10s, instead of just 50%
-pref("browser.tabs.remote.autostart", true);
END
- _distini="$pkgdir/usr/lib/$name/distribution/distribution.ini"
+ _distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
install -Dm644 /dev/stdin "$_distini" <<END
[Global]
id=archlinux
@@ -177,17 +118,17 @@ about=Mozilla Firefox for Arch Linux
[Preferences]
app.distributor=archlinux
-app.distributor.channel=$name
+app.distributor.channel=$pkgname
app.partner.archlinux=archlinux
END
- for i in 16 32 48 64 128; do
- install -Dm644 browser/branding/aurora/default$i.png \
+ for i in 16 22 24 32 48 64 128 256; do
+ install -Dm644 browser/branding/official/default$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
done
- install -Dm644 browser/branding/aurora/content/about-logo.png \
+ install -Dm644 browser/branding/official/content/about-logo.png \
"$pkgdir/usr/share/icons/hicolor/192x192/apps/$pkgname.png"
- install -Dm644 browser/branding/aurora/content/about-logo@2x.png \
+ install -Dm644 browser/branding/official/content/about-logo@2x.png \
"$pkgdir/usr/share/icons/hicolor/384x384/apps/$pkgname.png"
install -Dm644 ../firefox-symbolic.svg \
"$pkgdir/usr/share/icons/hicolor/symbolic/apps/$pkgname-symbolic.svg"
@@ -195,25 +136,15 @@ END
install -Dm644 ../$pkgname.desktop \
"$pkgdir/usr/share/applications/$pkgname.desktop"
- # Use system-provided dictionaries
-
-
# Install a wrapper to avoid confusion about binary path
+ install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
+#!/bin/sh
+exec /usr/lib/$pkgname/firefox "\$@"
+END
# Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
-
-
- # Use system certificates
- ln -srf "$pkgdir/usr/lib/libnssckbi.so" \
- "$pkgdir/usr/lib/$name/libnssckbi.so"
-
-
-
-msg2 'renaming'
-
- ln -s "/usr/lib/firefox-beta/firefox-bin" "$pkgdir/usr/bin/firefox-beta"
-
-
-rm "$pkgdir/usr/bin/firefox"
+ ln -srf "$pkgdir/usr/bin/$pkgname" \
+ "$pkgdir/usr/lib/$pkgname/firefox-bin"
}
+
diff --git a/firefox-fixed-loading-icon.png b/firefox-fixed-loading-icon.png
deleted file mode 100644
index 55f25e591ff5..000000000000
--- a/firefox-fixed-loading-icon.png
+++ /dev/null
Binary files differ
diff --git a/firefox-install-dir.patch b/firefox-install-dir.patch
deleted file mode 100644
index 51fe4ba0a855..000000000000
--- a/firefox-install-dir.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up firefox-29.0/mozilla-release/config/baseconfig.mk.orig firefox-29.0/mozilla-release/config/baseconfig.mk
---- mozilla-release/config/baseconfig.mk.orig 2014-04-22 15:38:52.948165295 +0200
-+++ mozilla-release/config/baseconfig.mk 2014-04-22 15:42:20.387481673 +0200
-@@ -4,7 +4,7 @@
- # whether a normal build is happening or whether the check is running.
- includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
- idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
--installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-+installdir = $(libdir)/$(MOZ_APP_NAME)
- sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
- ifndef TOP_DIST
- TOP_DIST = dist
diff --git a/firefox.sh b/firefox.sh
new file mode 100644
index 000000000000..4323c996bf27
--- /dev/null
+++ b/firefox.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /opt/firefox-beta/firefox --class "Firefox Beta" "$@"
diff --git a/fix-wifi-scanner.diff b/fix-wifi-scanner.diff
deleted file mode 100644
index f8fdd6c42142..000000000000
--- a/fix-wifi-scanner.diff
+++ /dev/null
@@ -1,16 +0,0 @@
- netwerk/wifi/nsWifiScannerDBus.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git c/netwerk/wifi/nsWifiScannerDBus.cpp i/netwerk/wifi/nsWifiScannerDBus.cpp
-index 182553e18fa6e104..6fa0a0b023d3e45f 100644
---- c/netwerk/wifi/nsWifiScannerDBus.cpp
-+++ i/netwerk/wifi/nsWifiScannerDBus.cpp
-@@ -62,7 +62,7 @@ nsWifiScannerDBus::SendMessage(const char* aInterface,
- return NS_ERROR_FAILURE;
- }
- } else if (!strcmp(aFuncCall, "GetAll")) {
-- const char* param = "";
-+ const char* param = "org.freedesktop.NetworkManager.AccessPoint";
- if (!dbus_message_iter_append_basic(&argsIter, DBUS_TYPE_STRING, &param)) {
- return NS_ERROR_FAILURE;
- }
diff --git a/mozconfig b/mozconfig
deleted file mode 100644
index 7d1dca962453..000000000000
--- a/mozconfig
+++ /dev/null
@@ -1,47 +0,0 @@
-. $topsrcdir/browser/config/mozconfig
-#export CC=clang
-#export CXX=clang++
-export CXXFLAGS+=" -mno-avx -fPIC"
-export CFLAGS+=" -fPIC"
-ac_add_options --prefix=/usr
-ac_add_options --libdir=/opt/
-ac_add_options --enable-release
-ac_add_options --enable-gold
-ac_add_options --enable-pie
-
-ac_add_options --enable-official-branding
-ac_add_options --enable-default-toolkit=cairo-gtk3
-
-# System libraries
-ac_add_options --with-system-nspr
-ac_add_options --with-system-nss
-ac_add_options --with-system-jpeg
-ac_add_options --with-system-zlib
-ac_add_options --with-system-bz2
-ac_add_options --with-system-png
-ac_add_options --with-system-libevent
-ac_add_options --with-system-libvpx
-ac_add_options --with-system-icu
-ac_add_options --enable-system-hunspell
-ac_add_options --enable-system-sqlite
-ac_add_options --enable-system-ffi
-# system cairo without layers acceleration results in choppy video playback
-#ac_add_options --enable-system-cairo
-ac_add_options --enable-system-pixman
-#ac_add_options --enable-clang-plugin
-
-# Features
-ac_add_options --enable-startup-notification
-ac_add_options --enable-pulseaudio
-#ac_add_options --disable-gstreamer
-
-ac_add_options --enable-rust
-
-ac_add_options --enable-crashreporter
-#ac_add_options --disable-telemetry-reporting
-ac_add_options --disable-updater
-#ac_add_options --disable-installer
-ac_add_options --disable-debug-symbols
-#ac_add_options --disable-cpp-rtti
-
-# vim:set ft=sh:
diff --git a/no-libnotify.patch b/no-libnotify.patch
deleted file mode 100644
index a01ccb429442..000000000000
--- a/no-libnotify.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff --git i/toolkit/system/gnome/moz.build w/toolkit/system/gnome/moz.build
-index 0ecde07..206d6eb 100644
---- i/toolkit/system/gnome/moz.build
-+++ w/toolkit/system/gnome/moz.build
-@@ -5,9 +5,7 @@
- # file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
- SOURCES += [
-- 'nsAlertsIconListener.cpp',
- 'nsGnomeModule.cpp',
-- 'nsSystemAlertsService.cpp',
- ]
-
- if CONFIG['MOZ_ENABLE_GCONF']:
-diff --git i/toolkit/system/gnome/nsGnomeModule.cpp w/toolkit/system/gnome/nsGnomeModule.cpp
-index 6ecebcc..2f193a3 100644
---- i/toolkit/system/gnome/nsGnomeModule.cpp
-+++ w/toolkit/system/gnome/nsGnomeModule.cpp
-@@ -20,8 +20,6 @@ NS_GENERIC_FACTORY_CONSTRUCTOR(nsGIOService)
- NS_GENERIC_FACTORY_CONSTRUCTOR_INIT(nsGSettingsService, Init)
- NS_GENERIC_FACTORY_CONSTRUCTOR_INIT(nsPackageKitService, Init)
- #endif
--#include "nsSystemAlertsService.h"
--NS_GENERIC_FACTORY_CONSTRUCTOR_INIT(nsSystemAlertsService, Init)
-
- #ifdef MOZ_ENABLE_GCONF
- NS_DEFINE_NAMED_CID(NS_GCONFSERVICE_CID);
-@@ -31,7 +29,6 @@ NS_DEFINE_NAMED_CID(NS_GIOSERVICE_CID);
- NS_DEFINE_NAMED_CID(NS_GSETTINGSSERVICE_CID);
- NS_DEFINE_NAMED_CID(NS_PACKAGEKITSERVICE_CID);
- #endif
--NS_DEFINE_NAMED_CID(NS_SYSTEMALERTSSERVICE_CID);
-
- static const mozilla::Module::CIDEntry kGnomeCIDs[] = {
- #ifdef MOZ_ENABLE_GCONF
-@@ -42,7 +39,6 @@ static const mozilla::Module::CIDEntry kGnomeCIDs[] = {
- { &kNS_GSETTINGSSERVICE_CID, false, nullptr, nsGSettingsServiceConstructor },
- { &kNS_PACKAGEKITSERVICE_CID, false, nullptr, nsPackageKitServiceConstructor },
- #endif
-- { &kNS_SYSTEMALERTSSERVICE_CID, false, nullptr, nsSystemAlertsServiceConstructor },
- { nullptr }
- };
-
-@@ -55,7 +51,6 @@ static const mozilla::Module::ContractIDEntry kGnomeContracts[] = {
- { NS_GSETTINGSSERVICE_CONTRACTID, &kNS_GSETTINGSSERVICE_CID },
- { NS_PACKAGEKITSERVICE_CONTRACTID, &kNS_PACKAGEKITSERVICE_CID },
- #endif
-- { NS_SYSTEMALERTSERVICE_CONTRACTID, &kNS_SYSTEMALERTSSERVICE_CID },
- { nullptr }
- };
diff --git a/vendor.js b/vendor.js
deleted file mode 100644
index d8d606bc15d7..000000000000
--- a/vendor.js
+++ /dev/null
@@ -1,9 +0,0 @@
-// Use LANG environment variable to choose locale
-pref("intl.locale.matchOS", true);
-
-// Disable default browser checking.
-pref("browser.shell.checkDefaultBrowser", false);
-
-// Don't disable our bundled extensions in the application directory
-pref("extensions.autoDisableScopes", 11);
-pref("extensions.shownSelectionUI", true);