summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
-rw-r--r--bug1654465.diff77
3 files changed, 96 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcf2ef84a241..7aa14c898b46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,6 @@ pkgbase = firefox-beta
makedepends = unzip
makedepends = zip
makedepends = diffutils
- makedepends = python2-setuptools
makedepends = yasm
makedepends = mesa
makedepends = imake
@@ -23,12 +22,12 @@ pkgbase = firefox-beta
makedepends = llvm
makedepends = jack
makedepends = gtk2
- makedepends = python
makedepends = nodejs
- makedepends = python2-psutil
makedepends = cbindgen
makedepends = nasm
- makedepends = xorgproto
+ makedepends = python-setuptools
+ makedepends = python-psutil
+ makedepends = lld
depends = gtk3
depends = libxt
depends = mime-types
@@ -50,11 +49,13 @@ pkgbase = firefox-beta
source = https://archive.mozilla.org/pub/firefox/releases/80.0b1/source/firefox-80.0b1.source.tar.xz
source = https://archive.mozilla.org/pub/firefox/releases/80.0b1/source/firefox-80.0b1.source.tar.xz.asc
source = 0001-Use-remoting-name-for-GDK-application-names.patch
+ source = bug1654465.diff
source = firefox-beta.desktop
validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
sha256sums = 284daebc9876878de648f0e10632db585cb3b2344b59ea3d0952589d96aee970
sha256sums = SKIP
sha256sums = 3bb7463471fb43b2163a705a79a13a3003d70fff4bbe44f467807ca056de9a75
+ sha256sums = e577f7e5636deda0026b0e385186f3ecb2212c9b84b6a2949a1811dab3e410d6
sha256sums = 54d93249fedc9c4cdc5eb82da498b08f08bcb089f85a138b457f3251a0913ad1
pkgname = firefox-beta
diff --git a/PKGBUILD b/PKGBUILD
index 5bd201fdf827..b0ec8e0718c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -58,9 +58,9 @@ arch=(i686 x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/en-US/firefox/channel/#beta"
depends=(gtk3 libxt mime-types dbus-glib ffmpeg 'nss>=3.55' ttf-font libpulse)
-makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
- xorg-server-xvfb autoconf2.13 rust clang llvm jack gtk2
- python nodejs python2-psutil cbindgen nasm xorgproto)
+makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
+ autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
+ python-setuptools python-psutil lld)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -71,10 +71,12 @@ conflicts=('firefox-beta-bin')
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/$_pkgname-$pkgver.source.tar.xz{,.asc}
0001-Use-remoting-name-for-GDK-application-names.patch
+ bug1654465.diff
$pkgname.desktop)
sha256sums=('284daebc9876878de648f0e10632db585cb3b2344b59ea3d0952589d96aee970'
'SKIP'
'3bb7463471fb43b2163a705a79a13a3003d70fff4bbe44f467807ca056de9a75'
+ 'e577f7e5636deda0026b0e385186f3ecb2212c9b84b6a2949a1811dab3e410d6'
'54d93249fedc9c4cdc5eb82da498b08f08bcb089f85a138b457f3251a0913ad1')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@@ -104,6 +106,9 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1654465
+ patch -Np1 -i ../bug1654465.diff
+
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@@ -115,6 +120,8 @@ ac_add_options --enable-release
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
+ac_add_options --enable-linker=lld
+ac_add_options --disable-elf-hack
export CC='clang --target=x86_64-unknown-linux-gnu'
export CXX='clang++ --target=x86_64-unknown-linux-gnu'
export AR=llvm-ar
@@ -179,15 +186,11 @@ END
xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" \
./mach python build/pgo/profileserver.py
- if [[ ! -s merged.profdata ]]; then
- echo "No profile data produced."
- return 1
- fi
+ stat -c "Profile data found (%s bytes)" merged.profdata
+ test -s merged.profdata
- if [[ ! -s jarlog ]]; then
- echo "No jar log produced."
- return 1
- fi
+ stat -c "Jar log found (%s bytes)" jarlog
+ test -s jarlog
echo "Removing instrumented browser..."
./mach clobber
diff --git a/bug1654465.diff b/bug1654465.diff
new file mode 100644
index 000000000000..f9982cb4d105
--- /dev/null
+++ b/bug1654465.diff
@@ -0,0 +1,77 @@
+ build/moz.configure/rust.configure | 2 +-
+ config/makefiles/rust.mk | 5 +++++
+ .../mozbuild/test/configure/test_toolchain_configure.py | 14 --------------
+ 3 files changed, 6 insertions(+), 15 deletions(-)
+
+diff --git c/build/moz.configure/rust.configure i/build/moz.configure/rust.configure
+index aaa693059d95..c90ae5ca7b25 100644
+--- c/build/moz.configure/rust.configure
++++ i/build/moz.configure/rust.configure
+@@ -146,7 +146,7 @@ def rust_compiler(rustc_info, cargo_info, build_project):
+ or by directly running the installer from https://rustup.rs/
+ '''))
+ if build_project == 'tools/crashreporter':
+- rustc_min_version = Version('1.31.0')
++ rustc_min_version = Version('1.38.0')
+ else:
+ rustc_min_version = Version('1.43.0')
+ cargo_min_version = rustc_min_version
+diff --git c/config/makefiles/rust.mk i/config/makefiles/rust.mk
+index a9abcc9af4c0..b5c7973104ce 100644
+--- c/config/makefiles/rust.mk
++++ i/config/makefiles/rust.mk
+@@ -63,6 +63,11 @@ ifndef MOZ_DEBUG_RUST
+ ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
+ cargo_rustc_flags += -Clto
+ endif
++# Versions of rust >= 1.45 need -Cembed-bitcode=yes for all crates when
++# using -Clto.
++ifeq (,$(filter 1.38.% 1.39.% 1.40.% 1.41.% 1.42.% 1.43.% 1.44.%,$(RUSTC_VERSION)))
++RUSTFLAGS += -Cembed-bitcode=yes
++endif
+ endif
+ endif
+
+diff --git c/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py i/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
+index e1921ece6865..759d4d98cc0d 100755
+--- c/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
++++ i/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
+@@ -1796,38 +1796,24 @@ class RustTest(BaseConfigureTest):
+ arm_arch=7, fpu='neon', thumb2=True, float_abi='softfp')),
+ 'thumbv7neon-linux-androideabi')
+
+- self.assertEqual(
+- self.get_rust_target('arm-unknown-linux-androideabi',
+- version='1.32.0',
+- arm_target=ReadOnlyNamespace(
+- arm_arch=7, fpu='neon', thumb2=True, float_abi='softfp')),
+- 'armv7-linux-androideabi')
+-
+ self.assertEqual(
+ self.get_rust_target('arm-unknown-linux-androideabi',
+ arm_target=ReadOnlyNamespace(
+ arm_arch=7, fpu='neon', thumb2=False, float_abi='softfp')),
+ 'armv7-linux-androideabi')
+
+ self.assertEqual(
+ self.get_rust_target('arm-unknown-linux-androideabi',
+ arm_target=ReadOnlyNamespace(
+ arm_arch=7, fpu='vfpv2', thumb2=True, float_abi='softfp')),
+ 'armv7-linux-androideabi')
+
+ self.assertEqual(
+ self.get_rust_target('armv7-unknown-linux-gnueabihf',
+ arm_target=ReadOnlyNamespace(
+ arm_arch=7, fpu='neon', thumb2=True, float_abi='hard')),
+ 'thumbv7neon-unknown-linux-gnueabihf')
+
+- self.assertEqual(
+- self.get_rust_target('armv7-unknown-linux-gnueabihf',
+- version='1.32.0',
+- arm_target=ReadOnlyNamespace(
+- arm_arch=7, fpu='neon', thumb2=True, float_abi='hard')),
+- 'armv7-unknown-linux-gnueabihf')
+-
+ self.assertEqual(
+ self.get_rust_target('armv7-unknown-linux-gnueabihf',
+ arm_target=ReadOnlyNamespace(