summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
-rw-r--r--firefox-beta-bin.desktop1
-rw-r--r--firefox-beta.sh2
-rw-r--r--policies.json5
5 files changed, 28 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0409e01bcfc1..347e2c3a1e19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-beta-bin
pkgdesc = Standalone web browser from mozilla.org - Beta
- pkgver = 70.0rc1
+ pkgver = 126.0b2
pkgrel = 1
url = https://www.mozilla.org/en-US/firefox/channel/#beta
install = firefox-beta-bin.install
@@ -8,10 +8,12 @@ pkgbase = firefox-beta-bin
license = MPL
license = GPL
license = LGPL
+ depends = alsa-lib
depends = dbus-glib
depends = gtk3
depends = libxt
depends = nss
+ depends = ccache
optdepends = ffmpeg: H264/AAC/MP3 decoding
optdepends = hunspell: Spell checking
optdepends = hyphen: Hyphenation
@@ -19,14 +21,15 @@ pkgbase = firefox-beta-bin
optdepends = networkmanager: Location detection via available WiFi networks
optdepends = pulseaudio: Sound
optdepends = upower: Battery API
- provides = firefox=70.0rc1
+ provides = firefox=126.0b2
conflicts = firefox-beta
- source = firefox-70.0rc1.tar.bz2::https://ftp.mozilla.org/pub/firefox/candidates/70.0-candidates/build1/linux-x86_64/en-US/firefox-70.0.tar.bz2
+ source = https://archive.mozilla.org/pub/firefox/releases/126.0b2/linux-x86_64/en-US/firefox-126.0b2.tar.bz2
source = firefox-beta.sh
source = firefox-beta-bin.desktop
- sha256sums = 471436dc15c42ed55ec3de3e121007dc8ce4966c0cc0114cd3bd05ca5f57672b
- sha256sums = 367100e5f66523a90c3792e2e0d0e2fe8a3c28748b905ce9f5f6b121343d7842
- sha256sums = 05dafb94c7dbe7a1fcc1e7555f350aebf7fd7bdc2459819273ac00d3ca5f028e
+ source = policies.json
+ sha256sums = 915ad101d26acf80a0ac18b4e787277b3d8c2d1371cc1796bd2cba641810390a
+ sha256sums = 4bec62032e49c28ff27750abddbdbdbb1a4b5cba719c39498968fe53adee790b
+ sha256sums = 210f13ea47c4b96387f26ee7fc4dfc5c192cfb169aef2a13303fbd1ee58b3761
+ sha256sums = e977c3d690224dd727d8761d2c0a66ba41bfd02ae0fd7850c4545d06b5a8e63c
pkgname = firefox-beta-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 3da5a30a22bd..5d5c132b5f2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Det <nimetonmaili g-mail>
-# Contributors: Achilleas Pipinellis, speed145a, Schnouki
+# Maintainer: Simon Brulhart <simon@brulhart.me>
+# Contributors: Det <nimetonmaili g-mail>, Achilleas Pipinellis, speed145a, Schnouki, bittin
pkgname=firefox-beta-bin
_pkgname=firefox-beta
-pkgver=70.0rc1
+pkgver=126.0b2
_major=${pkgver/rc*}
_build=${pkgver/*rc}
pkgrel=1
@@ -11,7 +11,7 @@ pkgdesc="Standalone web browser from mozilla.org - Beta"
arch=('x86_64')
url="https://www.mozilla.org/en-US/firefox/channel/#beta"
license=('MPL' 'GPL' 'LGPL')
-depends=('dbus-glib' 'gtk3' 'libxt' 'nss')
+depends=('alsa-lib' 'dbus-glib' 'gtk3' 'libxt' 'nss' 'ccache')
optdepends=('ffmpeg: H264/AAC/MP3 decoding'
'hunspell: Spell checking'
'hyphen: Hyphenation'
@@ -22,12 +22,14 @@ optdepends=('ffmpeg: H264/AAC/MP3 decoding'
provides=("firefox=$pkgver")
conflicts=('firefox-beta')
install=$pkgname.install
-source=("https://ftp.mozilla.org/pub/firefox/releases/$pkgver/linux-x86_64/en-US/firefox-$pkgver.tar.bz2"
+source=("https://archive.mozilla.org/pub/firefox/releases/$pkgver/linux-x86_64/en-US/firefox-$pkgver.tar.bz2"
"$_pkgname.sh"
- "$pkgname.desktop")
-sha256sums=('471436dc15c42ed55ec3de3e121007dc8ce4966c0cc0114cd3bd05ca5f57672b'
- '367100e5f66523a90c3792e2e0d0e2fe8a3c28748b905ce9f5f6b121343d7842'
- '05dafb94c7dbe7a1fcc1e7555f350aebf7fd7bdc2459819273ac00d3ca5f028e')
+ "$pkgname.desktop"
+ "policies.json")
+sha256sums=('915ad101d26acf80a0ac18b4e787277b3d8c2d1371cc1796bd2cba641810390a'
+ '4bec62032e49c28ff27750abddbdbdbb1a4b5cba719c39498968fe53adee790b'
+ '210f13ea47c4b96387f26ee7fc4dfc5c192cfb169aef2a13303fbd1ee58b3761'
+ 'e977c3d690224dd727d8761d2c0a66ba41bfd02ae0fd7850c4545d06b5a8e63c')
# RC
if [[ $_build = ? ]]; then
source[0]="firefox-$pkgver.tar.bz2::https://ftp.mozilla.org/pub/firefox/candidates/$_major-candidates/build$_build/linux-x86_64/en-US/firefox-$_major.tar.bz2"
@@ -43,6 +45,7 @@ package() {
msg2 "Moving stuff in place..."
# Install
cp -r firefox/ "$pkgdir"/opt/$_pkgname
+ install -m644 policies.json -D -t "$pkgdir"/opt/$_pkgname/distribution/
# Launchers
install -m755 $_pkgname.sh "$pkgdir"/usr/bin/$_pkgname
diff --git a/firefox-beta-bin.desktop b/firefox-beta-bin.desktop
index 6462021c4f51..d874a1b50957 100644
--- a/firefox-beta-bin.desktop
+++ b/firefox-beta-bin.desktop
@@ -88,7 +88,6 @@ Icon=firefox-beta
Terminal=false
Type=Application
MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
-StartupNotify=true
StartupWMClass=Firefox Beta
Categories=Network;WebBrowser;
Keywords=web;browser;internet;
diff --git a/firefox-beta.sh b/firefox-beta.sh
index 4323c996bf27..7ea72a9912a1 100644
--- a/firefox-beta.sh
+++ b/firefox-beta.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec /opt/firefox-beta/firefox --class "Firefox Beta" "$@"
+exec /opt/firefox-beta/firefox --class "Firefox Beta" --name "Firefox Beta" "$@"
diff --git a/policies.json b/policies.json
new file mode 100644
index 000000000000..f36622021fcd
--- /dev/null
+++ b/policies.json
@@ -0,0 +1,5 @@
+{
+ "policies": {
+ "DisableAppUpdate": true
+ }
+}