summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
-rw-r--r--policies.json5
3 files changed, 24 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a03377c34fa..5e37b4fe3fbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-beta-bin
pkgdesc = Standalone web browser from mozilla.org - Beta
- pkgver = 72.0b2
+ pkgver = 126.0b5
pkgrel = 1
url = https://www.mozilla.org/en-US/firefox/channel/#beta
install = firefox-beta-bin.install
@@ -8,10 +8,12 @@ pkgbase = firefox-beta-bin
license = MPL
license = GPL
license = LGPL
+ depends = alsa-lib
depends = dbus-glib
depends = gtk3
depends = libxt
depends = nss
+ depends = ccache
optdepends = ffmpeg: H264/AAC/MP3 decoding
optdepends = hunspell: Spell checking
optdepends = hyphen: Hyphenation
@@ -19,14 +21,15 @@ pkgbase = firefox-beta-bin
optdepends = networkmanager: Location detection via available WiFi networks
optdepends = pulseaudio: Sound
optdepends = upower: Battery API
- provides = firefox=72.0b2
+ provides = firefox=126.0b5
conflicts = firefox-beta
- source = https://ftp.mozilla.org/pub/firefox/releases/72.0b2/linux-x86_64/en-US/firefox-72.0b2.tar.bz2
+ source = https://archive.mozilla.org/pub/firefox/releases/126.0b5/linux-x86_64/en-US/firefox-126.0b5.tar.bz2
source = firefox-beta.sh
source = firefox-beta-bin.desktop
- sha256sums = e8896d9b75f0e67988313cf7ce3e78dde38ebff44688a0526f7647db7c5a49c9
+ source = policies.json
+ sha256sums = 8f96bbe7c30b3a8c43d05ec33e20f51353ad5ed207af93aa9eb886119f371b81
sha256sums = 4bec62032e49c28ff27750abddbdbdbb1a4b5cba719c39498968fe53adee790b
sha256sums = 210f13ea47c4b96387f26ee7fc4dfc5c192cfb169aef2a13303fbd1ee58b3761
+ sha256sums = e977c3d690224dd727d8761d2c0a66ba41bfd02ae0fd7850c4545d06b5a8e63c
pkgname = firefox-beta-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index d12be04f4b47..713e81ae5b66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Det <nimetonmaili g-mail>
-# Contributors: Achilleas Pipinellis, speed145a, Schnouki
+# Maintainer: Simon Brulhart <simon@brulhart.me>
+# Contributors: Det <nimetonmaili g-mail>, Achilleas Pipinellis, speed145a, Schnouki, bittin
pkgname=firefox-beta-bin
_pkgname=firefox-beta
-pkgver=72.0b2
+pkgver=126.0b5
_major=${pkgver/rc*}
_build=${pkgver/*rc}
pkgrel=1
@@ -11,7 +11,7 @@ pkgdesc="Standalone web browser from mozilla.org - Beta"
arch=('x86_64')
url="https://www.mozilla.org/en-US/firefox/channel/#beta"
license=('MPL' 'GPL' 'LGPL')
-depends=('dbus-glib' 'gtk3' 'libxt' 'nss')
+depends=('alsa-lib' 'dbus-glib' 'gtk3' 'libxt' 'nss' 'ccache')
optdepends=('ffmpeg: H264/AAC/MP3 decoding'
'hunspell: Spell checking'
'hyphen: Hyphenation'
@@ -22,12 +22,14 @@ optdepends=('ffmpeg: H264/AAC/MP3 decoding'
provides=("firefox=$pkgver")
conflicts=('firefox-beta')
install=$pkgname.install
-source=("https://ftp.mozilla.org/pub/firefox/releases/$pkgver/linux-x86_64/en-US/firefox-$pkgver.tar.bz2"
+source=("https://archive.mozilla.org/pub/firefox/releases/$pkgver/linux-x86_64/en-US/firefox-$pkgver.tar.bz2"
"$_pkgname.sh"
- "$pkgname.desktop")
-sha256sums=('e8896d9b75f0e67988313cf7ce3e78dde38ebff44688a0526f7647db7c5a49c9'
+ "$pkgname.desktop"
+ "policies.json")
+sha256sums=('8f96bbe7c30b3a8c43d05ec33e20f51353ad5ed207af93aa9eb886119f371b81'
'4bec62032e49c28ff27750abddbdbdbb1a4b5cba719c39498968fe53adee790b'
- '210f13ea47c4b96387f26ee7fc4dfc5c192cfb169aef2a13303fbd1ee58b3761')
+ '210f13ea47c4b96387f26ee7fc4dfc5c192cfb169aef2a13303fbd1ee58b3761'
+ 'e977c3d690224dd727d8761d2c0a66ba41bfd02ae0fd7850c4545d06b5a8e63c')
# RC
if [[ $_build = ? ]]; then
source[0]="firefox-$pkgver.tar.bz2::https://ftp.mozilla.org/pub/firefox/candidates/$_major-candidates/build$_build/linux-x86_64/en-US/firefox-$_major.tar.bz2"
@@ -43,6 +45,7 @@ package() {
msg2 "Moving stuff in place..."
# Install
cp -r firefox/ "$pkgdir"/opt/$_pkgname
+ install -m644 policies.json -D -t "$pkgdir"/opt/$_pkgname/distribution/
# Launchers
install -m755 $_pkgname.sh "$pkgdir"/usr/bin/$_pkgname
diff --git a/policies.json b/policies.json
new file mode 100644
index 000000000000..f36622021fcd
--- /dev/null
+++ b/policies.json
@@ -0,0 +1,5 @@
+{
+ "policies": {
+ "DisableAppUpdate": true
+ }
+}