summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD16
2 files changed, 8 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de4a7df64766..67eb6b535c12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,46 +1,6 @@
pkgbase = firefox-developer-da
pkgdesc = Standalone web browser from mozilla.org, developer build - Danish
pkgver = 55.0b6
- pkgrel = 1
- url = http://www.mozilla.org/firefox/developer
- arch = x86_64
- license = MPL
- license = GPL
- license = LGPL
- depends = dbus-glib
- depends = gtk3
- depends = libxt
- depends = mime-types
- depends = nss
- depends = sqlite
- optdepends = alsa-lib: An alternative implementation of Linux sound support
- optdepends = ffmpeg: Complete solution to record, convert and stream audio and video
- optdepends = gtk2: flash plugin support
- optdepends = gtk3-print-backends: Print support
- optdepends = hunspell: Spell checking
- optdepends = hyphen: Hyphenation
- optdepends = libnotify: Notification integration
- optdepends = networkmanager: Location detection via available WiFi networks
- optdepends = pulseaudio: Audio/video playback
- optdepends = speech-dispatcher: Text to Speech
- optdepends = startup-notification: Support for FreeDesktop Startup Notification
- source = https://download-installer.cdn.mozilla.net/pub/devedition/releases/55.0b6/linux-x86_64/da/firefox-55.0b6.tar.bz2
- source = https://download-installer.cdn.mozilla.net/pub/devedition/releases/55.0b6/SHA512SUMS
- source = https://download-installer.cdn.mozilla.net/pub/devedition/releases/55.0b6/SHA512SUMS.asc
- source = firefox-developer.desktop
- source = vendor.js
- validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
- sha512sums = aeb0d26b878769cbb5e3748151072942cc92cccc456b2f5e066483e4744d8faa086bc77d223a9810463478b25d22b33acce54726a0431a33b6038ee6a8c478ea
- sha512sums = 3f2ac3b9ad5f509acca49c4de616706a475c1a06c559296703ea54db28f1442b64bf0fece3b75b4df7c4b7a39350b8077b9efb47dae057464c56d5df274c479d
- sha512sums = SKIP
- sha512sums = b109b884ed79e9e214541750a0fcac8d7d8891cc7f0e0d472b717a5b71e569ab5852534bceaab045a5b13a9290a7905604d08fe97e28c675a2266c30fe719cb6
- sha512sums = bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010
-
-pkgname = firefox-developer-da
-
-pkgbase = firefox-developer-da
- pkgdesc = Standalone web browser from mozilla.org, developer build - Danish
- pkgver = 55.0b6
pkgrel = 6
url = http://www.mozilla.org/firefox/developer
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e095ae90212c..8850eba6ee74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,23 +50,23 @@ optdepends=(
)
prepare() {
- msg2 "!> Vigtigt: Det er nødvendigt at importere"
- msg2 "!> PGP nøgle for 'Mozilla Sofware Releases' <release@mozilla.com>"
- msg2 "!> Mere information kan findes her:"
- msg2 "!> <https://wiki.archlinux.org/index.php/GnuPG#Import_a_public_key>"
- msg2 "!> $ gpg --keyserver pgp.mit.edu --recv-keys D98F0353"
+ msg "!> Vigtigt: Det er nødvendigt at importere"
+ msg "!> PGP nøgle for 'Mozilla Sofware Releases' <release@mozilla.com>"
+ msg "!> Mere information kan findes her:"
+ msg "!> <https://wiki.archlinux.org/index.php/GnuPG#Import_a_public_key>"
+ msg "!> $ gpg --keyserver pgp.mit.edu --recv-keys D98F0353"
# Check if hash of the source archive matches the one provided by Mozilla (which was signed with GPG).
_checksum=`grep "linux-x86_64/$_lang/firefox-$pkgver.tar.bz2" $srcdir/SHA512SUMS | cut -f1 -d " "`
_actual=`sha512sum $srcdir/firefox-$pkgver.tar.bz2 | cut -f1 -d " "`
- msg2 "!> Checking integrity of firefox-$pkgver.tar.bz2"
+ msg "!> Checking integrity of firefox-$pkgver.tar.bz2"
if [[ $_checksum == $_actual ]];
then
- msg2 "!> Integrity verified successfully."
+ msg "!> Integrity verified successfully."
else
- msg2 "!> Integrity verification failed!"
+ msg "!> Integrity verification failed!"
exit 1
fi
}