summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD36
2 files changed, 36 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3918c328e107..6b2ce657e2c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-developer-es-mx
pkgdesc = Standalone web browser from mozilla.org, developer build (es-MX)
- pkgver = 54.0a2.20170307
+ pkgver = 56.0b7.20170830
pkgrel = 1
url = http://www.mozilla.org/projects/firefox
arch = i686
@@ -8,25 +8,28 @@ pkgbase = firefox-developer-es-mx
license = MPL
license = GPL
license = LGPL
- depends = alsa-lib
+ depends = dbus-glib
+ depends = gtk3
depends = libxt
- depends = libnotify
- depends = mime-types
depends = nss
- depends = gtk2
- depends = gtk3
- depends = sqlite
- depends = dbus-glib
+ depends = mime-types
+ optdepends = pulseaudio: audio support
+ optdepends = ffmpeg: h.264 video
+ optdepends = gtk2: flash plugin support
+ optdepends = hunspell: spell checking
+ optdepends = hyphen: hyphenation
+ optdepends = libnotify: notification integration
+ optdepends = networkmanager: location detection via available WiFi networks
+ optdepends = speech-dispatcher: text-to-speech
+ optdepends = startup-notification: support for FreeDesktop Startup Notification
conflicts = firefox-developer
source = firefox-developer.desktop
source = vendor.js
- source = https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-aurora-l10n/firefox-54.0a2.es-MX.linux-x86_64.tar.bz2
- source = https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-aurora/firefox-54.0a2.en-US.linux-x86_64.txt
+ source = https://download-installer.cdn.mozilla.net/pub/devedition/releases/56.0b7/linux-x86_64/es-MX/firefox-56.0b7.tar.bz2
validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
sha512sums = 018c9995046572ed85bd8b6b569ed5dfd3fdfeec3ca25d013879ce1fd6faac13362d2c1554af3351e9ed672e316f7e6c4130760b48c973e65ef37abaf44f7864
sha512sums = bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010
- sha512sums = SKIP
- sha512sums = SKIP
+ sha512sums = a9702aff50e7d30e770f4331c9d529a68a04103fd03130ecbc520f01eeeff391b49e708b0adb6a4c20e09f9ef08090d7662cb46536ea8adec9edc2774901561b
pkgname = firefox-developer-es-mx
diff --git a/PKGBUILD b/PKGBUILD
index 579e012eb3f7..fefb5d19673e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,34 +9,40 @@
_name=firefox
_channel=developer
_lang=es-MX
+_codename=date
pkgname="${_name}-${_channel}-${_lang,,}"
pkgdesc="Standalone web browser from mozilla.org, developer build (${_lang})"
url="http://www.mozilla.org/projects/firefox"
-pkgver=54.0a2.20170307
-_version=54.0a2
+pkgver=56.0b7.20170830
+_version=56.0b7
pkgrel=1
arch=('i686' 'x86_64')
conflicts=('firefox-developer')
license=('MPL' 'GPL' 'LGPL')
-_file="${_name}-${_version}.en-US.linux"
-_file_l10n="${_name}-${_version}.${_lang}.linux"
-_srcurl="https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-aurora"
-_srcurl_l10n="${_srcurl}-l10n"
+_srcurl="https://download-installer.cdn.mozilla.net/pub/devedition/releases"
source=(
- 'firefox-developer.desktop' 'vendor.js'
- "${_srcurl_l10n}/${_file_l10n}-${CARCH}.tar.bz2"
- "${_srcurl}/${_file}-${CARCH}.txt")
+ 'firefox-developer.desktop'
+ 'vendor.js'
+ "${_srcurl}/${_version}/linux-${CARCH}/${_lang}/${_name}-${_version}.tar.bz2")
sha512sums=(
'018c9995046572ed85bd8b6b569ed5dfd3fdfeec3ca25d013879ce1fd6faac13362d2c1554af3351e9ed672e316f7e6c4130760b48c973e65ef37abaf44f7864'
'bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010'
- 'SKIP'
- 'SKIP')
+ 'a9702aff50e7d30e770f4331c9d529a68a04103fd03130ecbc520f01eeeff391b49e708b0adb6a4c20e09f9ef08090d7662cb46536ea8adec9edc2774901561b')
+depends=('dbus-glib' 'gtk3' 'libxt' 'nss' 'mime-types')
+optdepends=('pulseaudio: audio support'
+ 'ffmpeg: h.264 video'
+ 'gtk2: flash plugin support'
+ 'hunspell: spell checking'
+ 'hyphen: hyphenation'
+ 'libnotify: notification integration'
+ 'networkmanager: location detection via available WiFi networks'
+ 'speech-dispatcher: text-to-speech'
+ 'startup-notification: support for FreeDesktop Startup Notification')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353')
-depends=('alsa-lib' 'libxt' 'libnotify' 'mime-types' 'nss' 'gtk2' 'gtk3'
- 'sqlite' 'dbus-glib')
-pkgver() {
- echo "${_version}.$(head -n1 "${srcdir}/${_file}-${CARCH}.txt" | cut -c-8)"
+prepare() {
+ # remove the dictionaries included in the archive
+ rm -rf firefox/dictionaries
}
package() {