summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--0000-rust-1.29.patch36
-rw-r--r--PKGBUILD24
3 files changed, 56 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e80d1ee7027..3291bf2a7118 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-esr
pkgdesc = Standalone web browser from mozilla.org, Extended Support Release
pkgver = 60.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.mozilla.org/en-US/firefox/organizations/
arch = i686
arch = x86_64
@@ -43,6 +43,7 @@ pkgbase = firefox-esr
optdepends = libnotify: Notification integration
optdepends = pulseaudio: Audio support
optdepends = speech-dispatcher: Text-to-Speech
+ optdepends = clang
provides = firefox
conflicts = firefox
options = !emptydirs
@@ -51,10 +52,12 @@ pkgbase = firefox-esr
source = https://ftp.mozilla.org/pub/firefox/releases/60.2.0esr/source/firefox-60.2.0esr.source.tar.xz
source = firefox.desktop
source = firefox-symbolic.svg
+ source = 0000-rust-1.29.patch
validpgpkeys = 2B90598A745E992F315E22C58AB132963A06537A
sha256sums = 795bdc8b5648234ce74322e3e9b219947d984ce3a1e4e09ce1061fafbbe77717
sha256sums = c202e5e18da1eeddd2e1d81cb3436813f11e44585ca7357c4c5f1bddd4bec826
sha256sums = a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9
+ sha256sums = ce243b1e835651723d2186709fcd5218ad050ff56550c3ef25e23c718a69497b
pkgname = firefox-esr
diff --git a/0000-rust-1.29.patch b/0000-rust-1.29.patch
new file mode 100644
index 000000000000..023dbfd1d857
--- /dev/null
+++ b/0000-rust-1.29.patch
@@ -0,0 +1,36 @@
+
+diff --git a/build/moz.configure/init.configure b/build/moz.configure/init.configure
+--- a/build/moz.configure/init.configure
++++ b/build/moz.configure/init.configure
+@@ -587,17 +587,26 @@ option('--target', nargs=1,
+ @imports(_from='__builtin__', _import='KeyError')
+ @imports(_from='__builtin__', _import='ValueError')
+ def split_triplet(triplet, allow_unknown=False):
+ # The standard triplet is defined as
+ # CPU_TYPE-MANUFACTURER-OPERATING_SYSTEM
+ # There is also a quartet form:
+ # CPU_TYPE-MANUFACTURER-KERNEL-OPERATING_SYSTEM
+ # But we can consider the "KERNEL-OPERATING_SYSTEM" as one.
+- cpu, manufacturer, os = triplet.split('-', 2)
++ # Additionally, some may omit "unknown" when the manufacturer
++ # is not specified and emit
++ # CPU_TYPE-OPERATING_SYSTEM
++ parts = triplet.split('-', 2)
++ if len(parts) == 3:
++ cpu, _, os = parts
++ elif len(parts) == 2:
++ cpu, os = parts
++ else:
++ die("Unexpected triplet string: %s" % triplet)
+
+ # Autoconf uses config.sub to validate and canonicalize those triplets,
+ # but the granularity of its results has never been satisfying to our
+ # use, so we've had our own, different, canonicalization. We've also
+ # historically not been very consistent with how we use the canonicalized
+ # values. Hopefully, this will help us make things better.
+ # The tests are inherited from our decades-old autoconf-based configure,
+ # which can probably be improved/cleaned up because they are based on a
+
+
+
+
diff --git a/PKGBUILD b/PKGBUILD
index b17d62a853e5..f137928b9532 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=firefox-esr
pkgver=60.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="Standalone web browser from mozilla.org, Extended Support Release"
arch=(i686 x86_64)
license=(MPL GPL LGPL)
@@ -22,12 +22,17 @@ provides=(firefox)
conflicts=(firefox)
options=(!emptydirs !makeflags !strip)
source=(https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz
- firefox.desktop firefox-symbolic.svg)
+ firefox.desktop firefox-symbolic.svg 0000-rust-1.29.patch)
sha256sums=('795bdc8b5648234ce74322e3e9b219947d984ce3a1e4e09ce1061fafbbe77717'
'c202e5e18da1eeddd2e1d81cb3436813f11e44585ca7357c4c5f1bddd4bec826'
- 'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9')
+ 'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
+ 'ce243b1e835651723d2186709fcd5218ad050ff56550c3ef25e23c718a69497b')
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
+## Set this variable to 1 if you want to build with clang compiler ##
+#_CLANG=0
+[ "$_CLANG" ] && [ "$_CLANG" -eq "1" ] && optdepends+=(clang)
+
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
@@ -41,11 +46,12 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() {
-# mkdir -p path
-# ln -sf /usr/bin/python2 path/python
-
cd firefox-${pkgver}
+ # Bug 1479540 - Accept "triplet" strings with only two parts in moz.configure
+ # https://hg.mozilla.org/mozreview/gecko/rev/e820a3a4ce2284ecd2992dc827fedc357b75eeb7#index_header
+ patch -Np1 -i ../0000-rust-1.29.patch
+
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@@ -101,8 +107,10 @@ build() {
# export PATH="$srcdir/path:$PATH"
# Build with clang
- export CC=clang
- export CXX=clang++
+ if [ "$_CLANG" -eq "1" ]; then
+ export CC=clang
+ export CXX=clang++
+ fi
# Do PGO
#xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \