summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9ebf87c9fbe..1fe0a8d0bdd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = firefox-extension-cookie-autodelete
pkgdesc = Firefox extension that automatically deletes cookies.
pkgver = 3.4.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Cookie-AutoDelete/Cookie-AutoDelete
arch = any
- groups = firefox-addons
license = MIT
- depends = firefox
- source = https://github.com/Cookie-AutoDelete/Cookie-AutoDelete/archive/v3.4.0.tar.gz
+ source = firefox-extension-cookie-autodelete-3.4.0.tar.gz::https://github.com/Cookie-AutoDelete/Cookie-AutoDelete/archive/v3.4.0.tar.gz
b2sums = 09fb14d9950982ab503c6f8489e6acd7435e1bc1a2f3815adde891021c17ffe243bb56687a8a940d1c08a66a273a965d4e0397c2c9940d10218751c317976494
pkgname = firefox-extension-cookie-autodelete
diff --git a/PKGBUILD b/PKGBUILD
index d5b0e24c5f84..f7f49f518f2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,18 @@
pkgname='firefox-extension-cookie-autodelete'
pkgver=3.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="Firefox extension that automatically deletes cookies."
license=('MIT')
arch=('any')
url="https://github.com/Cookie-AutoDelete/Cookie-AutoDelete"
-depends=('firefox')
-groups=('firefox-addons')
-source=("https://github.com/Cookie-AutoDelete/Cookie-AutoDelete/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Cookie-AutoDelete/Cookie-AutoDelete/archive/v$pkgver.tar.gz")
b2sums=('09fb14d9950982ab503c6f8489e6acd7435e1bc1a2f3815adde891021c17ffe243bb56687a8a940d1c08a66a273a965d4e0397c2c9940d10218751c317976494')
prepare() {
- msg "Install npm dependencies"
npm --silent -C "Cookie-AutoDelete-$pkgver" install
- msg "Fix vulnerabilities found in installed npm dependencies"
+ # Fix possible vulnerabilities in npm dependencies
npm --silent -C "Cookie-AutoDelete-$pkgver" audit fix
# Force to build release for $pkgver
@@ -31,7 +28,7 @@ build() {
package() {
cd "Cookie-AutoDelete-$pkgver"
- install -Dm644 LICENSE "$pkgver/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd builds
install -Dm644 "Cookie-AutoDelete_${pkgver}_Firefox.xpi" "$pkgdir/usr/lib/firefox/browser/extensions/CookieAutoDelete@kennydo.com.xpi"