summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a3a42b181f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = firefox-extension-unmht
+ pkgdesc = view MHT (MHTML) web archive format files, and save complete web pages, including text and graphics, into a single MHT file.
+ pkgver = 7.3.0.5
+ pkgrel = 1
+ url = https://addons.mozilla.org/firefox/addon/unmht
+ arch = any
+ license = MPL
+ depends = firefox
+ source = unmht-7.3.0.5.xpi::https://addons.cdn.mozilla.net/user-media/addons/8051/unmht-7.3.0.5-sm+an+fx+tb.xpi
+ sha256sums = 1ef360d4aa7f5991a49c642d9d132de6dab5807729a9207a133602454ab445aa
+
+pkgname = firefox-extension-unmht
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4955bf5a759d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+# Contributor: Tianjiao Yin <ytj000+aur@gmail.com>
+
+_plugin_name=unmht
+_plugin_version=7.3.0.5
+pkgdesc="view MHT (MHTML) web archive format files, and save complete web pages, including text and graphics, into a single MHT file."
+license=('MPL')
+
+pkgname=firefox-extension-${_plugin_name}
+pkgver=${_plugin_version}
+pkgrel=1
+arch=('any')
+url="https://addons.mozilla.org/firefox/addon/unmht"
+depends=("firefox")
+source=("${_plugin_name}-${_plugin_version}.xpi::https://addons.cdn.mozilla.net/user-media/addons/8051/${_plugin_name}-${_plugin_version}-sm+an+fx+tb.xpi")
+
+package() {
+ cd $srcdir
+ emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+ local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
+ install -d $dstdir
+ rm *.xpi
+ mv * $dstdir
+}
+sha256sums=('1ef360d4aa7f5991a49c642d9d132de6dab5807729a9207a133602454ab445aa')