summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8b826bd90d7..48435bb8e072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,11 +53,13 @@ prepare() {
fi
done
msg "Matched LANGs: ${sys_lang_list[*]}"
-
- countdown 10 & countdown_pid=$!
- read -s -n 1 -t 10 ikey || true
- kill $countdown_pid
- echo -e -n "\n"
+
+ tty -s && {
+ countdown 10 & countdown_pid=$!
+ read -s -n 1 -t 10 ikey || true
+ kill $countdown_pid
+ echo -e -n "\n"
+ }
if [ "$ikey" = "i" ]; then
# Pre-select menu items