summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD48
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b67d1882cceb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = firefox-ubuntu-bin
+ pkgdesc = Standalone web browser from mozilla.org with Ubuntu patches (binary)
+ pkgver = 58.0
+ pkgrel = 1
+ url = https://www.mozilla.org/firefox/
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = MPL
+ depends = dbus-glib
+ depends = ffmpeg
+ depends = gtk2
+ depends = gtk3
+ depends = hunspell
+ depends = icu
+ depends = libpulse
+ depends = libvpx
+ depends = libxt
+ depends = mime-types
+ depends = mozilla-common
+ depends = nss
+ depends = sqlite
+ depends = startup-notification
+ depends = ttf-font
+ optdepends = libnotify: Notification integration
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = pulseaudio: Audio support
+ optdepends = speech-dispatcher: Text-to-Speech
+ provides = firefox
+ provides = firefox-ubuntu
+ conflicts = firefox
+ conflicts = firefox-ubuntu
+ source = http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_58.0+build6-0ubuntu0.17.10.1_amd64.deb
+ md5sums = f0f4787491e5731c50c20cd7a74f4504
+
+pkgname = firefox-ubuntu-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a1124a4fae8e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar*
+firefox_*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24fe71411214
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: aimileus < $(echo YWltaWxpdXNAcHJvdG9ubWFpbC5jb20K | base64 -d) >
+pkgname=firefox-ubuntu-bin
+_pkgname=firefox
+pkgver=58.0
+_ubuntuver="$pkgver+build6-0ubuntu0.17.10.1_amd64"
+pkgrel=1
+pkgdesc="Standalone web browser from mozilla.org with Ubuntu patches (binary)"
+arch=("x86_64")
+url="https://www.mozilla.org/firefox/"
+license=('GPL' 'LGPL' 'MPL')
+depends=(
+ 'dbus-glib'
+ 'ffmpeg'
+ 'gtk2'
+ 'gtk3'
+ 'hunspell'
+ 'icu'
+ 'libpulse'
+ 'libvpx'
+ 'libxt'
+ 'mime-types'
+ 'mozilla-common'
+ 'nss'
+ 'sqlite'
+ 'startup-notification'
+ 'ttf-font'
+)
+optdepends=(
+ 'libnotify: Notification integration'
+ 'networkmanager: Location detection via available WiFi networks'
+ 'pulseaudio: Audio support'
+ 'speech-dispatcher: Text-to-Speech'
+)
+provides=('firefox' 'firefox-ubuntu')
+conflicts=('firefox' 'firefox-ubuntu')
+source=("http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_$_ubuntuver.deb")
+md5sums=('f0f4787491e5731c50c20cd7a74f4504')
+
+prepare() {
+ tar xvf data.tar.xz
+ # UBUNTU_MENUPROXY=0 is a requirement for global menus
+ # https://github.com/rilian-la-te/vala-panel-appmenu/issues/125
+ sed -i 's|Exec=firefox|Exec=env UBUNTU_MENUPROXY=0 firefox|' usr/share/applications/firefox.desktop
+}
+
+package() {
+ install -Dm755 etc usr -t "$pkgdir/"
+}