summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO40
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD70
-rw-r--r--firefox-unbranded-bin-safe.desktop25
-rw-r--r--firefox-unbranded-bin.desktop25
-rw-r--r--firefox-unbranded-bin.install17
6 files changed, 178 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f633b123cb0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = firefox-unbranded-bin
+ pkgdesc = Standalone web browser from mozilla.org - Unbranded version (binary)
+ pkgver = 49.0.2
+ pkgrel = 1
+ url = https://wiki.mozilla.org/Add-ons/Extension_Signing#Latest_Builds
+ install = firefox-unbranded-bin.install
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = alsa-lib
+ depends = dbus-glib
+ depends = desktop-file-utils
+ depends = gtk2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = icu
+ depends = libevent
+ depends = libvpx
+ depends = libxt
+ depends = mime-types
+ depends = nss
+ depends = sqlite
+ optdepends = ffmpeg: H264/AAC/MP3 decoding
+ optdepends = libpulse: PulseAudio driver
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = upower: Battery API
+ provides = firefox=49.0.2
+ conflicts = firefox
+ conflicts = firefox-unbranded
+ source = firefox-unbranded-bin.desktop
+ source = firefox-unbranded-bin-safe.desktop
+ validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
+ sha512sums = 88849a4d75ed528e21272364461c70a968fc92b661d1dd5007ff54aff11080d2555666cdddd34f0969e2b4bd4d9e1f588133a073323c646b507bc2be6a4e2b23
+ sha512sums = cfc78bb8dbf4bff0da690ff185e9c27ad1cdfc742d8c65aebba22e711aefb634a55c9d941bcc3c46e4e17d515fdefd3a8bb1b4d61cb946ccda0854041181c3fb
+ source_x86_64 = https://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-release-linux64-add-on-devel/1474711644/firefox-49.0.2.en-US.linux-x86_64-add-on-devel.tar.bz2
+ sha512sums_x86_64 = 7df80ccee6ec98f181b0247aac02fbbbca94bde8d47bdf5932c3ca012db2f0a1ea99b815a80a7c68f5c40e3c23c34b221040e6c5f12497b19c66940d2ef2313c
+
+pkgname = firefox-unbranded-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00f08bfcd3d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: LA-MJ <4mr.minj+aur [at] g-mail>
+# based on modified PKGBUILD for firefox-beta-bin by Det et al
+
+pkgname=firefox-unbranded-bin
+_pkgname=firefox-unbranded
+_name=firefox
+pkgver=49.0.2
+pkgrel=1
+pkgdesc="Standalone web browser from mozilla.org - Unbranded version (binary)"
+arch=('x86_64')
+url="https://wiki.mozilla.org/Add-ons/Extension_Signing#Latest_Builds"
+license=('MPL' 'GPL' 'LGPL')
+depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'gtk3' 'hicolor-icon-theme'
+ 'icu' 'libevent' 'libvpx' 'libxt' 'mime-types' 'nss' 'sqlite')
+optdepends=('ffmpeg: H264/AAC/MP3 decoding'
+ 'libpulse: PulseAudio driver'
+ 'networkmanager: Location detection via available WiFi networks'
+ 'upower: Battery API')
+provides=("firefox=$pkgver")
+conflicts=("firefox"
+ "firefox-unbranded")
+install=$pkgname.install
+validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353')
+_rooturl="https://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-release-linux64-add-on-devel"
+_lasttmstmp="$(curl -s "${_rooturl}/" | grep -Po '(?<=/)\d+(?=/")' | sort -n | tail -n1)"
+_srcurl="${_rooturl}/${_lasttmstmp}"
+_pkgver=$(curl -s "${_srcurl}/" | grep -Pom1 "(?<=/${_name}-)[\w.]+(?=\.en-US)")
+_file="${_name}-${_pkgver}.en-US.linux-x86_64-add-on-devel"
+_sha512sum="$(curl -s "${_srcurl}/${_file}.checksums" | grep "${_file}.tar.bz2" | grep sha512 | cut -d " " -f1)"
+source=("$pkgname.desktop"
+ "$pkgname-safe.desktop")
+source_x86_64=("${_srcurl}/${_file}.tar.bz2")
+sha512sums=('88849a4d75ed528e21272364461c70a968fc92b661d1dd5007ff54aff11080d2555666cdddd34f0969e2b4bd4d9e1f588133a073323c646b507bc2be6a4e2b23'
+ 'cfc78bb8dbf4bff0da690ff185e9c27ad1cdfc742d8c65aebba22e711aefb634a55c9d941bcc3c46e4e17d515fdefd3a8bb1b4d61cb946ccda0854041181c3fb')
+sha512sums_x86_64=("${_sha512sum}")
+
+pkgver() {
+ print "$_pkgver"
+}
+
+package() {
+ # Create directories
+ msg2 "Creating directory structure..."
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share/applications
+ mkdir -p "$pkgdir"/usr/share/icons/hicolor/128x128/apps
+ mkdir -p "$pkgdir"/opt
+
+ msg2 "Moving stuff in place..."
+ # Install
+ cp -r firefox/ "$pkgdir"/opt/$_pkgname
+
+ # /usr/bin symlinks
+ ln -s /opt/$_pkgname/firefox "$pkgdir"/usr/bin/$_name
+ ln -s /opt/$_pkgname/firefox "$pkgdir"/usr/bin/$pkgname
+
+ # Desktops
+ install -m644 *.desktop "$pkgdir"/usr/share/applications/
+
+ # Icons
+ for i in 16x16 32x32 48x48; do
+ install -d "$pkgdir"/usr/share/icons/hicolor/$i/apps/
+ ln -s /opt/$_pkgname/browser/chrome/icons/default/default${i/x*}.png \
+ "$pkgdir"/usr/share/icons/hicolor/$i/apps/$_name.png
+ done
+
+ # 128x128
+ ln -s /opt/$_pkgname/browser/icons/mozicon128.png \
+ "$pkgdir"/usr/share/icons/hicolor/128x128/apps/$_name.png
+}
diff --git a/firefox-unbranded-bin-safe.desktop b/firefox-unbranded-bin-safe.desktop
new file mode 100644
index 000000000000..538e61aef533
--- /dev/null
+++ b/firefox-unbranded-bin-safe.desktop
@@ -0,0 +1,25 @@
+[Desktop Entry]
+Name=Firefox Unbranded - Safe Mode
+GenericName=Web Browser - Safe Mode
+Comment=Browse the World Wide Web in Safe Mode
+Exec=firefox -safe-mode %u
+Terminal=false
+Type=Application
+Icon=firefox
+Categories=Network;WebBrowser;
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;
+StartupNotify=false
+StartupWMClass=Firefox-Safe
+Actions=NewTab;NewWindow;NewPrivateWindow;
+
+[Desktop Action NewTab]
+Name=Open new tab
+Exec=firefox -safe-mode -new-tab about:newtab
+
+[Desktop Action NewWindow]
+Name=Open new window
+Exec=firefox -safe-mode -new-window
+
+[Desktop Action NewPrivateWindow]
+Name=New private window
+Exec=firefox -safe-mode -private-window
diff --git a/firefox-unbranded-bin.desktop b/firefox-unbranded-bin.desktop
new file mode 100644
index 000000000000..e28c2fb41af0
--- /dev/null
+++ b/firefox-unbranded-bin.desktop
@@ -0,0 +1,25 @@
+[Desktop Entry]
+Name=Firefox Unbranded
+GenericName=Web Browser
+Comment=Browse the World Wide Web
+Exec=firefox %u
+Terminal=false
+Type=Application
+Icon=firefox
+Categories=Network;WebBrowser;
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;
+StartupNotify=false
+StartupWMClass=Firefox
+Actions=NewTab;NewWindow;NewPrivateWindow;
+
+[Desktop Action NewTab]
+Name=Open new tab
+Exec=firefox -new-tab about:newtab
+
+[Desktop Action NewWindow]
+Name=Open new window
+Exec=firefox -new-window
+
+[Desktop Action NewPrivateWindow]
+Name=New private window
+Exec=firefox -private-window
diff --git a/firefox-unbranded-bin.install b/firefox-unbranded-bin.install
new file mode 100644
index 000000000000..4268f4450670
--- /dev/null
+++ b/firefox-unbranded-bin.install
@@ -0,0 +1,17 @@
+note() {
+ printf "${blue}==>${yellow} NOTE$1:${bold} $2${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note 1 "This package replaces regular firefox."
+ note 2 "Valid launchers are: 'firefox' and 'firefox-unbranded-bin'."
+}
+
+post_upgrade() {
+ post_install
+}