summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD46
-rw-r--r--no-crmf.diff15
3 files changed, 16 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f38a5c88e30..4ee8c77efea8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-wayland
pkgdesc = Standalone web browser from mozilla.org with Wayland support enabled
- pkgver = 59.0.2
+ pkgver = 62.0
pkgrel = 1
url = https://www.mozilla.org/firefox/
arch = x86_64
@@ -24,6 +24,7 @@ pkgbase = firefox-wayland
makedepends = llvm
makedepends = jack
makedepends = gtk2
+ makedepends = python
depends = gtk3
depends = mozilla-common
depends = libxt
@@ -32,7 +33,7 @@ pkgbase = firefox-wayland
depends = dbus-glib
depends = ffmpeg
depends = nss
- depends = hunspell
+ depends = hunspell-en_US
depends = sqlite
depends = ttf-font
depends = libpulse
@@ -47,14 +48,12 @@ pkgbase = firefox-wayland
options = !emptydirs
options = !makeflags
options = !strip
- source = hg+https://hg.mozilla.org/mozilla-unified#tag=FIREFOX_59_0_2_RELEASE
+ source = hg+https://hg.mozilla.org/mozilla-unified#tag=FIREFOX_62_0_RELEASE
source = firefox.desktop
source = firefox-symbolic.svg
- source = no-crmf.diff
sha256sums = SKIP
sha256sums = 677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a
sha256sums = 9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797
- sha256sums = 02000d185e647aa20ca336e595b4004bb29cdae9d8f317f90078bdcc7a36e873
pkgname = firefox-wayland
diff --git a/PKGBUILD b/PKGBUILD
index 910bbbe60d1a..f02a4b95ba1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Max Liebkies <mail@maxliebkies.de>
pkgname=firefox-wayland
-pkgver=59.0.2
+pkgver=62.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org with Wayland support enabled"
arch=(x86_64)
@@ -13,9 +13,9 @@ url="https://www.mozilla.org/firefox/"
provides=('firefox')
conflicts=('firefox')
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell sqlite ttf-font libpulse libvpx icu)
+ nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm jack gtk2)
+ autoconf2.13 rust mercurial clang llvm jack gtk2 python)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -23,12 +23,10 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
options=(!emptydirs !makeflags !strip)
_repo=https://hg.mozilla.org/mozilla-unified
source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
- firefox.desktop firefox-symbolic.svg
- no-crmf.diff)
+ firefox.desktop firefox-symbolic.svg)
sha256sums=('SKIP'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
- '9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- '02000d185e647aa20ca336e595b4004bb29cdae9d8f317f90078bdcc7a36e873')
+ '9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -43,14 +41,8 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() {
- mkdir -p path
- ln -sf /usr/bin/python2 path/python
-
cd mozilla-unified
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
- patch -Np1 -i ../no-crmf.diff
-
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@@ -59,9 +51,9 @@ ac_add_options --enable-application=browser
ac_add_options --prefix=/usr
ac_add_options --enable-release
-ac_add_options --enable-gold
-ac_add_options --enable-pie
-ac_add_options --enable-optimize="-O2"
+ac_add_options --enable-linker=gold
+ac_add_options --enable-hardening
+ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
# Branding
@@ -70,7 +62,6 @@ ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=org.archlinux
export MOZILLA_OFFICIAL=1
export MOZ_TELEMETRY_REPORTING=1
-export MOZ_ADDON_SIGNING=1
export MOZ_REQUIRE_SIGNING=1
# Keys
@@ -85,7 +76,6 @@ ac_add_options --with-system-jpeg
ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
-ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
@@ -104,15 +94,8 @@ END
build() {
cd mozilla-unified
- # _FORTIFY_SOURCE causes configure failures
- CPPFLAGS+=" -O2"
-
- export PATH="$srcdir/path:$PATH"
export MOZ_SOURCE_REPO="$_repo"
- # Do PGO
- #xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \
- # MOZ_PGO=1 ./mach build
./mach build
./mach buildsymbols
}
@@ -127,15 +110,15 @@ package() {
// Use LANG environment variable to choose locale
pref("intl.locale.requested", "");
+// Use system-provided dictionaries
+pref("spellchecker.dictionary_path", "/usr/share/hunspell");
+
// Disable default browser checking.
pref("browser.shell.checkDefaultBrowser", false);
// Don't disable our bundled extensions in the application directory
pref("extensions.autoDisableScopes", 11);
pref("extensions.shownSelectionUI", true);
-
-// Opt all of us into e10s, instead of just 50%
-pref("browser.tabs.remote.autostart", true);
END
_distini="$pkgdir/usr/lib/firefox/distribution/distribution.ini"
@@ -162,14 +145,9 @@ END
install -Dm644 ../firefox-symbolic.svg \
"$pkgdir/usr/share/icons/hicolor/symbolic/apps/firefox-symbolic.svg"
- install -Dm644 ../$pkgname.desktop \
+ install -Dm644 ../firefox.desktop \
"$pkgdir/usr/share/applications/firefox.desktop"
- # Use system-provided dictionaries
- rm -r "$pkgdir/usr/lib/firefox/dictionaries"
- ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/firefox/dictionaries"
- ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/firefox/hyphenation"
-
# Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/firefox" <<END
#!/bin/sh
diff --git a/no-crmf.diff b/no-crmf.diff
deleted file mode 100644
index 682ba3fc0fd2..000000000000
--- a/no-crmf.diff
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git i/old-configure.in w/old-configure.in
-index 12170a47568f..dbbaa0bc9194 100644
---- i/old-configure.in
-+++ w/old-configure.in
-@@ -1808,9 +1808,7 @@ if test -n "$_USE_SYSTEM_NSS"; then
- AM_PATH_NSS(3.35, [MOZ_SYSTEM_NSS=1], [AC_MSG_ERROR([you don't have NSS installed or your version is too old])])
- fi
-
--if test -n "$MOZ_SYSTEM_NSS"; then
-- NSS_LIBS="$NSS_LIBS -lcrmf"
--else
-+if test -z "$MOZ_SYSTEM_NSS"; then
- NSS_CFLAGS="-I${DIST}/include/nss"
- case "${OS_ARCH}" in
- # Only few platforms have been tested with GYP