summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD48
-rw-r--r--firefox.desktop (renamed from firefox56.desktop)0
-rw-r--r--remove-shield.patch137
4 files changed, 168 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6dc29955006..a49e9be7fd89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -42,6 +42,7 @@ pkgbase = firefox56
optdepends = pulseaudio: Audio support
optdepends = speech-dispatcher: Text-to-Speech
provides = firefox
+ conflicts = firefox
options = !emptydirs
options = !makeflags
options = !strip
@@ -52,9 +53,10 @@ pkgbase = firefox56
source = no-plt.diff
source = plugin-crash.diff
source = glibc-2.26-fix.diff
- source = firefox56.desktop
+ source = firefox.desktop
source = firefox-symbolic.svg
source = firefox-install-dir.patch
+ source = remove-shield.patch
sha256sums = SKIP
sha256sums = f068b84ad31556095145d8fefc012dd3d1458948533ed3fff6cbc7250b6e73ed
sha256sums = e98a3453d803cc7ddcb81a7dc83f883230dd8591bdf936fc5a868428979ed1f1
@@ -65,6 +67,7 @@ pkgbase = firefox56
sha256sums = ada313750e6fb14558b37c764409a17c1672a351a46c73b350aa1fe4ea9220ef
sha256sums = a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9
sha256sums = d86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd
+ sha256sums = 1d833f76286f38360ebe142ac1a81e71ac45586ed6991701227f207cf1c80ac1
pkgname = firefox56
diff --git a/PKGBUILD b/PKGBUILD
index eecaaa8e4917..90e3a12d4c8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,10 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
+basepkg=firefox
pkgname=firefox56
provides=('firefox')
+conflicts=('firefox')
pkgver=56.0.2
pkgrel=1
pkgdesc="Old version of the standalone web browser from mozilla.org"
@@ -26,7 +28,7 @@ source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
wifi-disentangle.patch wifi-fix-interface.patch
0001-Bug-1384062-Make-SystemResourceMonitor.stop-more-res.patch
no-plt.diff plugin-crash.diff glibc-2.26-fix.diff
- $pkgname.desktop firefox-symbolic.svg firefox-install-dir.patch)
+ $basepkg.desktop firefox-symbolic.svg firefox-install-dir.patch remove-shield.patch)
sha256sums=('SKIP'
'f068b84ad31556095145d8fefc012dd3d1458948533ed3fff6cbc7250b6e73ed'
'e98a3453d803cc7ddcb81a7dc83f883230dd8591bdf936fc5a868428979ed1f1'
@@ -36,7 +38,8 @@ sha256sums=('SKIP'
'cd7ff441da66a287f8712e60cdc9e216c30355d521051e2eaae28a66d81915e8'
'ada313750e6fb14558b37c764409a17c1672a351a46c73b350aa1fe4ea9220ef'
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
- 'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd')
+ 'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
+ '1d833f76286f38360ebe142ac1a81e71ac45586ed6991701227f207cf1c80ac1')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -74,6 +77,9 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1394149
patch -Np1 -i ../glibc-2.26-fix.diff
+ # Disable mozilla shield (annoying telemetry that displays your browser is out of date)
+ patch -Np1 -i ../remove-shield.patch
+
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@@ -137,7 +143,7 @@ package() {
DESTDIR="$pkgdir" ./mach install
find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +
- _vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
+ _vendorjs="$pkgdir/usr/lib/$basepkg/browser/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END
// Use LANG environment variable to choose locale
pref("intl.locale.matchOS", true);
@@ -153,7 +159,7 @@ pref("extensions.shownSelectionUI", true);
pref("browser.tabs.remote.autostart", true);
END
- _distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
+ _distini="$pkgdir/usr/lib/$basepkg/distribution/distribution.ini"
install -Dm644 /dev/stdin "$_distini" <<END
[Global]
id=archlinux
@@ -162,45 +168,45 @@ about=Mozilla Firefox for Arch Linux
[Preferences]
app.distributor=archlinux
-app.distributor.channel=$pkgname
+app.distributor.channel=$basepkg
app.partner.archlinux=archlinux
END
for i in 16 22 24 32 48 256; do
install -Dm644 browser/branding/official/default$i.png \
- "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
+ "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$basepkg.png"
done
install -Dm644 browser/branding/official/content/icon64.png \
- "$pkgdir/usr/share/icons/hicolor/64x64/apps/$pkgname.png"
+ "$pkgdir/usr/share/icons/hicolor/64x64/apps/$basepkg.png"
install -Dm644 browser/branding/official/mozicon128.png \
- "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
+ "$pkgdir/usr/share/icons/hicolor/128x128/apps/$basepkg.png"
install -Dm644 browser/branding/official/content/about-logo.png \
- "$pkgdir/usr/share/icons/hicolor/192x192/apps/$pkgname.png"
+ "$pkgdir/usr/share/icons/hicolor/192x192/apps/$basepkg.png"
install -Dm644 browser/branding/official/content/about-logo@2x.png \
- "$pkgdir/usr/share/icons/hicolor/384x384/apps/$pkgname.png"
+ "$pkgdir/usr/share/icons/hicolor/384x384/apps/$basepkg.png"
install -Dm644 ../firefox-symbolic.svg \
- "$pkgdir/usr/share/icons/hicolor/symbolic/apps/$pkgname-symbolic.svg"
+ "$pkgdir/usr/share/icons/hicolor/symbolic/apps/$basepkg-symbolic.svg"
- install -Dm644 ../$pkgname.desktop \
- "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 ../$basepkg.desktop \
+ "$pkgdir/usr/share/applications/$basepkg.desktop"
# Use system-provided dictionaries
- rm -r "$pkgdir"/usr/lib/$pkgname/dictionaries
- ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
+ rm -r "$pkgdir"/usr/lib/$basepkg/dictionaries
+ ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$basepkg/dictionaries"
+ ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$basepkg/hyphenation"
# Install a wrapper to avoid confusion about binary path
- install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
+ install -Dm755 /dev/stdin "$pkgdir/usr/bin/$basepkg" <<END
#!/bin/sh
-exec /usr/lib/$pkgname/firefox "\$@"
+exec /usr/lib/$basepkg/firefox "\$@"
END
# Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -srf "$pkgdir/usr/bin/$pkgname" \
- "$pkgdir/usr/lib/$pkgname/firefox-bin"
+ ln -srf "$pkgdir/usr/bin/$basepkg" \
+ "$pkgdir/usr/lib/$basepkg/firefox-bin"
# Use system certificates
ln -srf "$pkgdir/usr/lib/libnssckbi.so" \
- "$pkgdir/usr/lib/$pkgname/libnssckbi.so"
+ "$pkgdir/usr/lib/$basepkg/libnssckbi.so"
}
diff --git a/firefox56.desktop b/firefox.desktop
index 2014e9ecfba9..2014e9ecfba9 100644
--- a/firefox56.desktop
+++ b/firefox.desktop
diff --git a/remove-shield.patch b/remove-shield.patch
new file mode 100644
index 000000000000..e4423f64b9da
--- /dev/null
+++ b/remove-shield.patch
@@ -0,0 +1,137 @@
+diff -crB mozilla-unified_A/browser/base/content/test/static/browser_all_files_referenced.js mozilla-unified_B/browser/base/content/test/static/browser_all_files_referenced.js
+*** mozilla-unified_A/browser/base/content/test/static/browser_all_files_referenced.js Sat Jan 6 20:54:57 2018
+--- mozilla-unified_B/browser/base/content/test/static/browser_all_files_referenced.js Sat Jan 6 21:31:54 2018
+***************
+*** 18,27 ****
+ "resource://app/defaults/preferences/",
+ "resource://gre/modules/commonjs/",
+ "resource://gre/defaults/pref/",
+- "resource://shield-recipe-client/node_modules/jexl/lib/",
+
+- // https://github.com/mozilla/normandy/issues/577
+- "resource://shield-recipe-client/test/",
+
+ // https://github.com/mozilla/activity-stream/issues/3053
+ "resource://activity-stream/data/content/tippytop/images/",
+--- 18,24 ----
+***************
+*** 118,126 ****
+ // browser/extensions/pdfjs/content/web/viewer.js#7450
+ {file: "resource://pdf.js/web/debugger.js"},
+
+- // These are used in content processes. They are actually referenced.
+- {file: "resource://shield-recipe-client-content/shield-content-frame.js"},
+- {file: "resource://shield-recipe-client-content/shield-content-process.js"},
+
+ // Starting from here, files in the whitelist are bugs that need fixing.
+ // Bug 1339420
+--- 115,120 ----
+diff -crB mozilla-unified_A/browser/extensions/moz.build mozilla-unified_B/browser/extensions/moz.build
+*** mozilla-unified_A/browser/extensions/moz.build Sat Jan 6 20:54:57 2018
+--- mozilla-unified_B/browser/extensions/moz.build Sat Jan 6 21:31:39 2018
+***************
+*** 15,21 ****
+ 'pdfjs',
+ 'pocket',
+ 'screenshots',
+- 'shield-recipe-client',
+ 'webcompat',
+ ]
+
+--- 15,20 ----
+Only in mozilla-unified_A/browser/extensions: shield-recipe-client
+diff -crB mozilla-unified_A/layout/tools/reftest/reftest-preferences.js mozilla-unified_B/layout/tools/reftest/reftest-preferences.js
+*** mozilla-unified_A/layout/tools/reftest/reftest-preferences.js Sat Jan 6 20:55:05 2018
+--- mozilla-unified_B/layout/tools/reftest/reftest-preferences.js Sat Jan 6 21:31:34 2018
+***************
+*** 63,70 ****
+ user_pref("browser.search.countryCode", "US");
+ user_pref("browser.search.geoSpecificDefaults", false);
+
+- // Make sure Shield doesn't hit the network.
+- user_pref("extensions.shield-recipe-client.api_url", "https://localhost/selfsupport-dummy/");
+
+ // use about:blank, not browser.startup.homepage
+ user_pref("browser.startup.page", 0);
+--- 63,68 ----
+diff -crB mozilla-unified_A/testing/profiles/prefs_general.js mozilla-unified_B/testing/profiles/prefs_general.js
+*** mozilla-unified_A/testing/profiles/prefs_general.js Sat Jan 6 20:55:08 2018
+--- mozilla-unified_B/testing/profiles/prefs_general.js Sat Jan 6 21:31:30 2018
+***************
+*** 321,328 ****
+ // This will prevent HTTP requests for region defaults.
+ user_pref("browser.search.geoSpecificDefaults", false);
+
+- // Make sure Shield doesn't hit the network.
+- user_pref("extensions.shield-recipe-client.api_url", "");
+
+ user_pref("media.eme.enabled", true);
+
+--- 321,326 ----
+diff -crB mozilla-unified_A/testing/runtimes/mochitest-browser-chrome-e10s.runtimes.json mozilla-unified_B/testing/runtimes/mochitest-browser-chrome-e10s.runtimes.json
+*** mozilla-unified_A/testing/runtimes/mochitest-browser-chrome-e10s.runtimes.json Sat Jan 6 20:55:08 2018
+--- mozilla-unified_B/testing/runtimes/mochitest-browser-chrome-e10s.runtimes.json Sat Jan 6 21:31:18 2018
+***************
+*** 603,609 ****
+ "browser/extensions/pdfjs/test/browser_pdfjs_navigation.js": 9323,
+ "browser/extensions/pdfjs/test/browser_pdfjs_views.js": 5701,
+ "browser/extensions/pdfjs/test/browser_pdfjs_zoom.js": 10608,
+- "browser/extensions/shield-recipe-client/test/browser_Heartbeat.js": 8542,
+ "browser/modules/test/browser_BrowserUITelemetry_buckets.js": 4394,
+ "browser/modules/test/browser_CaptivePortalWatcher.js": 17780,
+ "browser/modules/test/browser_ContentSearch.js": 6354,
+--- 603,608 ----
+diff -crB mozilla-unified_A/testing/runtimes/mochitest-browser-chrome.runtimes.json mozilla-unified_B/testing/runtimes/mochitest-browser-chrome.runtimes.json
+*** mozilla-unified_A/testing/runtimes/mochitest-browser-chrome.runtimes.json Sat Jan 6 20:55:08 2018
+--- mozilla-unified_B/testing/runtimes/mochitest-browser-chrome.runtimes.json Sat Jan 6 21:31:10 2018
+***************
+*** 577,583 ****
+ "browser/extensions/pdfjs/test/browser_pdfjs_views.js": 5372,
+ "browser/extensions/pdfjs/test/browser_pdfjs_zoom.js": 9760,
+ "browser/extensions/pocket/test/browser_pocket_ui_check.js": 2012,
+- "browser/extensions/shield-recipe-client/test/browser_Heartbeat.js": 7131,
+ "browser/modules/test/browser_BrowserUITelemetry_buckets.js": 4374,
+ "browser/modules/test/browser_CaptivePortalWatcher.js": 13616,
+ "browser/modules/test/browser_ContentSearch.js": 5221,
+--- 577,582 ----
+diff -crB mozilla-unified_A/testing/talos/talos/config.py mozilla-unified_B/testing/talos/talos/config.py
+*** mozilla-unified_A/testing/talos/talos/config.py Sat Jan 6 20:55:08 2018
+--- mozilla-unified_B/testing/talos/talos/config.py Sat Jan 6 21:30:52 2018
+***************
+*** 155,162 ****
+ 'media.gmp-manager.updateEnabled': False,
+ 'extensions.systemAddon.update.url':
+ 'http://127.0.0.1/dummy-system-addons.xml',
+- 'extensions.shield-recipe-client.api_url':
+- 'https://127.0.0.1/selfsupport-dummy/',
+ 'media.navigator.enabled': True,
+ 'media.peerconnection.enabled': True,
+ 'media.navigator.permission.disabled': True,
+--- 155,160 ----
+diff -crB mozilla-unified_A/testing/talos/talos/xtalos/xperf_whitelist.json mozilla-unified_B/testing/talos/talos/xtalos/xperf_whitelist.json
+*** mozilla-unified_A/testing/talos/talos/xtalos/xperf_whitelist.json Sat Jan 6 20:55:08 2018
+--- mozilla-unified_B/testing/talos/talos/xtalos/xperf_whitelist.json Sat Jan 6 21:30:58 2018
+***************
+*** 16,22 ****
+ "{firefox}\\browser\\features\\presentation@mozilla.org.xpi": {"mincount": 0, "maxcount": 100, "minbytes": 0, "maxbytes": 10000000},
+ "{firefox}\\browser\\features\\webcompat@mozilla.org.xpi": {"mincount": 0, "maxcount": 100, "minbytes": 0, "maxbytes": 10000000},
+ "{firefox}\\browser\\features\\webcompat-reporter@mozilla.org.xpi": {"mincount": 0, "maxcount": 100, "minbytes": 0, "maxbytes": 10000000},
+- "{firefox}\\browser\\features\\shield-recipe-client@mozilla.org.xpi": {"mincount": 0, "maxcount": 100, "minbytes": 0, "maxbytes": 10000000},
+ "{firefox}\\browser\\features\\activity-stream@mozilla.org.xpi": {"mincount": 0, "maxcount": 100, "minbytes": 0, "maxbytes": 10000000},
+ "{firefox}\\browser\\features\\screenshots@mozilla.org.xpi": {"mincount": 0, "maxcount": 100, "minbytes": 0, "maxbytes": 10000000},
+ "{firefox}\\browser\\features\\onboarding@mozilla.org.xpi": {"mincount": 0, "maxcount": 100, "minbytes": 0, "maxbytes": 10000000},
+--- 16,21 ----
+diff -crB mozilla-unified_A/testing/xpcshell/head.js mozilla-unified_B/testing/xpcshell/head.js
+*** mozilla-unified_A/testing/xpcshell/head.js Sat Jan 6 20:55:13 2018
+--- mozilla-unified_B/testing/xpcshell/head.js Sat Jan 6 21:30:46 2018
+***************
+*** 1539,1546 ****
+ prefs.setCharPref("media.gmp-manager.url.override", "http://%(server)s/dummy-gmp-manager.xml");
+ prefs.setCharPref("media.gmp-manager.updateEnabled", false);
+ prefs.setCharPref("extensions.systemAddon.update.url", "http://%(server)s/dummy-system-addons.xml");
+- prefs.setCharPref("extensions.shield-recipe-client.api_url",
+- "https://%(server)s/selfsupport-dummy/");
+ prefs.setCharPref("toolkit.telemetry.server", "https://%(server)s/telemetry-dummy");
+ prefs.setCharPref("browser.search.geoip.url", "https://%(server)s/geoip-dummy");
+ prefs.setCharPref("browser.safebrowsing.downloads.remote.url", "https://%(server)s/safebrowsing-dummy");
+--- 1539,1544 ----