summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9492bdd80615
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = firegrid
+ pkgdesc = Click anywhere with only 3 keystrokes
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/foliea/firegrid
+ arch = any
+ license = MIT
+ makedepends = wget,
+ makedepends = crystal
+ depends = noto-fonts,
+ depends = libx11,
+ depends = imagemagick,
+ depends = voidcsfml
+ source = https://github.com/foliea/firegrid/archive/0.1.1.tar.gz
+ md5sums = SKIP
+
+pkgname = firegrid
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fbf920a62001
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+f*.tar.gz
+firegrid-*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3b467feb84b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Adrien Folie <folie.adrien@gmail.com>
+pkgname=firegrid
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Click anywhere with only 3 keystrokes"
+arch=(any)
+url="https://github.com/foliea/firegrid"
+license=('MIT')
+depends=('noto-fonts', 'libx11', 'imagemagick', 'voidcsfml')
+makedepends=('wget', 'crystal')
+source=("https://github.com/foliea/firegrid/archive/$pkgver.tar.gz")
+md5sums=('SKIP')
+
+prepare() {
+ wget https://github.com/crystal-lang/crystal/releases/download/0.23.1/crystal-0.23.1-3-linux-x86_64.tar.gz
+ tar -xzvf crystal-0.23.1-3-linux-x86_64.tar.gz
+ export PATH="$PWD/crystal-0.23.1-3/bin:$PATH"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 "bin/$pkgname" "$pkgdir/usr/sbin/$pkgname"
+ install -Dm644 -d config "$pkgdir/etc/$pkgname"
+}