summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
-rw-r--r--firejail-pacman-hook.install15
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 648793806437..c1196b7990fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = firejail-pacman-hook
pkgdesc = Updates firejail symbolic links on pacman operations
pkgver = 1
- pkgrel = 1
+ pkgrel = 2
+ install = firejail-pacman-hook.install
arch = any
license = Unlicense
source = firejail.hook
diff --git a/PKGBUILD b/PKGBUILD
index 0ea5707c9bb7..70764d065b3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Carlos Marchal <marchal.carlos at pm dot me>
pkgname='firejail-pacman-hook'
pkgver=1
-pkgrel=1
-pkgdesc="Updates firejail symbolic links on pacman operations"
+pkgrel=2
+pkgdesc='Updates firejail symbolic links on pacman operations'
arch=('any')
license=('Unlicense')
-source=("firejail.hook")
+install='firejail-pacman-hook.install'
+source=('firejail.hook')
sha256sums=('42939e3f287d6ae3de20a73dcf29f785a132020111ff302f4fb110388a756baf')
package() {
diff --git a/firejail-pacman-hook.install b/firejail-pacman-hook.install
new file mode 100644
index 000000000000..ba32ccaec995
--- /dev/null
+++ b/firejail-pacman-hook.install
@@ -0,0 +1,15 @@
+post_install() {
+ cat << EOF
+ Don't forget to add the users for which you want desktop integration with:
+ "firecfg --add-users user [user]"
+ If you don't want to wait until the next trigger of this hook, run:
+ "firecfg"
+EOF
+}
+
+post_remove() {
+ cat << EOF
+ You may want to remove any existing links with:
+ "firecfg --clean"
+EOF
+}